You are not logged in.

IC2 Experimental builds (jenkins):
v2.0/2.1/2.2 / 2.3 / 2.5 / 2.6 (For Minecraft 1.6.4/1.7.2/1.7.10 / 1.8.9 / 1.9.4 / 1.10)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

1

Wednesday, March 11th 2015, 3:20am

Charging batteries

I finally started playing with the new charging batteries tonight and they seem pretty awesome -- no longer do you need to dedicate your armor chest slot to carrying energy to feed your mining drill / laser / other tools! However, it seems that they only will charge items in your hotbar, and not items in your main inventory ( not such a big deal ) or armor equiped in armor slots. So if you want to recharge your night vision goggles or your electric jetpack, you have to put them into your hotbar for a bit to recharge rather than just wear them normally. Is this intended? It would be *really* awesome if the charging energy crystal could continuously power your electric jetpack in your chest slot.

Chocohead

Drowning in mods.

  • "Chocohead" is male
  • Korea, Democratic People's Republic of United Kingdom

Posts: 5,983

Location: Badly generated chunks.

  • Send private message

2

Wednesday, March 11th 2015, 7:50am

It feels a lot like balance to only let them charge in your hotbar, otherwise you could just keep lapotron crystals in your inventory while fighting wearing a Q-Suit.
145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

I see this too much.

3

Wednesday, May 6th 2015, 10:00am

the charging battery also seems to recharge thigns slower then a batpack at times.. where i could use the wrench many times in a row it would recharge instantly if it needed to the charger is slower buy alot at times...

And i understand this has to be in the inventory the charger does not need to be on the hotbar?

MauveCloud

Coal Miner

  • "MauveCloud" is male

Posts: 1,048

Location: California

  • Send private message

4

Wednesday, May 20th 2015, 4:57am

I've had a charging energy crystal work from the inventory (the item to be charged has to be in the hotbar, but the charger does not), but it doesn't work so well now (the crystal says it has 3.85M EU, but my mining laser in the hotbar has been stuck at 2.06k EU for several minutes, and that apparently isn't enough for one shot in horizontal mode) - I'm wondering if exiting and relaunching my single-player game messed it up. It seemed to work better shortly after I crafted it.

5

Wednesday, May 20th 2015, 10:31am

Make sure it's in"enabled" mode. (Tooltip)
Check out my mods here.

MauveCloud

Coal Miner

  • "MauveCloud" is male

Posts: 1,048

Location: California

  • Send private message

6

Wednesday, May 20th 2015, 3:37pm

Make sure it's in"enabled" mode. (Tooltip)


Apparently it was disabled, though I'm fairly sure I hadn't deliberately deactivated it. It took me a few tries, but I figured out how to enable it ("ALT Key" + "Use Item"). What conditions can cause it to become disabled? (aside from manually setting it to disabled)

7

Wednesday, May 20th 2015, 5:16pm

Apparently it was disabled, though I'm fairly sure I hadn't deliberately deactivated it. It took me a few tries, but I figured out how to enable it ("ALT Key" + "Use Item"). What conditions can cause it to become disabled? (aside from manually setting it to disabled)
You probably accidentally right-clicked it, because you don't need to press the ALT key. It's enough to just right-click it.
Check out my mods here.

MauveCloud

Coal Miner

  • "MauveCloud" is male

Posts: 1,048

Location: California

  • Send private message

8

Wednesday, May 20th 2015, 5:39pm

Actually, it seems a bit inconsistent about that. A few times when I moved it out of my hotbar and into my main inventory (shortly before posting my previous reply), it was disabled when I checked a moment later. Just now, I had trouble getting it disabled either with or without the alt key, then suddenly disabling and enabling worked without the alt key. Also, it seemed like having no other electrical items in my inventory caused it to automatically disable itself (even before moving it out of the hotbar).