You are not logged in.

IC2 Experimental builds (jenkins):
v2.0/2.1/2.2 / 2.3 / 2.5 / 2.6 (For Minecraft 1.6.4/1.7.2/1.7.10 / 1.8.9 / 1.9.4 / 1.10)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

Dear visitor, welcome to IC² Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

unknown zombie

Tree Cutter

  • "unknown zombie" is male

Posts: 13

Location: Florida

  • Send private message

21

Thursday, August 14th 2014, 7:15am

Player, you have really worked some miracles with this code here. I don't know how you did it but this mod has single-handedly prevented me from having to altogether skip the 1.7.10 generation of mods.

The chunk loading lag in 1.7.10 was completely unbearable. I basically had to start Minecraft and then alt-tab to another program for 10 minutes. The whole time Minecraft was just frozen solid and filling my log with chunk ticking errors.

This mod completely solved that issue. Thank you so very much for your effort in making it!

Queue

CQI Co-founder

  • "Queue" is male

Posts: 567

Location: I honestly don't know.

  • Send private message

22

Thursday, August 14th 2014, 5:52pm

Player, I talked to ProfMobius, and EVOC is in the works for 1.7.10, but he was very interested in what you had going, maybe you could chat with him.


23

Friday, August 15th 2014, 7:57am

Gotta say thanks for this, it has done wonders for my personal pack. I was starting to get disheartened about 1.7.10 as it was just about unplayable with any number of mods causing crazy lag during chunk gen.

While I still get occasional spikes while generating new chunks, the game feels a TON smoother and removes a ton of frustration.

24

Saturday, August 16th 2014, 11:52pm

This mod sounds amazing, i am very tempted to install it and test it (although you said you don't want inexperienced users installing it soo... im not sure in which category i fall into). I think i will give it a try at least to see the chunk generation speed and make some stress tests.

Chocohead

Drowning in mods.

  • "Chocohead" is male
  • Korea, Democratic People's Republic of United Kingdom

Posts: 5,978

Location: Badly generated chunks.

  • Send private message

25

Sunday, August 17th 2014, 12:14am

Just people testing/using it is good, since any of the issues that could arise are more likely to be found the more people that use it. At least that's how I see it.
145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


---- Minecraft Crash Report ----
// I just don't know what went wrong :(

I see this too much.

SpwnX

IC² Creative Content Inventor, GT Public Relations Manager and your lovely forum moderator

  • "SpwnX" is male
  • Brazil

Posts: 8,359

Location: Nowhere to be found, unless I know you

  • Send private message

26

Sunday, August 17th 2014, 12:31am

By inexperienced users he means modpack users, aka the ones that dont know how to install a single mod on their own.
If you are able to install forge, IC2, and all those mods without help of 3rd party, you are not inexperienced.
We need people to document GregTech, help us by joining the FTB wiki team: http://ftb.gamepedia.com/GregTech_6

27

Sunday, August 17th 2014, 12:49am

ok guess then im very experienced :D i have made packs of more than 100 mods in the past, resolving all the id conflicts and such, tho i still consider myself kinda newb :D

SpwnX

IC² Creative Content Inventor, GT Public Relations Manager and your lovely forum moderator

  • "SpwnX" is male
  • Brazil

Posts: 8,359

Location: Nowhere to be found, unless I know you

  • Send private message

28

Sunday, August 17th 2014, 2:00am

A few crashes after installing fastcraft:
SpwnX has attached the following files:
We need people to document GregTech, help us by joining the FTB wiki team: http://ftb.gamepedia.com/GregTech_6

29

Sunday, August 17th 2014, 2:53am

This is a log of a new loading world that crashed http://openeye.openmods.info/crashes/529…c9f331437617576

And this is the log for the whole minecraft load and such (in case you need it) http://paste.atlauncher.com/view/f33484fe

SpwnX

IC² Creative Content Inventor, GT Public Relations Manager and your lovely forum moderator

  • "SpwnX" is male
  • Brazil

Posts: 8,359

Location: Nowhere to be found, unless I know you

  • Send private message

30

Sunday, August 17th 2014, 4:48am

Debug crashlog as requested.
SpwnX has attached the following file:
We need people to document GregTech, help us by joining the FTB wiki team: http://ftb.gamepedia.com/GregTech_6

SpwnX

IC² Creative Content Inventor, GT Public Relations Manager and your lovely forum moderator

  • "SpwnX" is male
  • Brazil

Posts: 8,359

Location: Nowhere to be found, unless I know you

  • Send private message

31

Sunday, August 17th 2014, 6:25am

More logs:
SpwnX has attached the following files:
We need people to document GregTech, help us by joining the FTB wiki team: http://ftb.gamepedia.com/GregTech_6

32

Monday, August 18th 2014, 2:40am

Version 1.4 is out, hopefully fixing your crashes.

Edit: not quite, 1.5 is on the way ;)

33

Monday, August 18th 2014, 9:30am

Hello ! I install your mod just with forge, a minimap and optifine.
Does this mod is "affected" by optifine ? (Do I need to remove optifine, or not change the config of it, actually I change the chunk loading thing in it on "smooth").

BTW thanks for your mod !

34

Monday, August 18th 2014, 2:10pm

First at all, amazing piece of code you wrote Player.
FastCraft is working perfect when starting the server with Forge, but if i use it with Cauldron (170 or lower it doesnt matter) i'm getting a Crash.

Here's the log.

Spoiler Spoiler


Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
OS is 64
Adding Accesstransformer map: CoFH_at.cfg

A problem occurred running the Server launcher.java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.run(ServerLaunchWrapper.java:43)
        at cpw.mods.fml.relauncher.ServerLaunchWrapper.main(ServerLaunchWrapper.java:12)

Caused by: java.lang.NoClassDefFoundError: net/minecraft/entity/player/EntityPlayer
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Unknown Source)
        at java.lang.Class.getMethod0(Unknown Source)
        at java.lang.Class.getMethod(Unknown Source)
        at net.minecraft.launchwrapper.Launch.launch(Launch.java:131)
        at net.minecraft.launchwrapper.Launch.main(Launch.java:28)
        ... 6 more

Caused by: java.lang.ClassNotFoundException: net.minecraft.entity.player.EntityPlayer
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 12 more

Caused by: java.lang.NoClassDefFoundError: net/minecraft/entity/EntityLivingBase

        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:180)
        ... 14 more

Caused by: java.lang.ClassNotFoundException: net.minecraft.entity.EntityLivingBase
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 18 more

Caused by: java.lang.NoClassDefFoundError: net/minecraft/entity/Entity
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:180)
        ... 20 more

Caused by: java.lang.ClassNotFoundException: net.minecraft.entity.Entity
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:188)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        ... 24 more

Caused by: java.lang.RuntimeException: asm error net.minecraft.entity.Entity [V'
ELacO0FD2ZUG[V*LBWH$:8:c?4ab;_Db6M`cO.[; dr ;`'E3aKCI[36L7c=F'b]/^c$-#(WaS<#-Gc?
%bc[BbG 0 1
        at fastcraft.asm.FastCraftTransformer.transform(Unknown Source)
        at net.minecraft.launchwrapper.LaunchClassLoader.runTransformers(LaunchClassLoader.java:276)
        at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:174)
        ... 26 more

Presione una tecla para continuar . . .



Keep up the great work!!
hditano has attached the following files:
  • server-latest.txt (3.36 kB - 413 times downloaded - latest: Mar 22nd 2017, 1:01pm)
  • latest.log (5.13 kB - 168 times downloaded - latest: Yesterday, 8:37pm)

This post has been edited 1 times, last edit by "hditano" (Aug 18th 2014, 2:17pm) with the following reason: Added Logs


35

Monday, August 18th 2014, 5:25pm

That's due to some code differences in MCPC, I've added the startup option -Dfastcraft.asm.permissive (has to be before -jar) which disables hook insertion validation, which is fine for the case you had. It requires some extra care in regards of backups and testing however.

36

Monday, August 18th 2014, 5:53pm

As everyone else has said, this is quite a piece of work. Really helped me so far.

As for the Cauldron issue, is there a way to get this to work on a dedicated server? Most hosts will not allow you to add startup options.
I maintain the DNS Techpack, found on the AT Launcher. You can find me on Twitter @IAmOmicron or on Discord with the same alias.

37

Monday, August 18th 2014, 6:41pm

That's due to some code differences in MCPC, I've added the startup option -Dfastcraft.asm.permissive (has to be before -jar) which disables hook insertion validation, which is fine for the case you had. It requires some extra care in regards of backups and testing however.


Sadly i'm still getting an error when loading a world.

This is using

cauldron-1.7.10-1.1206.01.170-server
ForgeMultipart-1.7.10-1.1.0.297-universal

java -Xmx%mem% -XX:MaxPermSize=256M -Dfastcraft.asm.permissive -jar cauldron-1.7.10-1.1206.01.170-server.jar nogui


Second Crash File..happened while starting up the server
hditano has attached the following files:

This post has been edited 2 times, last edit by "hditano" (Aug 18th 2014, 6:55pm)


38

Monday, August 18th 2014, 9:37pm

Ah great, they are using other field names as well. This means that MCPC won't work until I add explicit support.

Edit: That obviously doesn't mean that it can't be used on the client, FastCraft should work client only, server only, both or even both with mismatched versions.

39

Tuesday, August 19th 2014, 11:40pm

Not sure if you still interested on Crash Logs...after updating Cauldron i'm getting this one
hditano has attached the following file:

40

Sunday, August 24th 2014, 1:38am

I tried installing this today with Bevo's Tech Pack and for some reason it made things much worse. I normally can get about 10-15 FPS without Optifine. I installed this, and couldn't get over 3 FPS. Am I doing something wrong? Is there a configuration somewhere that I need to tweak?

Edit: Ok, so it wasn't the mod causing the issues. The server updated and something in the new version of BTP is causing the frame rate issues. I'll track that down first.

This post has been edited 1 times, last edit by "Davkas2005" (Aug 24th 2014, 1:46am)


Counter:

Hits today: 74,492 | Hits yesterday: 42,089 | Hits record: 152,331 | Hits total: 65,083,890