You are not logged in.

IC2 Experimental builds (jenkins):
v2.0/2.1/2.2 / 2.3 / 2.5 / 2.6 (For Minecraft 1.6.4/1.7.2/1.7.10 / 1.8.9 / 1.9.4 / 1.10)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

Dear visitor, welcome to IC² Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

ethanbmnz

FastCraft Modpack Usage Notifier

  • "ethanbmnz" is male
  • Send private message

861

Tuesday, July 7th 2015, 8:01am

Hi Player

I am going to use FastCraft in my FTB modpack, PeplzTech

Thank you.

862

Wednesday, July 8th 2015, 5:14pm

Hello, I am going to be using fastcraft in my FTB modpack called B-Bunny Modpack. Thanks.

863

Wednesday, July 8th 2015, 10:08pm

Modpack

I am going to use your mod in my modpack, ImmersiveCraft. It is a pack on the FTB launcher with a pack code (semi-public) and i will use the whole

(This pack contains <a color="aqua" href="[WIP|1.7.10] FastCraft 1.21">Fastcraft</a>, by Player, enabled by default. Fastcraft enhances Minecraft with increased performance. Bug reports being made directly to Mod Authors should state Fastcraft is enabled.)


thing. I saw on the FTB packsite (http://forum.feed-the-beast.com/threads/…idelines.18250/) that i needed to notify you.
-Hjuju

864

Wednesday, July 8th 2015, 10:10pm

Hello, i am going to use FastCraft in a FTB pack called ImmersiveCraft. Thanks!

865

Thursday, July 9th 2015, 4:23pm

We will be using Fastcraft in the public pack Crundee Craft on ATLauncher :)

866

Friday, July 10th 2015, 6:30pm

Hello Player,

I will be using FastCraft in a public modpack called Nuclear Fallout.

867

Monday, July 13th 2015, 8:42pm

Hello Player,

I am a secondary updater for the FTB 3rd party pack called Mongoose Labs and would like to let you know that Fastcraft will be included in the modpack.

868

Tuesday, July 14th 2015, 5:35pm

Quite some responses after being busy with Minecon and bug fixes..

lil_kreen: Constant heap usage fluctuations are normal for Java, 300 MB doesn't sound too bad and the way it's being handled internally is quite efficient. The usual cause for slow/stalled chunk updating is that a nearby chunk gets updated frequently mostly through broken mod code. Said nearby updating chunk "steals" the update time slow for the distant ones. Chunks not in view range also receive rather low priority. You can control the amount of time available for chunk updates through the max fps setting, lower fps limit = more time for updates. The metrics you posted look quite normal, although I'd expect the terrain part to be lower with FC 1.22. You may want to try the async culling option in the FC 1.22 config for slightly better performance.

MaouKami: That's quite well reprducable indeed, I'll see about adding said debugging functionality.

SpwnX: I believe I fixed a very related problem, so that's to be tested in the next build.

nicholasiv: That's fine.

Bogdan-G: Hmm the stall reports aren't overly conclusive, I'll investigate later.

Questwizard: 1.8 runs chunks updates in different threads, which works around most of the problem, but also most updates are from broken mod code, which just doesn't exist in 1.8 yet. In 1.7 all nearby block updates get processed instantly at the start of a frame, covering all block changes during the previous frame. I'll add some more logic to optionally reduce its impact at the cost of not updating right away. If 1.8 doesn't normally render nearby updates right away I'd consider that a bug... Distant updates are throttled in both versions.

Xyain_Jyrain: Sponge mixin support is broken right now, but it should be fixed for the next build.

jochuan: This crash is LWJGL's fault, I'll look into fixing what triggers it though.

869

Thursday, July 16th 2015, 2:12am

Hello, this is to notify you that we will be using your mod in our servers modpack for DeVcoFTB

870

Thursday, July 16th 2015, 2:21pm

MaouKami: That's quite well reprducable indeed, I'll see about adding said debugging functionality.
Yeah, still having this problem, have no clue where its coming from, but do know its not fastcraft, ran it without i simply get the same message,
But without the 2 strings about fastcraft, but if you still think you can add a debug function so i can find what is causing it, that would be awesome.

Starting to get more and more problems atm haha, just had to add another 2gb to the server counting up to 10gb total, cause on startup its now using 5gb.
And within a few hours reached 8gb, while nothing has changed server-wise, and found no good tool to locate the spot, or mod that is causing this.

You would think it are loaded chunks but nope, not that many chunks loaded, even lowered the chunk loading limit.
But thats something all together :p.

Nick_77ab2

Tree Cutter

  • "Nick_77ab2" is male

Posts: 72

Location: HOGWARTS BITCH!

  • Send private message

871

Friday, July 17th 2015, 2:27am

MaouKami: That's quite well reprducable indeed, I'll see about adding said debugging functionality.
Yeah, still having this problem, have no clue where its coming from, but do know its not fastcraft, ran it without i simply get the same message,
But without the 2 strings about fastcraft, but if you still think you can add a debug function so i can find what is causing it, that would be awesome.

Starting to get more and more problems atm haha, just had to add another 2gb to the server counting up to 10gb total, cause on startup its now using 5gb.
And within a few hours reached 8gb, while nothing has changed server-wise, and found no good tool to locate the spot, or mod that is causing this.

You would think it are loaded chunks but nope, not that many chunks loaded, even lowered the chunk loading limit.
But thats something all together :p.

maybe i can help, what mods are you using?

872

Friday, July 17th 2015, 11:32am

MaouKami: That's quite well reprducable indeed, I'll see about adding said debugging functionality.
Yeah, still having this problem, have no clue where its coming from, but do know its not fastcraft, ran it without i simply get the same message,
But without the 2 strings about fastcraft, but if you still think you can add a debug function so i can find what is causing it, that would be awesome.

Starting to get more and more problems atm haha, just had to add another 2gb to the server counting up to 10gb total, cause on startup its now using 5gb.
And within a few hours reached 8gb, while nothing has changed server-wise, and found no good tool to locate the spot, or mod that is causing this.

You would think it are loaded chunks but nope, not that many chunks loaded, even lowered the chunk loading limit.
But thats something all together :p.

maybe i can help, what mods are you using?
using the ftb infinity 1.7 modpack, added to that forgeessentials, fastcraft updated, betterfps,stackie, specialai, just removed opis i was using it for finding cause of cpu but cpu is fine now kind off.

edit: great.. cpu usage is often at max now, and server is complaining about skipping ticks, but its flooding with the error msg as well so..

This post has been edited 1 times, last edit by "MaouKami" (Jul 17th 2015, 2:00pm)


873

Friday, July 17th 2015, 7:49pm

notify

I am letting you know that I am using your mod on a private 3rd party mod pack on the ftb launcher. Thank you

874

Saturday, July 18th 2015, 10:51am

notify
I am letting you know that I am using your mod on a private 3rd party mod pack called "Bamse Pack"on the ftb launcher. Thank you

875

Monday, July 20th 2015, 3:32pm

Use in Modpack

Hi there, I'll be using FastCraft in a public modpack called DRA - The Awakening. Thanks!

876

Wednesday, July 22nd 2015, 6:47am

Hello Player,

With this I would like to notify you that I plan to use your fastcraft mod in a FTB Unlisted Third Party Modpack called "Nationcraft"

877

Friday, July 24th 2015, 10:38pm

Crash from world generation using FastCraft 1.21

I don't usually ask for help diagnosing crash reports, but this one is beyond me. I am generating my world by flying around in a creative test world and it seems when I come across specific biomes, my client hangs for a few seconds then crashes.

Here is the crash report: http://pastebin.com/E5wVipEK

From what I can tell, every crash report seems to specifically mention the Magical Forest from Thaumcraft. The world gen mods I am using are as follows: RWG, Biomes O plenty, Underground Biomes Constructs and Thaumcraft.

I hope someone can point out the problem, thanks.

Edit: Forgot to mention, the crash still happens regardless if I am using the specific RWG world type or the default.

878

Saturday, July 25th 2015, 3:36am

Greetings Player, I have a small bug to report when using fastcraft 1.22ctest10 and Smart Moving. It seems that when I use the mods crouch feature to lower player height to one block, some strange visual glitches occur. This seems to only happen in certain areas or heights, but it makes no difference what is in the surrounding area.

Before crouching...



and after crouching...


879

Saturday, July 25th 2015, 5:44am

No 1.8 update for a year already!

I've seen what FastCraft can do on Vanilla 1.7.10. I think that it would benefit a lot of us if you make a 1.8 edition for Fastcraft for Vanilla 1.8 servers and clients!

880

Saturday, July 25th 2015, 6:35am

Hey Player,

I'd like to use Fastcraft in a private pack on the FTB launcher, called AfriCraft.

Thanks!

Counter:

Hits today: 1,971 | Hits yesterday: 29,849 | Hits record: 152,331 | Hits total: 65,265,335