You are not logged in.

IC2 Experimental builds (jenkins):
v2.0/2.1/2.2 / 2.3 / 2.5 / 2.6 (For Minecraft 1.6.4/1.7.2/1.7.10 / 1.8.9 / 1.9.4 / 1.10)
IndustrialCraft² recent version: v1.117! (For Minecraft 1.5.2 → topic)

Dear visitor, welcome to IC² Forum. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1,301

Monday, April 4th 2016, 11:27pm

New build: http://files.player.to/fastcraft-1.23.jar

It should fix compatibility with ruinsmod and named entities with invalid AABBs used for serverside banners. Turning off enableCullingTweaks doesn't crash anymore.

1,302

Tuesday, April 5th 2016, 2:24am

Hi, I'm planning on using your Fastcraft mod in my modpack, "Space Monkey"

1,303

Tuesday, April 5th 2016, 4:08am

New build: http://files.player.to/fastcraft-1.23.jar

It should fix compatibility with ruinsmod and named entities with invalid AABBs used for serverside banners. Turning off enableCullingTweaks doesn't crash anymore.
If you feel comfortable with it, mind pushing it to stable? Mod pack devs I am talking to say they will add it however it needs to be stable. They want to push the updates tmr/wed however will only add FC if its set to rec/stable.

1,304

Wednesday, April 6th 2016, 1:00am

1.23 does not appear to have fixed the issue with Ruinsmod. With nothing other than Fastcraft 1.23, Ruins and Forge 1558, the Command Blocks still fail to fire off. However, reverting to 1.18 or below still seems to resolve the issue.
If there's some way to try and debug the issue, I'd be more than happy to get a log to you. The debugging section in Fastcraft's .ini doesn't seem like it should track the Ruinsmod issue, but if I'm wrong, let me know.

1,305

Wednesday, April 6th 2016, 4:31am

The line containing "Mod detection results" from your fml-server-latest.log (or -client- for the client) would be interesting.

1,306

Wednesday, April 6th 2016, 11:46pm

This is the entire log from fastcraft-1.22-ctest18.jar, while in-game looks like this.
Corresponding line:

Spoiler Spoiler

[Client thread/INFO]: Attempting early MinecraftForge initialization
[17:24:25] [Client thread/INFO]: MinecraftForge v10.13.4.1566 Initialized
[17:24:25] [Client thread/INFO]: Replaced 183 ore recipies
[17:24:25] [Client thread/INFO]: Completed early MinecraftForge initialization
[17:24:25] [Client thread/INFO]: Found 0 mods from the command line. Injecting into mod discoverer
[17:24:25] [Client thread/INFO]: Searching C:\Games\Minecraft\MultiMC\instances\Ruins and Fastcraft Test\minecraft\mods for mods
[17:24:28] [Client thread/INFO]: Forge Mod Loader has identified 6 mods to load
[17:24:29] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, FastCraft, AS_Ruins, AS_UpdateCheck] at CLIENT
[17:24:29] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, FastCraft, AS_Ruins, AS_UpdateCheck] at SERVER


This is the entire log from fastcraft-1.23.jar, while in-game looks like this.
Corresponding line in this log:

Spoiler Spoiler

Attempting early MinecraftForge initialization
[17:34:40] [Client thread/INFO]: MinecraftForge v10.13.4.1566 Initialized
[17:34:41] [Client thread/INFO]: Replaced 183 ore recipies
[17:34:41] [Client thread/INFO]: Completed early MinecraftForge initialization
[17:34:41] [Client thread/INFO]: Found 0 mods from the command line. Injecting into mod discoverer
[17:34:41] [Client thread/INFO]: Searching C:\Games\Minecraft\MultiMC\instances\Ruins and Fastcraft Test\minecraft\mods for mods
[17:34:44] [Client thread/INFO]: Forge Mod Loader has identified 6 mods to load
[17:34:45] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, FastCraft, AS_Ruins, AS_UpdateCheck] at CLIENT
[17:34:45] [Client thread/INFO]: Attempting connection with missing mods [mcp, FML, Forge, FastCraft, AS_Ruins, AS_UpdateCheck] at SERVER


It looks as though the Command Block is being blocked from triggering, but I have no idea why.
If I'm remembering correctly, this particular structure is not in the original Ruinsmod. Could it possibly be the Command block's format or something?

1,307

Thursday, April 7th 2016, 12:36am

This is the wrong log file, I need the fml log or really just the one line I mentioned earlier. It contains all debug level log output, latest.log is only INFO and higher.

1,308

Thursday, April 7th 2016, 12:52am

1.23 does not appear to have fixed the issue with Ruinsmod. With nothing other than Fastcraft 1.23, Ruins and Forge 1558, the Command Blocks still fail to fire off. However, reverting to 1.18 or below still seems to resolve the issue.
If there's some way to try and debug the issue, I'd be more than happy to get a log to you. The debugging section in Fastcraft's .ini doesn't seem like it should track the Ruinsmod issue, but if I'm wrong, let me know.
UPDATE TO LATEST FORGE AND RUINS VERSION TO FIX IT! -> 1.7.10 - 10.13.4.1614

ATOMIC STRYKERS RUINS MOD! -> https://www.dropbox.com/s/z11c7hnrqjo9sy…-UNZIP.rar?dl=0 I packed it for you!


Please don't waste players time with issues like this!

This post has been edited 1 times, last edit by "P3rf3ct_Zer0" (Apr 7th 2016, 1:08am)


1,309

Thursday, April 7th 2016, 7:16am

Whoops, sorry about that. Wasn't thinking.

Relevant line in the 1.22-ctest18 file:

Spoiler Spoiler

[main/DEBUG] [FastCraft/]: Mod detection results: {Bukkit=false, ColoredLights=false, OptiFine=false, ShadersMod=false, DynamicLights=false, NotEnoughIds=false}


Relevant line in the 1.23 file:

Spoiler Spoiler

[main/DEBUG] [FastCraft/]: Mod detection results: {AsRuins=false, Bukkit=false, ColoredLights=false, OptiFine=false, ShadersMod=false, DynamicLights=false, NotEnoughIds=false}


I guess it's just not picking up that Ruins is active.

This post has been edited 3 times, last edit by "Ariannae" (Apr 7th 2016, 7:25am)


1,310

Thursday, April 7th 2016, 6:41pm

Yes, that'd be the problem. My mod testing code only really works for core mods, I'll think about a solution..

1,311

Wednesday, April 13th 2016, 9:55pm

Fastcraft 1.22 and 1.23 seem to crash a game when the Twilight Forest Naga dies with a ConcurrentModificationException.

As described http://www.minecraftforum.net/forums/map…k?comment=11601 and onward.

1,312

Thursday, April 14th 2016, 12:52pm

fastcraft crashes instantly http://pastebin.com/wJezZHFE

Quoted

http://pastebin.com/wJezZHFE

1,313

Thursday, April 14th 2016, 2:52pm

It crashes because the entity is removing itself from World.loadedEntityList while being rendered, which is not good on TF's side...

1,314

Sunday, April 17th 2016, 10:52am

Got a crash while walking around, dunno the cause through
http://pastebin.com/jUVKLjrh

1,315

Monday, April 18th 2016, 6:35am

Just letting you know that I am planning on using FastCraft in my public pack on the FTB launcher, many thanks for your hard work! c:

1,316

Wednesday, April 20th 2016, 10:06pm

Notification of Use

Just wanted to let you know that I am going to be putting FastCraft into the next ExileCraft modpack update on the FTB Launcher! Tested it out and it works like a charm! Fantastic mod!
Thanks for the hard work you put into making this mod!


ExiledOn3

1,317

Thursday, April 21st 2016, 9:19pm

Hi Player,

Just wanted to notify you that I will be using your mod FastCraft in the upcoming version of Tranquility B on the FTB Launcher!

1,318

Friday, April 22nd 2016, 4:58am

Could the Ruins incompatibility be cause by the fact that Fastcraft seems to check for ASRuins, but the mod call itself AS_Ruins?

1,319

Monday, April 25th 2016, 2:39am

Hi!

Running "/help" results in an error and the only mod mentioned in the error message is fastcraft.

I'm running a server with a custom private modpack which was, unfortunately, not assembled by me. So it is possible that something else in the pack or a faulty config is interfering. But I don't know and since as I already said it is the only mod mentioned in the error message, I wanted to ask here in case this is indeed caused by fastcraft.

Here's the error I get (as you can see I'm using fastcraft 1.22, but as far as I can see there haven't been any changes made to 1.23 which would fix this if it is a bug in fastcraft):

Spoiler Spoiler

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
/help
[03:14:52] [Server thread/INFO]: An unknown error occurred while attempting to perform this command
[03:14:52] [Server thread/ERROR]: Couldn't process command: 'help'
java.lang.IllegalArgumentException: Comparison method violates its general contract!
    	at java.util.ComparableTimSort.mergeHi(Unknown Source) ~[?:1.8.0_91]
    	at java.util.ComparableTimSort.mergeAt(Unknown Source) ~[?:1.8.0_91]
    	at java.util.ComparableTimSort.mergeCollapse(Unknown Source) ~[?:1.8.0_91]
    	at java.util.ComparableTimSort.sort(Unknown Source) ~[?:1.8.0_91]
    	at java.util.Arrays.sort(Unknown Source) ~[?:1.8.0_91]
    	at java.util.Arrays.sort(Unknown Source) ~[?:1.8.0_91]
    	at java.util.ArrayList.sort(Unknown Source) ~[?:1.8.0_91]
    	at java.util.Collections.sort(Unknown Source) ~[?:1.8.0_91]
    	at net.minecraft.command.CommandHelp.func_71534_d(SourceFile:84) ~[au.class:?]
    	at net.minecraft.command.CommandHelp.func_71515_b(SourceFile:38) ~[au.class:?]
    	at net.minecraft.command.CommandHandler.func_71556_a(CommandHandler.java:94) [z.class:?]
    	at net.minecraft.server.dedicated.DedicatedServer.func_71333_ah(DedicatedServer.java:370) [lt.class:?]
    	at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:335) [lt.class:?]
    	at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:547) [MinecraftServer.class:?]
    	at fastcraft.aw.a(F:700) [fastcraft-1.22-ctest23.jar:?]
    	at fastcraft.H.aq(F:62) [fastcraft-1.22-ctest23.jar:?]
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:396) [MinecraftServer.class:?]
    	at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685) [li.class:?]

1,320

Thursday, April 28th 2016, 10:18pm

drakray: The incompatibility is due to FC currently not detecting the mod, thus leaving compatibility code disabled.

Veeno: That's just my tick method, FC uses it to change the scheduling of ticks to make it (slightly) more efficient. It's very unlikely to ever point to a problem in FC, just like "net.minecraft.server.MinecraftServer.run" doesn't point to a problem in MC itself. The specific issue you are having is caused by a command having an inconsistent comparator, e.g. by having a non-fixed name or a broken custom implementation of compareTo. You'll have to find the mod adding the problematic command(s).

Counter:

Hits today: 17,047 | Hits yesterday: 29,849 | Hits record: 152,331 | Hits total: 65,280,411