Solar Helmet nonfunctional, Experimental 1.8.9 <RESOLVED>

  • I am running 1.8.9 experimental.
    I crafted a solar helmet. I put it on. I put on a partly depleted jetpack. I was fully exposed to the sun in daylight. The jetpack did not charge. 30k power should take 25 minutes to charge, but I should go from 27.7k to 27.8k in 5 seconds assuming 20 EU/second.
    It also did not work with a Bat-Pack.

    Tried restarting the game, removing each equipment and putting it back on.

    • Official Post

    Which version of IC2 are you using? There was a bug with solar helmets not charging but it was fixed in IC2 2.3.244

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.

    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(

    I see this too much.

  • 2.3.224

    Thing is. I am running 1.8.9, and this is the latest version for it so far as I could tell.

    Or, rather, The wiki download wasn't working, and I used a third party source instead. Which was clearly outdated.

    Download worked, and the newset version works fine. Resolved.