[GregTech-6][1.7.10][Website][Patreon] Info, Support and Suggestions

  • Please check the content of the smaller pipes with a magnifying glass. Maybe it is not Water.


    Also try filling the nonuple pipe with pipes of larger or equal capacity and see if that fixes things.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • Okay, just tested your suggestions. The small pipes did contain water, and replacing them with larger pipes (normal-sized bronze fluid pipes) does indeed fix things. I still feel like I'm not understanding things though. Why do all of the fluids in the nonuple fluid pipe stop flowing when using wrong configuration? I was under the impression that the nonuple pipes were treated as if they were nine separate pipes, but it seems like something happening on one pipe can have an effect on the others.

  • Okay, just tested your suggestions. The small pipes did contain water, and replacing them with larger pipes (normal-sized bronze fluid pipes) does indeed fix things. I still feel like I'm not understanding things though. Why do all of the fluids in the nonuple fluid pipe stop flowing when using wrong configuration? I was under the impression that the nonuple pipes were treated as if they were nine separate pipes, but it seems like something happening on one pipe can have an effect on the others.

    The nonuple part isnt the problem, the Stainless Part is. A nonuple Bronze Pipe would have worked for the water. A Rule of thumb is "larger Pipes always fill smaller Pipes but not the other way around"

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • I don't see any tooltip anywhere that mentions "simple fluid".

    It should on NEI or (Old JEI if you rather like 1.8+) recipe for example for a fluid canning (GT) machine.

    Color Codes and Format Codes for the rules:


    Red Meaning Don't Read that.

    Green Meaning must Read that.

    Blue Meaning everytime someone swears (like extensive bad language) on purpose it will be changed into a not a swearing text. Since I cannot delete other peoples text unless I am a admin or something that allows to get rid of the extensive bad language post. I absolutely hated swearing or worse extensive bad language.

    Yellow Meaning That is incorrect.

    Purple Meaning Spelling Correction


  • Here are screen shots of my sulfuric acid setup. The right one shows the LV heater and roasting oven making the sulfur and air into sulfur dioxide. That goes out the top through bronze pipes into the mixer that combines it with more air to make sulfur trioxide, then into the mixer making sulfuric acid. That then goes out the back into stainless steel pipes over to the bath ( currently elsewhere making alimiunum ) and that empties into the nonouple stainless pipe below that has a filter to let the hydrogen out into the tank and the not hydrogen into the mv electrolyzer. The electrolyzer feeds the sulfur back into the oven, and the oxygen into the tank next to it.


  • Here are screen shots of my sulfuric acid setup. The right one shows the LV heater and roasting oven making the sulfur and air into sulfur dioxide. That goes out the top through bronze pipes into the mixer that combines it with more air to make sulfur trioxide, then into the mixer making sulfuric acid. That then goes out the back into stainless steel pipes over to the bath ( currently elsewhere making alimiunum ) and that empties into the nonouple stainless pipe below that has a filter to let the hydrogen out into the tank and the not hydrogen into the mv electrolyzer. The electrolyzer feeds the sulfur back into the oven, and the oxygen into the tank next to it.

    That's more or less the same workflow I've got with mine, but I like how you have the back of the sulfur trioxide mixer directly emptying into the left side of the sulfuric acid mixer like that. I wish I had thought of that when I was building mine, it would have simplified the design a lot. As for dealing with excess hydrogen/oxygen, I basically do what you do but I put a huge bronze pipe/huge invar pipe with an open side and a pressure valve there instead of a drum. That way when the pipe fills up it vents the excess gas instead of backlogging it in your machines. If you want to collect it in a drum, you can attach one to the open side of the pipe, then when the drum finally fills up, it goes back to filling the pipe which will vent the overflow. Here's a screenshot to show what I mean; the huge bronze pipe is for hydrogen, the huge invar pipe is for oxygen. The open side is on the bottom; the drum on top of the hydrogen pipe is set to output on the bottom; it's just there to ensure the hydrogen flows in a single direction:

    MffLTdd.png

    The nonuple part isnt the problem, the Stainless Part is. A nonuple Bronze Pipe would have worked for the water. A Rule of thumb is "larger Pipes always fill smaller Pipes but not the other way around"

    Right, I get that part. What I don't get is why the sulfur trioxide stopped flowing. Reviewing the screenshot from before, there shouldn't be any flow problem with sulfur trioxide: it should go from the first mixer, to the bottom nonuple pipe, then the top nonuple pipe, then through the filter into the second mixer. Instead, the first mixer fills up the bottom nonuple pipe with 500 L of Sulfur Trioxide, which stops moving there. Fixing the issue with the water also fixes the issue with the sulfur trioxide not flowing for some reason.

  • So where is this config where Bear nerfed the AE2 storage disks so I can put them back in? Most of the reason for AE2 existing is to be able to have a single huge storage pool for all of your shit instead of tons of chests everywhere., And I definitely want that before I throw galacticraft back in and explore the solar system in search of adamantium.

  • Minetweaker Configs

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • The only file I have in config/ named 'mine*' is enviromine/profiles/default/CustomProperties/minecraft.cfg.

    MineTweaker scripts end in .zs, they can be found in the (your minecraft folder)/scripts/ folder.

    The post was edited 1 time, last by theJ89: slightly more descriptive post ().

  • So I have noticed that machine with fluid tanks will continue to auto output after they are shut off, but items will not. The machine has to be powered on for the items to exit.

    Yeah it has always been nagging me MinecraftSkeleton

    A machine does auto-output items only when it produces something, and once its output slots get clogged up it will never try to push them out again. Greg, is this an intended behavior?


    Steps to reproduce:

    1. Place an item pipe and a chest on the item output side of a machine.
    2. Temporarily disconnect the pipe.
    3. Have the machine produce some items.
    4. Reconnect the pipe.


    What I expected to happen:

    The machine pushes items in the output slots into the pipe after reconnecting it.


    What actually happens:

    The machine doesn't push them out.

  • MineTweaker scripts end in .zs, they can be found in the (your minecraft folder)/scripts/ folder.

    So in there I have Check Recipe.zs and Gregtech.zs, which each have like one benign sounding thing. Other than that there is Computercraft.zs, Chisel.zs, Forestry.zs, OpenComputers.zs, Harvestcraft.zs, and Railcraft.zs. None of them mention "storage".

  • So I started Bumbliary. I have Biomes O' Plenty installed, and I can't find any bumble hives in the Nether.

    I flew around the Nether with my IC2 jetpack and nightvision goggle for 15 minutes, yet I didn't find a single hive there.


    I see there is some code for custom Nether biomes in WorldgenHives::generate, but it's apparently not working as expected. Will you look into it, Greg?

  • So in there I have Check Recipe.zs and Gregtech.zs, which each have like one benign sounding thing. Other than that there is Computercraft.zs, Chisel.zs, Forestry.zs, OpenComputers.zs, Harvestcraft.zs, and Railcraft.zs. None of them mention "storage".

    If it's not being removed by Minetweaker, it could be removed through AE2's config file. Check (your minecraft folder)/config/AppliedEnergistics2/AppliedEnergistics2.cfg.

    There's a section in this file where storage cells can presumably be enabled (true) / or disabled (false):

    Code
    1. features {
    2. ...
    3. storage {
    4. ...
    5. B:StorageCells=true
    6. }
    7. ...
    8. }


    Failing that, here are the IDs for the 1k, 4k, 16k, and 64k storage cells. If you have some kind of utility that lets you search the contents of several files at once, try looking for these strings:


    appliedenergistics2:item.ItemBasicStorageCell.1k

    appliedenergistics2:item.ItemBasicStorageCell.4k

    appliedenergistics2:item.ItemBasicStorageCell.16k

    appliedenergistics2:item.ItemBasicStorageCell.64k

  • Hello! I am completely new to GregTech and have no clue as to what I'm getting into.
    I am very interested in using this mod but after reading up, a lot of people are conflicted on which version to use and at the moment, so am I.

    I read this statement from a reddit post made a while ago and I'm worried that by using GT6 I won't be getting the same awesome GT experience I see in screenshots


    "TL;DR: Do you want molten metal casting and doing a lot by hand before getting interesting machinery? GT6. Do you want to spend a bunch of time trying to figure stuff out but then become a lord of industry? GT5U."


    So I guess what I'm asking is that with GT 6 am I still able to make intense setups and factory builds? Or is it more focused on early game in its current state?

  • So I guess what I'm asking is that with GT 6 am I still able to make intense setups and factory builds? Or is it more focused on early game in its current state?

    In my GT6 world I have a gigantic labyrinth of pipes and machines which processes ores in a fucking so complicated way. You can definitely enjoy factory builds with it.


    Also, for most things you need to do by hand at the early game, there are several ways to automate them later. Automation setups are usually highly involved, cost so much material, but are fun to build.

  • I will make the Item Pipes send an Adjacent Inventory Update if they get connected to something.


    And that Items get only pushed out while the Machine is running was originally intended, even for Fluids. However it did not work very well for Fluids so I had to make that one constant.

    So I started Bumbliary. I have Biomes O' Plenty installed, and I can't find any bumble hives in the Nether.

    I flew around the Nether with my IC2 jetpack and nightvision goggle for 15 minutes, yet I didn't find a single hive there.


    I see there is some code for custom Nether biomes in WorldgenHives::generate, but it's apparently not working as expected. Will you look into it, Greg?

    No Biome related Code there, I check for Dimension ID in this case.

    Code
    1. switch (aDimType) {
    2. ...
    3. case DIM_NETHER:
    4. tY = 16+aRandom.nextInt(96);
    5. if (WD.block(aWorld, tX, tY, tZ) != Blocks.netherrack) return rResult;
    6. for (byte tSide : ALL_SIDES_VALID) if (WD.opq(aWorld, tX+OFFSETS_X[tSide], tY+OFFSETS_Y[tSide], tZ+OFFSETS_Z[tSide], F, T)) tCount++;
    7. return (tCount == 5 && placeHive(tRegistry, aWorld, tX, tY, tZ, 0xaa0000 , 300, aRandom)) || rResult;
    8. ...

    What you probably mean is the Biome Code that is used in case there is a Nether alike Biome in a Mystcraft Dimension. That has nothing to do with the vanilla Nether.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • No Biome related Code there, I check for Dimension ID in this case.

    Code
    1. switch (aDimType) {
    2. ...
    3. case DIM_NETHER:
    4. tY = 16+aRandom.nextInt(96);
    5. if (WD.block(aWorld, tX, tY, tZ) != Blocks.netherrack) return rResult;
    6. for (byte tSide : ALL_SIDES_VALID) if (WD.opq(aWorld, tX+OFFSETS_X[tSide], tY+OFFSETS_Y[tSide], tZ+OFFSETS_Z[tSide], F, T)) tCount++;
    7. return (tCount == 5 && placeHive(tRegistry, aWorld, tX, tY, tZ, 0xaa0000 , 300, aRandom)) || rResult;
    8. ...

    What you probably mean is the Biome Code that is used in case there is a Nether alike Biome in a Mystcraft Dimension. That has nothing to do with the vanilla Nether.

    Oh I see. So it should place hives as long as the randomly chosen block is a netherrack, and 5 of its sides are opaque. Hmm...


    Then it could possibly be that bumble hives placed by GT6 are overwritten by BoP, which isn't very likely because it doesn't do that for Overworld hives.