[GregTech-6][1.7.10][Website][Patreon] Info, Support and Suggestions

  • Crash with latest GT 5.02e... Looks like it is because I do not have Thaumcraft installed. It crashed on minecraft startup with the only change in mods was upgrading GT 5.02d to 5.02e. Correct IC2 and all other mods are installed with 1.7.2 versions.

    Files

    • crash.txt

      (15.36 kB, downloaded 209 times, last: )
  • Crash with latest GT 5.02e... Looks like it is because I do not have Thaumcraft installed. It crashed on minecraft startup with the only change in mods was upgrading GT 5.02d to 5.02e. Correct IC2 and all other mods are installed with 1.7.2 versions.

    Check your other Mods. They include API Files in their Downloads. Go yell at the one, who has a thaumcraft/api folder inside his Code.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • Greeeeeeeeeeeeeeeeeeeeg.
    Fix your item rendering!
    Look at that hydrogen cell in the hotbar!


    Also overlays don't render on certain items when held, such as wooden plates (but it works fine for shiny and metal plates)


    FIX IT GREG FIX IT

  • Greg I tracked down the issue to Railcraft 1.7.2-9.1.0.0. That is the mod that has the outdated api. If I install Thaumcraft 1.7.1-4.1.1.14 the crash goes away. I left a message on the Railcraft forum.


    The sad part is that if people that play GT and have Railcraft installed and do not have Thaumcraft we are stuck with version 5.02d for the foreseeable future.


    Thanks for your response to track down this issue.

  • Greg I tracked down the issue to Railcraft 1.7.2-9.1.0.0. That is the mod that has the outdated api. If I install Thaumcraft 1.7.1-4.1.1.14 the crash goes away. I left a message on the Railcraft forum.


    The sad part is that if people that play GT and have Railcraft installed and do not have Thaumcraft we are stuck with version 5.02d for the foreseeable future.


    Thanks for your response to track down this issue.


    Do you mean to say that the newest GT version is actually dependent upon having Thaumcraft installed?


    (Also, the fix to the problem should be to just delete the Thaumcraft folder from the Railcraft .jar file.)

  • Forge itself says that you should NEVER include API files of other Mods. Modders who don't follow that simple rule will get yelled at by the Forge Team.


    Including API Files causes many Problems, which could be solved by simply deleting said API Files from the offending Mod (Railcraft in this case).


    My Thaumcraft Stuff only gets loaded if something includes the Thaumcraft API, because if something has the Thaumcraft API, it is per definition of Rules ONLY Thaumcraft and not another Mod.

    I don't say, your "insert whatever" is bad. I'm only showing ways for making it better.
    GregTech Website
    Patreon really helps me out. If you consider funding the development of GT, so I might be able to do it fulltime, why not?
    GregTech 6, the Main Thread, Bug Reports go here too.
    I'm also on #gt-dev on irc.esper.net, if you don't want to make a Forum account just to contact me.
    (I'm there almost every day, when I'm at my own computer. Yes you can drop bugs and suggestions there too)

  • Hello Mr. GregoriousT, it is an honor to meet you. You are an amazing modder, and if you were working for Mojang you would probably do better than Notch. Your mod extends the game so that it isn't plug and play like TE3. I hope to speak to you more about your mod, because it is truly a masterpiece, even better than anything Reika himself could cook up.

    Timely Bee: tempestivus gallifreis: "An apiarist is never late. He arrives precisely when he means to!"
    Lordly Bee: tempestivus rassilonis: They live in peace, within the sight of the Eye of Harmony.
    Doctoral Bee: tempestivus medicus qui: "Would you like a Jelly Baby?"
    Preferred power sources: :Reactor:
    Preferred weapon: :Industrial Credit:

  • Derping around with covers, an' hulls, an' buffers, and stuff, I found that having a pump cover (LV in my case) pointed towards a fluid pipe will drain energy from the hull, even if no fluids are moved. The mode setting didn't matter. The energy drain stopped occuring when the pipe was removed. The same behaviour occured when pointed at a railcraft tank, so I'm only guessing it affects fluid tanks in general. The same setup with conveyor covers and item pipes didn't cause energy to be drained. Is this intended behaviour?


    This is the first test world in quite some time where the first thing I did wasn't advanced pumping the closest sizable body of water into a quantum tank :(


    For having gone biome independant, looking for extreme hills in hopes of a cassiterite and tetrahedrite veins (most often in vain...) seems unavoidable.

  • For having gone biome independant, looking for extreme hills in hopes of a cassiterite and tetrahedrite veins (most often in vain...) seems unavoidable.


    Personally i think copper and tin ores should be somewhere around y level 40. Since those are the first ores you need, they should be like relatively accessible. The higher tier ores are the ones that should be hard to find.

    GENERATION 28: The first time you see this, copy it into your sig on any forum and add 1 to the
    generation. Social experiment.
    I have copied this line

  • Derping around with covers, an' hulls, an' buffers, and stuff, I found that having a pump cover (LV in my case) pointed towards a fluid pipe will drain energy from the hull, even if no fluids are moved. The mode setting didn't matter. The energy drain stopped occuring when the pipe was removed. The same behaviour occured when pointed at a railcraft tank, so I'm only guessing it affects fluid tanks in general. The same setup with conveyor covers and item pipes didn't cause energy to be drained. Is this intended behaviour?


    This is the first test world in quite some time where the first thing I did wasn't advanced pumping the closest sizable body of water into a quantum tank :(


    For having gone biome independant, looking for extreme hills in hopes of a cassiterite and tetrahedrite veins (most often in vain...) seems unavoidable.


    Covers on anything that can use energy (such as hulls and machines) uses energy.
    Covers on anything that cannot use energy (such as fluid and item pipes) does not use energy.
    Therefore if you wanna save energy, always put your covers on your pipes.


  • Actually I already set that to true and I said just part of translations effected.
    In fact I found almost all of tool tip didn't change.
    I opened my translate lang file below you may test that.
    https://github.com/DeckerCHAN/Gregtech5-Translation-Chinese


  • Do you mean to say that the newest GT version is actually dependent upon having Thaumcraft installed?


    (Also, the fix to the problem should be to just delete the Thaumcraft folder from the Railcraft .jar file.)


    Just to let everyone know I tried to delete the Thaumcraft folder in the Railcraft jar and it made Minecraft crashed with " java.lang.NoClassDefFoundError: mods/railcraft/common/carts/EntityLocomotiveSteamMagic" without Thaumcraft. So right now either we stay with GT 5.02d with Railcraft. Remove Railcraft, or install Thaumcraft. I can only request Greg (please) to possibly to add a config to disable the Thaumcraft research in GT as a temporary fix. I know the issue is with Railcraft but who knows when it will get fixed.

  • Just to let everyone know I tried to delete the Thaumcraft folder in the Railcraft jar and it made Minecraft crashed with " java.lang.NoClassDefFoundError: mods/railcraft/common/carts/EntityLocomotiveSteamMagic" without Thaumcraft. So right now either we stay with GT 5.02d with Railcraft. Remove Railcraft, or install Thaumcraft. I can only request Greg (please) to possibly to add a config to disable the Thaumcraft research in GT as a temporary fix. I know the issue is with Railcraft but who knows when it will get fixed.


    I don't think you're supposed to don't delete the thaumcraft folder. I think you should try going into the api folder and deleting the thaumcraft folder within that.

  • The proper solution is to delete the api folder of Thaumcraft.


    If you have Thaumcraft, you don't need to do anything else.


    If you do not have Thaumcraft, download the Thaumcraft API and shove it into your mods folder.]


    EDIT: This is wrong. I misunderstood the issue to be outdated APIs and stuff like that.

  • My original statement of deleting the Thaumcraft folder from the Railcraft .jar file came from checking the Railcraft .jar file, and finding a folder called Thaumcraft, containing one folder: api
    If that folder is deleted, it removes the Thaumcraft API from Railcraft, and should eliminate the problem (unless CJ did something odd with dependencies and not having either Thaumcraft or its API causes a crash).


    Epic Lulz's third statement would likely apply here as a workaround, however it seems like fuzzy design to have the TC API as a dependency, but not TC (and not to just disable anything reliant upon the TC API if TC was not present).

  • Hello Mr. GregoriousT, it is an honor to meet you. You are an amazing modder, and if you were working for Mojang you would probably do better than Notch. Your mod extends the game so that it isn't plug and play like TE3. I hope to speak to you more about your mod, because it is truly a masterpiece, even better than anything Reika himself could cook up.

    Do we now have our very own Fedora lord?

  • @GregoriousT
    GregTech ores doesn't seem to be registered as ore for IC2 Miner. Is it possible to fix? As currently IC2 miner is exceptionally useless, as it ignores GregTech ores.


    I have been making all IC2 items more expensive to use them, but having not working machines, makes them pointless.