Posts by JustHev


    Oh wow, I totally missed that one. I was spitting around in the

    I don't understand. How is that a problem? If you already have one of them then making something to work the other way is trivial.
    Though I'd strongly suggest NOT doing it in windows batch "language". Anything is better than that, even qbasic.
    You mean how to handle files that you have not yet created an alternative texture for? Why not just, you know, skip them in the script? It's trivial to see if a file exists or not.

    What programming language do you recommend that is simple to pickup, skips missing files and can easily run the script in opposite mode?

    Progress on the guide: Got the blocks done. GUI is self-explainatory. Items will be finished today I hope.

    Won't it be simple to check up the names via the .lang file? That's what I always do.

    Looked around, can't find your lang file anywhere.

    Alternatively, I believe it is possible to write a simple batch script to convert all the names to letters and vice versa.

    Good idea. Now comes my problem: You need two batchfiles: One to deobfuscate, one to obfuscate. Also, how can you handle files that are missing in the deobfuscated format (not yet textured files?)

    This is for special Textures in said Areas. Like the Netherrack Ore Texture in the Nether, the Endstone Ore Texture in the End etc. I am well aware, that not every Texture is actually updated to that as I am indeed very lazy, but the Functionality is there.

    Can I make a conclusion that the ores that do not have the specific background are pretty much unused?

    Do you see these tons of Textures I have? Guess why I used Numbers after splitting Textures for the 1.5 Update. It's much faster to use Numbers, than to have to name every single File, and adjust every single Filepath. I wonder why nobody else got that great Idea.

    Also there is a very simple System to the Numbers. For example every Ore has 6 Textures, that means every 6th Texture is another Ore. For the Items its even simpler, just take the damage Value of the Item and you already got its Texturefile. I even made subfolders for certain Textures to keep it a bit more sorted.

    And why do you complain about some simple Numbers? It's not like you wouldn't have to change all the Textures for a Pack anyways.

    I have a pc to weak to both run GIMP and Minecraft at the same moment. I got lost in the mess of texture files you had. I know you have a lot of textures. A lot of modders do. They also invested their time to convert their files instead of hacking around. I'm making a guide, hope it helps people.

    OK lazy man, you will hear from me. I'm out

    I would not need to change it for 1.6 at all. I was intelligent enough to put the Filepath into a seperate Constant, so I would basically only have to change one single Name. Not to mention that copypasting File Names into Code is a real Pain. Guess why I took the Number route. I just have to write "for (int i = 0; i < 96; i++)" and a generic Folder Path (which also contains said Constant above) to put the Icons into a Array.

    To me it looked like a remnant of the 1.5 update, and you didn't had time to change the names properly.

    But why are you the author of the only mod I've seen that went a number route?

    A few weeks ago, I posted a comment asking if you could properly name the gregtech block files. It got ignored. I tried making a patch for my texturepack that night, but broke my head at the amount of numbered files instead of logically named ones. I'm currently unable to find the blocks I want to texture in the mess you made.

    My original post is here

    Today I tried to make a GregTech patch for my own texture pack. After peeking around for 5 minutes, only finding numbered images and purple squares in half these images, I decided to give up. Then I saw you pasted a troll face picture in these files. It reflected all my feelings. Thanks Greg.

    On a serious note: With 1.6 hitting stores soon, will the GregTech files change their names to a more descriptive name, following vanilla MC style? (that means ruby_block.png instead of 4.png) The current namestyle is annoying to work with.