Posts by outlawjosey

    Sorry, the fix I know of is only for Mac OS. But if I had to guess, the issue might be that you are running Vista. Could be some other fix out there for the Win Vista bug. Best fix, however, would be to upgrade to Win 7 (maybe even downgrading to XP would be a better option.)

    Try using the soundsystem update from the 1.15(?) release topic. Delete the paulscode folder from the Minecraft jar and put the new one in, see if it works.

    Unfortunately, no, that didn't solve the problem. Now I am able to get past the "Mojang" screen. But sound/music is off in the MC settings. And when i try to turn it up/on my client will crash.

    The Nuclear Control 1.1.9 mod does the same thing, and i suspect it's for the same reason. However, it does not have a way to disable the sounds in the config file, so i just play without.

    No need to yell, sounds DO hate some systems, although I have no reports of it hating Macs just yet.

    Oh, I may have been a little frustrated for a time, but I was never upset. You all do great work. I am only trying to help :)

    However, I have found several people having this problem (all running OSX). Very few of them have figured out the workaround though. Maybe people aren't realizing the problem lies with Mac OS?

    I've done quite a bit of research on what has changed in 1.97 and proper methods of installing it. Yet, I can never get past the Mojang pre-MC Title screen.

    Here's what i've done:
    Started with a completely fresh minecraft folder.
    Installed minecraftforge-client- (have tried build 134 as well as 3.3.8 152 without any improved results)
    NOTE: I am sure I am installing Forge correctly (making sure the META-INF folder is removed, etc...) Also I am NOT trying to use Risugami's ModLoader.
    Started Minecraft client without IC 1.97 to make sure Forge as well as FML are both working properly. Both load fine, and i get a "ForgeModLoader.log" without any errors.
    Exited my client, then dropping the "industrialcraft-2-client_1.97.jar" into the "Mods" folder which FML had created on the last client start.
    Started my client again.

    And I cannot get it to move past the "Mojang" screen

    I am on Mac OS 10.6.8
    And have also tried this on Windows 7 with the same results.

    EDIT: I have confirmed this to be a Mac OSX problem ONLY. The first time i tried this on Win 7 I used an incorrect install process.
    2nd EDIT: I have also confirmed that this is an issue with IC2 (1.95b and 1.97) on Mac OSX using version of MC Forge later than Since IC2 1.97 doesn't work with version of Forge earlier than 3.3.7 I am stuck using 1.95b with Forge 3.2.3 and would consider this a definite bug. However, I have tried other mods (such as RedPower 2.0pr5b2) with later versions of Forge (3.3.7 and 3.3.8 ) and they work fine. The issue is only with IC2.

    3rd EDIT: After much research, I found this support post on MC Forge's pages:,504.0.html

    The "fix" is to disable the IC2 sounds in the config file. So you must attempt to run minecraft with IC2 installed so that the config text file will be created. Then after setting "soundsEnabled" to false, start your minecraft client again. Doing this, I was able to get IC2 1.97 to run with MC Forge

    Forge is claiming it's an IC2 bug, but from what I can tell, it only appears on Mac OSX.