[CRASH BUG] Bat-pack crashing when equipped

  • equipped a Bat-pack to the chest on a multiplayer server and crashed and every time I've tried to log in it crashes right away.

    Mods loaded: 10
    ModLoader 1.1
    mod_Planes 1.1v16
    mod_ModLoaderMp 1.1v3
    mod_BuildCraftCore 2.2.12
    mod_BuildCraftBuilders 2.2.12
    mod_BuildCraftEnergy 2.2.12
    mod_BuildCraftFactory 2.2.12
    mod_BuildCraftTransport 2.2.12
    mod_IC2 v1.64

    Minecraft has crashed!

    Minecraft has stopped running because it encountered a problem.

    If you wish to report this, please copy this entire text and email it to support@mojang.com.
    Please include a description of what you did when the error occured.

    --- BEGIN ERROR REPORT d356b1ac --------
    Generated 2/19/12 5:25 PM

    Minecraft: Minecraft 1.1
    OS: Windows 7 (amd64) version 6.1
    Java: 1.6.0_25, Sun Microsystems Inc.
    VM: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
    LWJGL: 2.4.2
    OpenGL: GeForce GTX 460/PCI/SSE2 version 4.2.0, NVIDIA Corporation

    java.lang.AbstractMethodError: ic2.common.ItemArmorBatpack.getArmorDisplay(Lxb;Lyq;I)I
    at agq.a(GuiIngame.java:116)
    at kz.b(EntityRenderer.java:945)
    at EntityRendererProxy.b(EntityRendererProxy.java:15)
    at net.minecraft.client.Minecraft.x(SourceFile:742)
    at net.minecraft.client.Minecraft.run(SourceFile:662)
    at java.lang.Thread.run(Unknown Source)
    --- END ERROR REPORT 91e6d0e3 ----------

    Joined a normal server with nods on it and it works fine but the server i play on crashes every time i logged in cause of the batpack
    version 1.6.4

  • I have had the same problem whilst using the batpack, except I have mac osx 10, and only have industrial craft (including Modloader, ModloaderMP, audio mod and MC forge) installed. Any help would be appreciated.

  • I tried to fix this by using 1.70b and now I get this crash:

    I have the latest forge (

  • Use v1.70b or downgrade Forge to

    Also when I try to use Forge I get this crash error:

    I removed the Ironchest mod, and still got a Saving Chunks crash when I opened the world. Do I have to erase my player's inventory without opening minecraft or something?

    Any help would be great, this is super frustrating to suddenly happen =/

  • Never mind, cancel the team that I'm sure is working on sorting this out for me =P

    Did a complete re-install of everything from a fresh .jar and started a new world. Bat pack isn't crashing anymore :)