Qantum Suit flight mode not working?

  • After several months I have *finally* managed to complete my quantum armor set and I can't make the quantum chest piece flight mode work. Pressing M while holding down space makes it print that it is toggling the Quantum Suite Hover Mode on/off, but it does not hover nor fly.

  • So to control the quantum jetpack you need two buttons; your IC2 Boost Key and your IC2 Mode Switch Key (which from your previous post appears to be bound to M). As you seem to be getting, you can toggle hover mode by holding the jump key and pressing IC2 Mode Switch key (Jump+Mode). However to toggle the jetpack (in order to use either mode) you need to hold down the mode switch key and tap the Boost Key (Mode+Boost).

    Doing this should toggle the jetpack on and off, you should get a text prompt saying 'Quantum jetpack enabled/disabled' depending on it's previous state. Once activated you can press Jump+Mode (as described above) to toggle hover mode, just like the other jetpacks (you'll get a text prompt for that as well).

    P.S. if you notice yourself sinking slightly in hover mode, don't worry, that happens.

    EDIT: If you're not sure what buttons these are bound to, look for them under 'Controls' in the Options menu.

  • Ahh thanks, that is awesome! It always annoyed me that the regular jetpack did not have an off switch. I just assumed if there were an off switch it would be one of the modes the mode switch key would cycle through.