[Solved] Can't hammer some copper ingots.

  • I have four mods that add copper ingots:

    Arcana RPG,

    Soul Forest,

    End Ores,

    and IC2 itself...


    The new copper ingot from the End Ores mod can be smashed. But the other two, from Arcana RPG & Soul Forest, can't.


    I tried registering them as ingotCopper but that didn't work.

    Java: Class.java
    1. if(Loader.isModLoaded("gibby_dungeons")) { //Arcana RPG
    2.     OreDictionary.registerOre("ingotCopper", new ItemStack(GameRegistry.findBlock("gibby_dungeons", "dungeons_copper")));
    3. }
    4. if(Loader.isModLoaded("soulforest")) { //Soul Forest
    5. OreDictionary.registerOre("ingotCopper", new ItemStack(GameRegistry.findBlock("soulforest", "Copperingot")));
    6. }

    How can I get ingots from other mods to be smashed with a hammer? How does End Ores do it?


    MC-1.7.10

  • I'm registering them at the FMLInitializationEvent

    Like this:

    Java
    1. public void init(FMLInitializationEvent event)
    2. {
    3. initOreDict();
    4. }
    5. public static void initOreDict() {
    6. if(Loader.isModLoaded("gibby_dungeons")) {
    7. OreDictionary.registerOre("ingotCopper", new ItemStack(GameRegistry.findBlock("gibby_dungeons", "dungeons_copper")));
    8. }
    9. }
  • I tried,

    System.out.println("ITEMSTACK OUT >> "+ new ItemStack(GameRegistry.findBlock("soulforest", "Copperingot")).getUnlocalizedName());

    and also,

    System.out.println("ITEMSTACK OUT >> "+ new ItemStack(GameRegistry.findBlock("soulforest", "Copperingot")));

    And it crashed both times:

    Does that mean that the stack is empty?

    I also tried it at FMLPostInitializationEvent instead of FMLInitializationEvent and that didn't work.

  • Aha! I found something interesting...