[BUG] IC2 1.63 Failed to initialise [SMP] (now v1.64)

  • Runs fine without IC2 (still get the Exception in thread “AWT-EventQueue-0″ java.lang.NullPointerException error, I'm unsure what this is but it runs past it regardless)

    I Have MLMP Version 2.1 (I Have double checked, ran with just MLMP and forge, had the block break bug and the modloader.class bug so I loaded the fixes)
    Sorry I can’t provide a fuller log….

    I've also tried taking out the other mods same problem

  • I've tried both, I have MLMP V2 and V2.1 ( surely V2.1 came after V2...)

    Anyway i get exactly the same from both versions..

  • V1.64 loaded IC2 better than before but still get

    C:\Users\Jamie\Desktop\New Folder>java -Xms512M -Xmx1024M -jar minecraft_server.jar174 recipes27 achievementsModLoader Server 1.1 Initializing...2012-01-25 12:03:21 [INFO] ModLoader Server 1.1 Initializing...Mod Loaded: mod_IC2 v1.642012-01-25 12:03:21 [INFO] Mod Loaded: mod_IC2 v1.64Mod Loaded: mod_NotEnoughItems 1.1.02012-01-25 12:03:22 [INFO] Mod Loaded: mod_NotEnoughItems 1.1.0Done.[IC2] Config loaded from C:\Users\Jamie\Desktop\New Folder\config\IC2.cfgMinecraftForge V1.3.1 Initialized25-Jan-2012 12:03:22 forge.ForgeHooks INFO: MinecraftForge V1.3.1 Initialized2012-01-25 12:03:22 [INFO] ModLoaderMP 1.1 InitializedModLoaderMP 1.1 InitializedMod Loaded: mod_IC2 v1.64CONFLICT @ -204Mod Loaded: mod_NotEnoughItems 1.1.0
    [IC2] Trying to load IC2 submodule: bcIntegration31x[IC2] Can't load submodule: java.lang.reflect.InvocationTargetException[IC2] Trying to load IC2 submodule: bcIntegration22x[IC2] Can't load submodule: java.lang.reflect.InvocationTargetExceptionCONFLICT @ -204

    I assume [IC2] Trying to load IC2 submodule: bcIntegration31x
    [IC2] Can't load submodule: java.lang.reflect.InvocationTargetException
    [IC2] Trying to load IC2 submodule: bcIntegration22x
    [IC2] Can't load submodule: java.lang.reflect.InvocationTargetException
    Is something to do with buildcraft so i put that in and this doesn't dissappear

    Okay i carry on regardless, copy the cfg files from the server to my .minecraft (as i always do) and boot minecraft
    try to connect and i get an error and the connection fails
    Note this error is when connecting to the server and if flashes on screen for a split second i don't have access to it.

  • I have MLMP V2.1 (Sorry if this is a bit rude but i did say I double checked my MLMP version and went and did it a third time)
    And the error flashes for a split second, I don't even have time to screen cap it.

  • Finaly a tool to debug server connections! (you don't want to know how long i've been looking for one)
    anyway heres what i got

    at ti.a(SourceFile:34)
    at ey.a(SourceFile:178)
    at ey.a(SourceFile:67)
    at ey.a(SourceFile:12)
    at afq.a(afq.java:156)
    at ItemMobSpawner.renderInventory(ItemMobSpawner.java:185)
    at forge.ForgeHooksClient.renderCustomItem(ForgeHooksClient.java:242)
    at su.a(RenderItem.java:204)
    at su.a(RenderItem.java:288)
    at agq.a(SourceFile:590)
    at agq.a(SourceFile:219)
    Error report complete.
    I think thats helped I've deleted the test world and i must have had a mob spawner in my inv (i don't know what that's caused a problem)
    Works now thankyou! :)