AnvilChunkLoader errors in IC^2?

  • Ive asked of support with chunks on minecraft forums, one of users - laijka - told me i should ask here. Here is log of last use of minecraft: http://pastebin.com/iNYa5RFG My problem? Every thing i had build is disappearing. Laijka told me that, it can be problem with IC^2 (original thread here http://www.minecraftforum.net/…__13905445__fromsearch__1) Anvil Errors are on 2866 and it is linked with "at ic2.common.TileEntityElectricMachine.a(TileEntityElectricMachine.java:41)"


    Hope everything is to understand

  • I didn't look at the logs at all, but I can almost guess that you are using the 4096 id fix and/or id resolver. Remove either/both of those, and all your problems will most likely go away.

  • Ya, 90% sure. There was another fellow having trouble, his world would regen when he left an area. Removing those 2 fixed it. There have also been a few people in the thaumcraft thread that have been having issues with those 2.


    You'd be amazed at the amount of mods you can get running with out 4096 IDs tho. It'll take a bit of reassigning some block IDs manually but you can do it.


    The only 2 mods you have that I don't are:


    Advanced Solar Panel
    Train mod


    But I have a few you don't.


    EE
    Thaumcraft 2
    Forestry


    You're also using: (but I don't think any of these would be using block IDs)


    Single Player Commands
    Sonic Ethers Unbelievable Shaders
    Timber!
    Enderman Dont Pickup Blocks Mod
    GuiAPI


    So really unless Train mod uses tons of block IDs you should have plenty to get the rest of what you use running with out 4096.
    You will end up having to start a new world, as you'll most likely have to change a bunch of IDs around.


    Back everything up. And give it a try without 4096/id resolver. If you can get everything running with out it great. Worst case you have to cut 1 mod out until 4096 gets fixed vanilla. If neither of those work, you can just restore the back up, and be right back where you are now.


    Here is the other thread, where the other fellow removed them and it fixed it.
    http://forum.industrial-craft.…page=Thread&threadID=5379

  • Thanks a lot, now everything is clear. I will try uninstal ID Resolver and 4096IDs and manually rewrite ids in other mods. Still im waiting for MineFactory for example and want try some other new mods, but first ID Resolver and 4096ID must work correctly with everything.


    Train mod is one i have never using, it seems nice. AdvSolar Panels are new hi-tech devices after nuclear power of IC^2. Moreover im waiting for Metallurgy and Aether, maybe they will be relased someday for 1.2.3


    Have a endless power in your cables and many ores in your mineshafts!


    +++TTC flag on+++

  • Aether removes compatibility with any ods it finds compatible so you wont have aether in your list of mods because it edits too many base classes sorry its just not possible :(

    The Truth! (!!!WARNING!!! DO NOT READ THIS IF YOU'RE RELIGIOUS IN ANY WAY!!!)


  • Argh, i had taste for Aether. But nvrmd, it is not relased yet. About 4096IDs - it breaks chunk loading, you told truth and im very happy now, everything works correctly. Trains mod too, only what i need to set its IDs from ~190 to ~205. Now i want try MineFactory for 1.2.3, hope everything will work.