[Bug] [v1.00] Miner and Pump bugs

  • I tried the pump out since it got more working in v1 now and found a few things:

    The pump throws out all filled items (I figured already out it's meant to be used with a chest) even if there's space left after filling them, like 1 bucket in the upper slot or just 1 cell.
    They also don't threw them into BC pipes if present although I only tried a stone pipe but since pulling shouldn't be needed as it's spitting them out I guess it should work with all types if it would.

    When using a Miner Pump combo the miner can't use a double chest that touches both, Miner and Pump.
    If set up like this: C = chest, P = pump, M = miner
    In this setup the pump seems to be working with the chest but the miner just spits it's blocks out and yeah, I made sure there was space in the chest.

    Lava pumping with that combo in the nether worked (after I gave the miner it's own chest to prevent spitting) but it's far from effecient, but as exchange infinite. If you like manual labor.
    This comes from the fact that the miner drill stops after entering the lava. The pump also only pumps that one lava block it entered, even if it stops in a whole lake of lava. I also checked the height but that was between 20 and 30.
    As exchange it can pump flow lava as I made it retract and re-enter the same block 2 times I end up with 3 buckets of lava although there was only 1 source block.
    But when I tried mining a flow block not surrounded by source blocks it didn't give lava. Weird.

    The miner also seems to ignore glowstone with the OV scanner of which I don't know if it's on purpose or not, but at the bottom where the lava was, short before where it stopped due to said lava was also glowstone still in range of the miner.
    2 blocks above the lava it was like this: A = air, G = glowstone, M = miner drill
    I don't know if that air block now was a problem or if it just didn't care about it but well, that glowstone was left untouched.
    Both scanners give a damn about glowstone. In and outside of the miner.

    Also, when I just tested mining down again with an OD scanner instead of the OV scanner (which I used for all other things before) something blew up when the drill entered the lava.
    The setup was like this: S = MFSU, V = MV Transformator, L = LV Transformator, B = Cable (ins. copper)
    I guess somehow the entering in the lava reminded the MV Tranformator that it can overpower the pump, which it then did. But weird that it just noticed that with the lava. Mhm I guess the filled bucket in the chest next to the pump triggered and update which remininded it. Good to know that I have to avoid this setup in the future xD

    Funfact: mining a hole into the void limits you to that coord in noclip, no escaping that with noclip.

    Edit: it's not infinite, it just takes a source block from somewhere else, but it still only does that one time upon entering lava. If there are 2 lava blocks on top of each other it stops after entering the upper block.

    Edit 2: The pump also doesn't seem to like to take empty cells from a chest. Seems to work only from the internal slot.

    On my install Mining Drill doesn't give off any sounds at all o.o
    Help! Somebody fix that please!
    Wait a sec... damnit.

    no idea if he was serious but either way that was damn funny xD