[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

    • Official Post

    The linear search/list is only for pending tile entities. Pending TEs are TEs that were created while processing another TE until they get flushed to the regular data structures the next tick. Due to the very temporary nature the list is usually empty and otherwise small. TE queries mostly happens via getChunkFromChunkCoords(...).func_150806_e(...) in the middle of getTileEntity(...).

    There may be corner cases where the list intermittently grows to a significant size, but I don't remember having seen anything severe enough to warrant a targeted tweak.

    The O(1) map lookups involved in fetching a chunk+te are usually the real problem. Mods with lots of neighbor interaction employ caches to limit the impact, the regular lookup is already optimized by Fastcraft. I however can't/don't want to add local caches to arbitrary mods. TileEntitySteamHeater could check its heaters only every n ticks, which is more powerful than anything I can do in a generic way.

  • I apologize for bringing up an issue previously discussed a few years back, but it still seems to be apparent. When using the "Ruins" mod for 1.7.10, any command-block that would use the "RUINSTRIGGER" command doesn't fire off when using FC 1.25, even though I believe it was supposedly fixed around 1.23 from what the change-log is saying.

    I can get the command blocks to work if I use version 1.21 of FC, but this sadly causes a few minor hiccups with other mods that I run, so isn't an ideal solution. I suppose what I am asking is, what is causing the issue between ruins and FC that wasn't being affected a few versions back, but is in the latest version? If this is an issue with the ruins mod itself or is an issue that has been made aware that cannot be fixed, I'm sorry to bring it up for another time if that's the case.

    The forge version is, Optifine is also being used, OptiFine_1.7.10_HD_U_E7, and Ruins doesn't seem to have a version, but on Curse it's just listed as the 1.7.10 version that includes the NBT-Fix. Thank you for your time.

  • First, thank you for developing this mod, while it's working, it's been a great help making the game run smoothly.

    However, I'm getting a repeated crash all of a sudden, and I don't get why. I first added this on 5-3 and it ran flawlessly until 5-9. There was lag on the server a friend runs and he installed Opis and Mobius Core (to run Opis) and updated the server firmware trying to solve the problem. Not sure if it did anything... but later that same night, I had my first crash. Then it was okay for a few more days before crashing again. Since then, it started crashing every few days and now it's doing it many times a day.

    Today, I had the owner check when Opis was installed and found the dat the same day I started crashing, so he removed Opis and Mobius Core... but i'm still having crashes! "java.util.ConcurrentModificationException" errors. Almost all the crash reports are the same... This last crash, I even tried to turn off the culling tweaks.... run for awhile and still crashed.

    Do you think you could help fix whatever is happening here? Please... I really need fastcraft or the gameplay is fairly jittery on the server, even on my modern core i7 laptop. This crash happens at random, but there's 2 places in the world where it's happened a lot more. At one point, I was stuck in an infinite crash loop, crashing as soon as I logged on.

    I have the latest Java and Windows 10, and it happens no matter what settings I set through the technic launcher. the server has 147 mods with 143 loaded.

    I hope you're still around

    Here's the specific lines the log states at the top... I attached the full crash report below.

  • Is there any possibility to add triple buffering in Fastcraft? in large modpacks the frame time is not stable, some frame take 100ms and some frame take 10ms, and this makes gamer 3D glazing(although the fps is 60 or above).

  • Hello! I am sorry if it was already answered, tried to find an anwer but could not anything specific, is there any estimae when would 1.12.2 version come? It's a great mod you created!

  • Hi Mod Dev.
    I am notifying you that I will be using your Mod FastCraft for Mc 1.7.10 in a private ModPack on the FTB launcher and I will be adding This in the description
    "This pack contains <a color="aqua" href="http://forum.industrial-craft.net/index.php?page=Thread&threadID=10820">Fastcraft</a>, by Player, enabled by default. Fastcraft enhances Minecraft with increased performance. Bug reports being made directly to Mod Authors should state Fastcraft is enabled."
    thank you for making a really good mod.

  • (BUG SUBMIT: Shadow Flickering )

    (1.7.10)FastCraft 1.25 makes Optifine U E7 player shadow broken.

    When installed FC 1.25 and Optifine U E7, every shader pack has a same problem:

    When the player is falling, the shadow of the player is flickering, thus , some frame the

    shadow of the player is vanished, and maybe next frame the shadow is out there again. The result is a flickering shadow of the player when falling. But when the player is running or using a jetpack, all things fine.When the player is jumping, the first half of the jumping is just fine, and when the player start to fall, the shadow of the player is abnormal.

    I tried asyncculling = true or false, turn on vsync and off, turn on or off the old lighting, shader options and almost every config I Have and still cannot solve the problem.

    I tried Use Optifine U D6 and shadermod instead of Optifine U E7. It works just fine with FC 1.25. But fps decreased by 50%.

    I tried Optifine U E7 without FastCraft 1.25 and the shadow is fine. But fps decreased about 25%.

    I Use Forge 1.7.10 1614, win10 laptop, Graphic Card Nv GTX 1060

    • Official Post

    It is Optifine doing all the shadow handling and FC disables most of its render optimizations with OF+shadersmod present,. I don't know what's wrong, maybe the player gets culled by FC in the shadow pass. I'm busy working on FC2 for 1.12.2, so unfortunately this bug can't be fixed at this point.