[Bug] Personal Chests won't re-open

  • Sirbrandino here. I just recently made 2 personal chests to replace the regular chests in case of a massive explosion while I was down mining. I filled each one up with various resources. They were not next to each other. they worked fine, I logged out and back in, still worked fine. But the next day I went to use them AND THEY WONT OPEN. Or be wrenched. So now I'm trying to figure out what to do considering all my stuff is located inside those chests.


    I'm running IC2 1.0, buildcraft 2.1.1, eloraams redstone, timberrr, and recipe book. Thanks again guys.

    I5 2500K | 4GB Cosair Vengence | Radeon 6850 | Rosewill 600w PSU | GigaByte Z68MA | CM Elite 311 | Dell 19" 720p (upgrading soon!)| Hitachi 500 GB 7200 HDD | LG 24X |Windows 7 (Genuine!)
    Alblaka in a Lightning Rod suggestion thread...[/size]

  • Ah! I just realised I was playing in offline mode. I'll check right now.
    Edit: Yep it works, it didn't occur to me that playing in offline mode would do that. Is there any way to allow single player to always open pcs?

    I5 2500K | 4GB Cosair Vengence | Radeon 6850 | Rosewill 600w PSU | GigaByte Z68MA | CM Elite 311 | Dell 19" 720p (upgrading soon!)| Hitachi 500 GB 7200 HDD | LG 24X |Windows 7 (Genuine!)
    Alblaka in a Lightning Rod suggestion thread...[/size]

  • Ah! I just realised I was playing in offline mode. I'll check right now.
    Edit: Yep it works, it didn't occur to me that playing in offline mode would do that. Is there any way to allow single player to always open pcs?


    I agree, adding a "if (!world.multiplayerWorld) return always true;" check in the Personal Blocks "hasAccess" check would be quite neat to resolve this potential issue, without conflicting with it's SMP functionality.

  • If you could do that, that would be great. Would allow me to play when I dont have internet and have peace of mind that something blowing up isnt going to destroy everything I own.

    I5 2500K | 4GB Cosair Vengence | Radeon 6850 | Rosewill 600w PSU | GigaByte Z68MA | CM Elite 311 | Dell 19" 720p (upgrading soon!)| Hitachi 500 GB 7200 HDD | LG 24X |Windows 7 (Genuine!)
    Alblaka in a Lightning Rod suggestion thread...[/size]