Help: Minecraft run issue with IC2 1.15

  • I can run Minecraft fine as long as i don't put the industrial-2-client_1.15.jar file in my mods folder as soon as i do that and i run MC I get an error. I have redownloaded all files and .minecraft and reinstalled.

    It crashes after i see the mojang logo thingy. And i have installed the audio thing it still doesnt work. Also i do have the modloader.class in my minecraft.jar

    Help plz

    edit 2 - When i attempt to open the jar file is cant open with 7zip but i can open it with winrar however it comes up with and error saying unexpected end to archive. I there something wrong with the download jar file? am i putting it in the wrong place?

    oh the errror message is:

    edit - putting in spoiler

  • Unfortunately, I can't.

    1) Al will stab me with a Nanosaber
    2) I'm having a heck of a problem with Linux and ModLoader hating each other.

  • Rehosting the IC2 jar file. I'm pretty sure he doesn't like that.

    Taken from the IC2 post, "As well, noone besides the author and persons elected by the author are allowed to provide any download links. Everyone else is NOT allowed to public any sort of download, though he/she may hand out links to this website/thread instead."

  • i get the same thing

    as soon as i put the ic.jar i get that i dowloded the thing 5 times in the last 20mins from everywhere that i coud find it plezzz help

    • Official Post

    Unfortunately, I can't.
    2) I'm having a heck of a problem with Linux and ModLoader hating each other.

    You have to copy the Modloader.class file out of the java/lang folder (inside the Minecraft.jar) once you copy the contents of Modloader's folder into the jar (I had the same issue, and that seemed to fix it).

  • Try:
    -Deleting the META-INF folder from your minecraft.jar (if you didn't already)
    -Check whether all your preq mods are the correct versions and installed in correct order.

    Tried that too, still no luck.

    My brain is starting to have a crash now!

    EDIT: Found the problem only downloading 191k, have tried re-downloading many times but still comes out small like that so getting it from a friend that got the whole file, I think the download link may have corrupted