SOLVED Upgrading 1.337 IC2 1.8.1 World to 1.00 MC (Server)

  • Hey guys, i got a server going and i'm thinking of a proper way to easy upgrade everything to 1.00 i have some questions for server owners though:

    1. Currently the following Mods are in the server:

    • BC Most recent for 1.8.1
    • IC2 1.337
    • RP Most recent for 1.8.1
    • Zeldo Additional Pipes (must!)
    • Thermometer for IC2 to measure Reactor Temperature (can be abandoned)

    Will the server break if i upgrade it into 1.00 due to ID conflicts or other stuff other than some of the ID conflicts that Abla posted ? Any experience form others ?

    2. Given the release is a few days old... Is IC2 so far stable in SMP, any new hickups ? If not, what causes incompatibility ?

    3. GIven that Question 1 is possible, can i delete all chunks around our built stuff and it shoudl become upgraded with all the new features from 1.00 ¨?

    4. Anyone using the new GSLS Shaders already ? DO they work with IC now ? (old ones didnt)

  • 1. Make backups, try it. If it doesn't work then backtrack.

    2. See the bugs section of the forums since the release of 1.42, that is all the bugs I know of.

    3. Yes, deleting the chunks means new chunks are generated. However, biomes might get messed up when doing so.

    4. Have no idea.

  • It completely fucked up the world, marble got replaced with something else, missing pieces everywhere, server lags like crazy. I doubt i can save this world i dont understand how forge and the mods assign ID's so i'll prolly abandon it :(((

  • Well i dont have a running python system so i cant convert it i can download midas as she says but i dont know what to change into what ?
    PS: I just installed python, never used it before and try to figure out how to run it.

  • You run python from a command line. It might be faster for me to just post this now that the forums are back.

    You'll need to change the old IDs to the new IDs. The old IDs were stored in your RP2 config however I'll dump my copy in case yours got corrupted.



    Differences on my thing after some work, + is the new number - is the old. You'll note most things went up by 20, but some skipped around as if avoiding other things.

  • EDIT: Something is still wrong, its not as borked up as before but the items in question before are just missing now. BC pipes are invisible, (figure i do the same there) marble completely disapperead completely. My Marble roof has vanished...
    EDIT EDIT: BC seems to generate problems as well when upgrading NOT related to IC and independetly from the RP Mod. Figure i can forget about saving my complex BC machines :P

    I checked the BC Config files, they have exactly the same ID's that cant be the problem there...

    Ok this is how it presents itself, i changed all id's carefully. and theres no black stuff appearng everywhere anymore, thats better. but still all the bugged items from before just disappearead now, they are blocking movement but they are all invisible. They are not functional anymore though since my machines stopped working that were depending ont hem (like redwires). The same happened with all BC Pipes, they just turned invisible essentially breaking the world. I dont know what to do from here really since i couldnt find any differences in the Buildcraft Configs.

  • Have you removed your Redpower 2 config to let it use the new block IDs?

    PS don't forget to keep an old backup for your 1.8.1 copy...

  • Have you removed your Redpower 2 config to let it use the new block IDs?

    PS don't forget to keep an old backup for your 1.8.1 copy...

    This is what i have done:

    I compared the Config in my old Server with the New Config of my new server. I changed the ID's in the old configs to the values in the new config (which is different to the one you posted btw), then i started the old server once. Afterwards i stopped the server, copied the World Folder from the old Server to the new Server (without deleting anything) and Started the new Server with the above result.

    So what you say is, i should delete the config on the new server before starting ? why did i change the id's then if i let it reassign new ids ? I dont understand how forge works at all for that matter...

    I have uploaded my old Server Files to (i deleted the minecraft.jar + the mod files due to copyright limitations) if that helps all the current configs are in there.

  • I'm getting close to the solution:

    It seems as the problem is around Zeldos Pipes mod. I removed that one along with all blocks that came with it from the server when updating it, however... i noticed when i delete Zeldos Additional Pipes on my 1.8.1 server and i restart the server, it fucks up ALL pipes from Buildcraft. I have no clue on why it should do that but i can see it in the server log and afterwards the pipes turn invisible.
    Since Zeldo doesnt have an updated versiont hat works together with IC and BC i ditched it, it looks like i have to fix that problem somehow first before trying to get the server to 1.00 in anyway :(

  • Rough; I reccommend recycling all your old BC pipes and using RP2 since you get nice features and it's part of the core mod instead of extra addons.

  • Rough; I reccommend recycling all your old BC pipes and using RP2 since you get nice features and it's part of the core mod instead of extra addons.

    I fixed, well worked around the zeldo pipe problem, i found a compatible version which does the trick for the BC pipes at least but the Eloraam Transition still doesnt work, i might need a step by step help to make sure i made everything right.

    I tried to make the transition for eloraams again, i went into the config changed everything in my 1.8.1. server to the config values in my 1.0.0 server. Done that, but when starting the server 1.8.1 i get errors about empty entities and such. So i'm doing something wrong. When i copy the world over just as is it obviously doesnt work since the ID's havent changed in the world file...

    Eloraams explanation to solve this problem are excessive as usual :P

    Could it also be that this ID fix only works in 1.00 versions ?

  • Evans,
    would it be to much of a hastle to let that script run if it helps and resend me the world ? I'm getting desperate here and dont know what to do else anymore :/

    I made it! I flippin made it! It looks all good so far gonna keep you updated, i'm so tired from constantly figuring out how to do it, its like a 3day nonstop gaming session. Thank you so much evans, without your tips i couldnt have succeeded, you made some people VERY happy.

    I'll post my solution afterwards so if anyone needs the same help...