[bug][1.63 pre-from-irc] bad interaction with switches and RP2 red-wire on machines/reactor chambers?

  • I just tried that 1.63 'release' with ModLoaderMP v2.1 installed in to the server.jar -after- Forge.

    The behavior of IC2 blocks and RP2 blocks is now -way- off. I am unable to place redstone wire (RP2) against IC2 blocks. I am -also- unable to shift+click to place a switch on to a reactor chamber. --Further-- Injection of redstone signal in to reactor chamber by an RP2 not-gate (I think we used a NOR gate for that, which one isn't important) to shut it off -also- does not work.

    I don't believe the issues of #2 are caused by RP2 since the normal switch no longer places either. Is this just a pre-release bug?

    An additional thought to occur to me since my initial reply in the other thread where this was off-topic: is this potentially fixed by the rail-placement fix added to Forge or does it need a similar adjustment in IC2 code?

  • 1,63?? how can you have it when i dont even have it............

    Player was fixing it up and he used me as someone to test it :D
    Im not sure why, But I think he couldnt duplicate that bug on his system.
    And I dont know the cause behind the interaction bug.

    I did "tell" Player though.

    He was very helpful :D

  • If he needs more reference link to this thread, though I can't really see anything super-interesting from my end. He -may- also have a newer version of MCForge than I had access to. I had to alter my installer script to get it to work with 1.3.1 (installing ModLoaderMP over it on the server instead of the other way around).

  • Unsure. The behavior I observed with both the RP2 redstone wire on machines+CF blocks (but NOT on vanilla blocks or RP2 blocks) was that I could not place a switch (vanilla) or the wire against any of the IC2 blocks I tested (CF foam wall side, and machine side); at least the later of which worked in the last stable version. (In fact I noted /that/ by seeing the wire that had popped off my massfab when the wire pulsed and the blocks updated)

    The reactor issue also allowed a 'shutdown' (forced off by redstone signal) reactor to blow up (I reloaded from the backup), and my failsafe vanilla switch on the side also failed to function (it popped off on block update, would not go back on even with shift click).

    In all cases, failed items 'fell off' or the placement was rejected outright and returned to inventory. It briefly placed client-side. This is -likely- an issue with installing the dependencies -over- Forge; but the vanilla switch makes me not sure; hence the inclusion of the checksums for my files (md5) as well as the script I used to prepare the test jars.

  • That's identical to the behaviour I saw with both vanilla buttons and IC² reinforced stone doors mounted on hardened construction foam: any attempt to interact causes them to fall off, and any attempt to replace fails. I had this happen in both 1.62 and 1.63.

  • I've been unable to use IC 1.62 since I need the SMP fixes (I refuse to play SSP unless I -need- a fix and the login servers are offline)