[BUG : 1.64] Overclocked Machines dont show correct times

  • When I use a overclocked machine the time left till a piece of coal is macerated or water cell compressed is not accurate.
    The white bit does go faster, But with more overclockers the white bar doesnt fill all the way up before suddenly "finishing" the job and starting the next piece.
    With 3 overclockers, Its approx 3/5ths of the way before it decides it finishes and starts the next.


    This isnt a server lag issue, Something like the server thinks the overclocker is 2x more powerful then it really is. And the client doesnt know this.

  • Heres a pic of the extractor making coolant cells.
    This is how far it gets before the coolant cell is "done"



    This is auctally pretty horrible as its not nice not knowing when this will be done :\


    And I got around top speed with 3 overclockers?

  • Shouldnt at least client take into account that there's 5 overclockers?
    It should be able to reason that the machine will take this much time


    Oh and the GUI doesnt jump.
    It just goes up to a point. Then the coal is macerated. Etc.

  • Shouldnt at least client take into account that there's 5 overclockers?
    It should be able to reason that the machine will take this much time


    Oh and the GUI doesnt jump.
    It just goes up to a point. Then the coal is macerated. Etc.


    Most likely the client doesnt accustom for the increase speed and displays a normal scaling, until the server sends a "DONE!".
    We'll look into it, but it's probably low priority.