Support: Jetpack not working!

  • Hi everybody!
    I have windows vista home ed., with IC2 1.70, build craft 3.X and other little mod such as toomanyitem installed...
    The problem is that if i use a standard jetpack :Jetpack: , it works perfectly, i go up and i die if i go down as normal :D , BUT, if i equip the Electic jetpack :Electric Jetpack: , it simply dosen't works! I hold normally the spacebar (to jump) as normal jetpack, but i simply jump in position... i'm sure it was charged, and i try to press H for see if the hover mode change something, but nothing...
    Have u any ideas of why it don't bring me to the sky? :thumbup:
    Tnx a lot :)

  • The mode key is now M

    Thanx for your answer!
    mmmhhh u right... the right button is M, and i can switch the hover mode unless i continue to jump... but the problem is not solved... i cannot leave the ground... i simply perform normal jump, hover on or not...

  • i am having the same issue, my electric jetpack simply does not work, and no i am at 40 or so, and mine usually cuts off around 85. Let me know if you need anything else.

  • Fixed, for me at least. I went ahead and trashed my old one, gave myself a new jetpack, charged it up and now it works. Give that a try Keymaster, seemed to work for me.

  • Are you located on a mountain or raised terrain?
    Jetpacks have height limits, Electric one doesnt do much above layer 90ish.

    I wasn't over layer 90th, but i found out why it doesn't works!
    I used the switch of creative-survival from toomanyitems to create-equip the jetpack.
    What i've done is this:
    1. create a new world in creative
    2. pick up a new :Electric Jetpack: into original the minecraft interface (not from toomanyitems)
    3. switch to survaival mode
    4. equip the :Electric Jetpack:
    5. try to jump over and over...
    BUT! There is a trap! I thinked it was charged because it's fuel bar seems full, but if u charge it with any source of elettricity as normal, the bar resets like it's empty, and start charge untill full charge. THAN it works! I now can fly perfectly!

    In short, at the creation, it's out of energy, even if it's seems full and ready to fly...

  • Yep, TMI-ed items do not work at all anymore, because it does not register an on-craft event, or something like that.
    The electrical item interface was changed to store energy without damage values I believe, so that causes TMI to not work right.

    I actually have to wonder if it is possible to spawn items in such a way as to have it think it was crafted, and hence work.