[1.81]Bug: Terrain Regeneration

  • Hi,

    I’m having a weird and very annoying problem where the terrains would regenerate after I’ve left the region and return. A cave I dig out would be filled when I return from mining, or a passage I dig out would be filled after I’ve died and respawn in a different region and made my way back. Sometimes I’m not even 30 – 60 blocks away. This will happen mid-game, on death, or on reloading game, basically seemingly any time.

    This has happened numerous times, at first I thought it was just a Forge glitch, but after some testing I'm starting to think it's a combination of IC2 and Forge. For a long time I couldn't figure out why this was happening, or how to duplicate it, but I finally realized that this happened whenever I've let my guard down thinking it won't happen again, and started placing IC2 machines. So I placed a generator with coal inside it, with a macerator next to it grinding stuff (this has always been the setup), and a iron furnace right beside the generator, just...because. So I place a set of those inside a cave, and also on top of the surface. Then I saved and quit the game entirely. When I returned, the cave has been completely holed up (with stones), and the two machines on the surface have vanished (but no stones), but the iron furnace was still there. So that seems pretty concrete. Here's the error log I got from the console I launched the game with. This is the 7 - 8 occurrence.

    And here's a second sampling of error log (on the 8th or 9th occurence)

    The class files are class files that Forge edits.

    FYI, the only other mods I have that affect biomes and generation are LCTrees++, BC2.x, and RP2. And this is SSP. I'm on Windows 7, using Forge version 1.41.59.

    ps. This is not a corrupted chunk problem, as I’ve generated new worlds 6 – 8 times now, and it happens everywhere I go, pretty much breaking the game, I can’t even store items in chests because they’d just get overridden.

  • Oh, thank you, that is spot on. That is indeed the case, but I don't know how as I don't actually have so many items in the game that it would run up to that number, especially since most mods I have seem to use the item damage method to implement the numerous items. Items IDs seem to jump from the thousands then to 20k then to 30k. I do use ID Resolver though, and all the items from IC2 are 32000+. Is that the problem?

    All the items I have above that range are still usable and do not vanish though. It's the aforementioned IC2 blocks that seem to trigger the regeneration, and their ids are 246 and 250.

    Are you familiar with ID Resolver enough to recommend a fix?

    Edit: It seems even without IDResolver IC2 items are still in the 34000+ range, even though in the config file they're around 29xxx.

  • So should items not go over 32000, or 30256? I'm confused.

    I tried not using IDResolver. I used a fresh jar and deleted the config files, then I edited the block ids manually (they were the only ones that seemed to conflict, MC didn't throw up item id conflicts), but when I got into the game and checked the items with NotEnoughItems, it was still showing IC2 items with ids higher than 34000+, but when I checked the config files for those items, they were in the 29000 range :S

    I am also using Robinton's 4096 block ids mod, because that's the only way I could use BC/IC/RP and LCTrees++ altogether.

    I've tried editing item ids from 29xxx range down to 24xxx range (since in-game they're about 5000 off), but that only throws up "ArrayIndexOutOfBoundsException: 39096" when I load up the game (whereas previously I could launch the game fine). So I then tried editing them down by 10k in number (to 19xxx), and that did the trick (they showed up in game in 24xxx range).

    Here's to hoping I won't get more problems in the future.

    Thanks for your help thus far.

    Edit: just a nagging question, what other mod could be affecting the ids so that actual in-game item ids don't match config ids? Could it be redpower's auto assign?

  • After the first run the RP auto assign should toggle itself back to off. So it really only affects the initial assignment of IDs and then is inactive.

    You shouldn't need the 4096 ID mod, I'm running BC/IC/RP/Foresrty/railcraft/portalgun/EE/wireless redpower/2 mods that give more tubes for BC/I think some thing else as well, but I've lost track... and have only had to change 5 block ID's and haven't had to run out of room yet. Nor have I touched a single item ID.

    I'd look at the tree mod you are using, or the block ID fix.

  • Wow, lctrees and buildcraft use identical block IDs (nearly)

    But that said, I was able to add in LCtrees with the rest of the mods I was running. It took alot of moving block ID's in the buildcraft config. And still I didn't touch an item ID. Going to test placing items now, see if it all works.

  • Yeah, LCTrees++ does indeed use a lot of the same IDs as these big mods. I quite like it, even without other biome mods it adds plenty of color and variety into various biomes just by itself. Thanks and I really appreciate you taking your time out testing this for me.

    I went with a hunch and tested having all these mods together without ChickenBone's ChickenCore and NotEnoughItems (which is a massive improvement over TMI), and it seem that the mod was the cause of a lot of problems. Not only did the array out of bound problem go away (with the same set of mods), but IC2 items are not longer 4000 - 5000 id numbers off (still 1000 off, but that's at least within 32000). I also no longer have a problem where input items I put into generators and solar panels would disappear on reload =/

    He did say in this thread that it was coded in a rush and that there would be bugs, but I did not expect the magnitude.

    If you are curious perhaps you can see if you can duplicate the problem with NEI so we can tell ChickenBone to fix it :p

  • No problems with codechickencore-client or NEI for me. Liking the world I started off in, might be adding this to my list.

    I started a world, wandered around for a day, NEI'd in a couple generators, batboxes, macerator, and electric furnaces. Set them all up with some work, then went off exploring. made sure I went far enough to gen new chunks, found a cave, spent 2 MC days down there exploring.. came out made my way back to my crude IC setup, all was well and good.

    I'm thinking it is either the item ID or block ID mod you have/had, or that you accidentally changed something in the config files you didn't need to.
    The only thing I needed to do was reassign pretty much all the BC block IDs, I moved them to around the 180-195 range.

  • You're right, I spoke too soon. I tested NEI again and it wasn't the problem, I can't remember the configuration I had before that led me to think it was NEI.

    You may be onto something about Robinton's 4096 BlockIDs mod. I had my doubts about it messing with item ids, since it is a block ids mod. I will do some more testing.

    Edit: It is indeed Robinton's 4096BlockIDs. *sigh* All this time...

  • Glad you got it figured out. Now I'm off to start a new world, no importing items for me.

    Thanks for pointing me in the direction of lctrees. Now I need to find something to tell me what block ID's i have left, for when thaumcraft 2 is done.

  • hi,

    im playing in mc 1.2.3 now
    with mods :
    ic2, rp2, bc, nei, id resolver, 40961 ids mod, bc extra tubes, timber, forge, tf2tm, portal gun, gui api, modloader and modloader mp
    and i have the same problem in this version of mc
    when i cloase down and start up mc

    and when i have a set up with ic2 machines, remove them and chanche the desinge the coper wire and any other wire shows it conects to previus plaed wire that has been removed again

    gr walra

  • 4096 ID's has a list of mods it's compatible with and ones it isn't. Those lists don't contain IC2, but based on this thread and another, it's a safe guess that 4096 ID's is not compatible with IC2 and/or one of the others you are using. Looking at the list of mods you are using, you'll have no problems getting them all running with out 4096 ID's.
    You'll need to get rid of 4096 ID's and ID resolver to fix the terrain regeneration.

    The second problem you are having is do to using an old version of forge. Update forge to build 64. http://lexmanos.no-ip.org:8080/job/Forge/64/

  • i used my backup from vanila 1.2.3
    now i have all mods as last time without id resolver, 4096 ids
    and gui api isnt on it cuz i didnt know what it was for

    but i wanted to know is there a easy way to see witch ids are still free

    gr walra

  • Tell NEI to "Show Unused Blocks". It's in the NEI options, bottom right option on the options page for me (I am using the older version for 1.2.3 that didn't have issues with IC2, think it was 1.1.3. I think I read it was even easier or you could export a list of block ID's, something new with it in the 1.2.0 version but I like my recipes).

    For me it shows them as a green vine with it's ID overlayed on it, but that could be because of my texture pack or the ID's I have used, not sure.

    But it calls them "UnusedBlock ID: xxx" (xxx=the id number), you can write them down. It'll show you all the ones out side of the block ID range (Item ID's, etc) also, so remember to only use the ones equal to or below 255

  • .minecraft/config/IC2.cfg

    this one [below my tekst] ?
    ummmm i dont see any blocks with ids
    [or its a other way as buildcraft witch showed me it like this: cobbelstone pipe: 149 ]

    # general

    general {
    # Enable crafting of buckets out of tin
    # Enable crafting of Industrial Credit coins
    # Enable crafting of glowstone dust out of dusts
    # Enable crafting of gunpowder out of dusts
    # Enable crafting of nukes
    # Enable crafting of rails out of bronze
    # Enable usage of lapotron crystals on miners
    # Enable activation of the quantum leggings' speed boost when sprinting instead of holding the boost key
    # Enable hiding of secret recipes in CraftGuide/NEI
    # Enable calculation of inventory weight when going through a teleporter
    # Enable generation of copper in the world
    # Enable generation of tin in the world
    # Enable generation of uranium in the world
    # Enable generation of rubber trees in the world
    # Base energy generation values - increase those for higher energy yield
    # Explosion power of a nuke, where TNT is 4
    # Maximum explosion power of a nuclear reactor, where TNT is 4
    # Maximum number of audio sources, only change if you know what you're doing
    # Enable sounds
    # List of valuable ores the miner should look for. Comma separated, format is id-metadata:value where value should be at least 1 to be considered by the miner
    valuableOres=14:3, 15:4, 16:1, 21:3, 56:5, 73:3

    # item

    item {