[Bug] IC2 v1.95 - NPE on loading world in TileEntityCable

  • Got this error when I reloaded a world:

    at ic2.common.TileEntityCable.onCreated(TileEntityCable.java:90)
    at ic2.common.TileEntityBlock$1.tickCallback(TileEntityBlock.java:27)
    at mod_IC2.OnTickInGame(mod_IC2.java:1377)
    at ic2.platform.Ic2.onTickInGame(Ic2.java:347)
    at ModLoader.onTick(ModLoader.java:1102)
    at EntityRendererProxy.b(EntityRendererProxy.java:22)
    at net.minecraft.client.Minecraft.x(Minecraft.java:869)
    at net.minecraft.client.Minecraft.run(Minecraft.java:747)
    at java.lang.Thread.run(Unknown Source)

    However, when I reloaded again, I got no errors.
    I took a look and it seems that sometimes you get unlucky and it calls onCreated before it is valid, and its worldObj is still null (I think).

  • pretty much the same error here upon loading up a 1.2.3 world. If I start a new world fresh there's no problems.
    load up the world again and whamo, half my base is gone and the chunk got reset. Thankfully I do have backups.

    edit: move myself off in the distance some with MCedit and I still get a reset chunk where my base was.

  • I have exactly the same error while loading a 1.2.3 world. With a new world I have no problem.

    Is there any way to fix this?