[support request/RESOLVED]: unable to install and run IC2/required mods

  • Hi! First off, I haven't got an error report, so I will try to explain the problem as clearly as possible.


    I have tried this on my windows XP and windows 7 computer and had it fail the same way. I've tried multiple times on each. Both are updated to 1.2.5, and have fresh minecraft.jar installations.


    First, I try to install Risugami's Modloader: I am installing v1.2.5. This part of the installation seems to work; I delete META-INF from mincraft.jar and drop in the Modloader files. Minecraft opens normally, and a "mods" folder appears in the .minecraft folder.


    Next, I try installing MCForge. I have tried this with 0.94 and 1.05, and neither have worked. I take the files from the .zip and drop them into the minecraft.jar folder. At this point, minecraft gets stuck on the loading screen and will not open. it's the brown dirt background with a green load bar. It gets stuck at "done loading."


    If I try placing the industrialcraft mod into the mod folder anyway, minecraft either hangs up exactly the same way, or gives me a crash report, but closes the window before I can grab it.


    I have also tried exacting the .zip files and copy/pasting them rather than dragging and dropping from the .zip files.No difference.


    Last, I have been using winrar.


    Any help or suggestions? Thank you for any help in advance.

  • Make sure you aren't checking the force update box after you have installed modloader.


    It really sounds like the META-INF folder is back.


    Have you tried putting both modloader and forge in at the same time and then running MC after that?


    Copy the contents of modloader first, then the forge contents, delete META-INF folder.


    Then run MC make sure that force update is not checked.

  • no luck with those suggestions either.


    The meta-inf folder did reappear after I tried installing the mods; but deleting it did not help. it still froze on the same screen. I will keep trying though.


    I checked the force update option, and it was not checked.

  • If I drop in the modloader and forge files at the same time then NO, it does not reappear. the mod folder does not appear either. Minecraft hangs up.


    If I drop in the modloader files, open minecraft, then close it and look in the jar file, meta-inf does reappear. If I delete it and drop in the forge files then open minecraft, it hangs up exactly as before.


    sorry for the ambiguity >.< still trying different things!

  • You may have tried this already, but...


    First, back up anything you want to save. (saves folder, etc)


    Delete the .minecraft folder


    Then run MC, so it downloads everything fresh. And try it again from there.

  • haha! every time I try to install a different way I do that :) it's the only way to get mincraft to work again once I try to install something. I have been doing this with a fresh set of files each time.


    sure is a stubborn problem!

  • Odd. I don't think it's user error, but to completely ensure that, maybe use something like MultiMC? It'll install the mods for you, directions/use are in Direwolf20's video.

  • I gave that a shot too - here's how it went.


    MultiMC wouldn't work at first because my .NET framework was out of date - whoops!
    I updated it to version 4. I tried the normal installation again just for giggles and it failed in the same way.


    I opened MultiMC and it worked - but when I followed the instructions and tried to open minecraft through multimc I got this error message:
    mc\instances\attempt_industrial_craft\.minecraft" "tiny_lion" 1906402003138969364
    Instance exited with code: 1
    java.lang.UnsupportedClassVersionError: Bad version number in .class file
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    Exception in thread "main"
    Crash detected!

  • PROGRESS!!


    I updated Java based on that last error message. When I installed Modloader and Forge they both worked!! Then I dropped in the industrialcraft2 Mod file and minecraft crashed. It flashed an error message at me and closed before I could copy the crash report :(

  • So, I tried freshly downloading the industrial craft 2 file, then restarted my computer, plopped it in the mods folder - it worked! minecraft no longer crashes!!


    Thanks to your help I figured out the problem :) looks like java needed to be updated. Kind of silly of me!


    Thank you so much! I can play with my friends on the server again! Thank you thank you thank you! :DDDD