[1.4.5] Open Beta v1.109

  • Other bugs:
    - Major: The apparently energy-net does strange things when storage blocks (Batbox) are linked to themselves. In my setup I had a reactor power a batbox, which powered my machines and then a third dead-end batbox after these, the last batbox was linked to the net with both the input and output. At first all boxed filled up properly while the machines were working fine, but when the generator stopped working, strange things happened. Energy was not transmitted even if the last batbox was full, then after reloading the last batbox was transmitting but the first one was no longer. Could not find a work-around for this yet.

    Did you loop your Energystorages? If so, then it's your fault as loops are not being processed by the E-net because of infinite senseless Energytransfer, which could even lead to terrible Cable-Loss, while just storing EU.

  • Did you loop your Energystorages? If so, then it's your fault as loops are not being processed by the E-net because of infinite senseless Energytransfer, which could even lead to terrible Cable-Loss, while just storing EU.


    I did loop but the issue was a different one: the enet behaved unpredictable, sometimes drawing energy from the one box until machines went dry even though the other box was still full, then suddenly after reloading the energy was drawn from the second box but the first one was ignored.


    Expected behaviour: Energy is drawn from both boxes by machines and excess energy is stored in the second then first batbox.


    For clarification, this was about my setup (side-view):
    :Rubber Log::Rubber Log::Rubber Log::Rubber Log::Macerator::Macerator::Macerator::Rubber Log::Glass Fibre::Glass Fibre:
    :Generator::Glass Fibre::Batbox::Glass Fibre::Glass Fibre::Glass Fibre::Glass Fibre::Glass Fibre::Batbox::Glass Fibre:


    Left batbox output pointing towards machines only, right batbox output looped bat into the enet.

  • [...]Expected behaviour: Energy is drawn from both boxes by machines and excess energy is stored in the second then first batbox.

    You don't actually need to loop at all -- just connect the two batboxes to each other in series, and output from the last batbox into your machines. It does exactly what you want.

  • http://pastebin.com/CYr4y4kG
    help again!
    why industrial craft no work?


    Please try to read the error message first, the problem is clearly stated in line 61.


    To get things running do the following:
    1. Navigate to your minecraft directory (something like: C:\Users\czarny\AppData\Roaming\.minecraft)
    2. find the folder configs and delete it
    3. Start Minecraft.


    All block ids will now be re-assigned, which might corrupt an existing world, but Minecraft should run afterwards.

  • You don't actually need to loop at all -- just connect the two batboxes to each other in series, and output from the last batbox into your machines. It does exactly what you want.


    Not exactly, as in my setup only the excess energy is put into the 2nd batbox, the machines have priority.


    But just before this gets to far, I actually do not construct my usual setup like this, I just happen to have that batbox in place from a miner I had placed next to my machines and tried to re-inject the energy into the net when I noticed the bug.


  • Not exactly, as in my setup only the excess energy is put into the 2nd batbox, the machines have priority.


    But just before this gets to far, I actually do not construct my usual setup like this, I just happen to have that batbox in place from a miner I had placed next to my machines and tried to re-inject the energy into the net when I noticed the bug.

    http://pastebin.com/P1ci8v5E
    ayfkm?!

  • I'm very sorry for that spam, I added modifications head over heels (the Polish proverb), but most of the mods were incompatible with one another and particularly jammy mod furniture. This mod gave these crashes.
    I think there will be no errors when adding these mods.
    and so I have 25 of them;)
    I'm sorry for everything.
    ps. translation may be not so much because I am Polish and I'm using http://translate.google.pl. also sorry for the translation.
    po polsku:


    bardzo przepraszam za tamten spam, dodawałem modyfikację na łeb na szyję (takie polskie przysłowie) lecz większość modów były niekompatybilne z innymi a szczególnie jammy furniture mod. ten mod dawał te crashe.
    myślę że już nie będzie tych błędów przy dodawaniu modów.
    i tak mam ich 25 ;)
    za wszystko przepraszam.
    ps. tłumaczenie może być nie za bardzo ponieważ jestem Polakiem i używam http://translate.google.pl. za tłumaczenie też przepraszam.

  • czarny-what mods are you using? What crash did you get? (%appdata%\.minecraft\Forgemodloader-client-0.log OR %appdata%\.minecraft\crash-reports\xxxx.txt)
    You might want to update to 1.110