[IC2 Exp|IC2 Classic][1.6.4] AdvGenerators^3

  • Hello Everyone.
    You may remember the dead mod AdvGenerators from 1.2.5-1.4.7
    If that is not the case. Here is the Original thread: [Addon v1.112]AdvGenerators²v3.3.0-New Toys!!!


    After i created a couple things in my mod and in my world i missed every now and then a alternative
    energy source. Yeah IC2 Exp Lavagen was extreme nerved. It was anyways finite, but i could not find
    something that i want to use. At least for just a couple EU for free and watergenerators are simply
    not enough. So the really old mod AdvGenerators came into my mind. I loved it. Sadly there was no version
    for 1.6.4 or newer. So i decided to update it.


    AdvGeneratos^3 is a 95% copy of AdvGenerators^2.
    What are the changes?
    First and Easiest change. Unlike before the blocks support almost every form of FluidContainer.
    Second thing some recipes changed a little bit. Later to that.
    Third thing. The PESU is no longer counting as batterie in your inventory. Also it do not save his energy
    when you break it.
    Fourth thing. It require my base mod SpmodAPI. That adds a lot of things. Luckly you can dissable
    almost everything by the onlyAPI config in the config file.
    Fifth thing. It supports IC2&IC2Classic. But only my Version of IC2 Classic. Immibis 1.6.4 version does not
    support ic2 exp addons.
    Sixth thing. Slots explain what they do in most cases when you hover over them and press controll (have be empty)
    That is a feature that come from SpmodAPI!
    Seventh: Wood gas can be turned into a biofuel if you have bc (refinery) and forestry installed.


    Now the differences when you switch from ic2 exp to ic2 classic or back.


    If you use ic2 exp everything that uses redefined iron in the classic version require Iron plates.
    In the Exp version none of the machines can explode!
    When you use IC2 Classic you create a magnet in the electrolyze. (Config can force the ic2 exp crafting recipe.
    When you use IC2 Exp you can not foam plasma cable!


    Yeah i think that covers everything.


    I hope you enjoy the new old AdvGenerators^3


    Little note: Prerelease count not to for AdvGenerators. I have it active because my whole todolist is
    not finish yet.
    Download link:
    https://github.com/TinyModular…inyModularThings/releases

    The post was edited 1 time, last by Speiger ().

  • Thanks for the update :D
    Sadly, I can't use it as my game crashes on me all the time. When I only install SPmod, some classes from tinymodularthings are missing. As soon as I also install tmt, the game crashes because of something else:


    When using only SPmod in api only mode and no tmt this happens:


    Yes, I am using MultiMC, but that should be no issue.


    €dit: I just saw that no config files were created either, as it seems. Is that normal? <-- Maybe you should say your configs are in a private folder :D


    €dit2: The line causing the error seems to be:

    Code
    1. regist(new WorldCrafter());


    This method where this line appears in is called by SPmodAPICore.serverside(), that explains the second entry in the stacktrace.


    The question for me is now, is this WorldCrafter class really neccessary for the API mod? If yes, add it in there, if no, make the call depend on whether Tmt is installed.


    Example code:

    Code
    1. if (Loader.isModLoaded("TinyModularThings")) {
    2. regist(new WorldCrafter());
    3. }


    Of course this needs Tmt loaded to work. I suppose there is a more elegant option if you find it :D


    Thanks for your help!
    - Shadow

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

    The post was edited 2 times, last by Shadowlife ().

  • Thanks for that thing. I am still working on the API mode. Never said that it is finished.
    When i tried it it worked perfectly. But i will take a look in it.


    To Your fix. You forgot something. That crash was happeining on class load and not at the line where you showed me.
    I have to remove the Import to make it actually work..

  • Sadly, I can't use it as my game crashes on me all the time. When I only install SPmod, some classes from tinymodularthings are missing. As soon as I also install tmt, the game crashes because of something else:

    The First Crashreport is a Item Missmatch error. Because he tries to load something which he can not find.
    To explain it more simply: When Any Item / Block has a Missmatch he automaticly Stop the Registering of the Items/Blocks. Does not care where. So then the Recipes missmatch because he get Items which have a null in it instead of an registered Item... I have fixed the other bug and hope that everything works how it should.
    Check please the FML and Look for a crash on loading that should happen after the SpmodAPI Info Files (loaded blocks/items/World/Utils)


    Also a note: My ItemIDs you do not need to make + 256. It automaticly do that for you you only need to type a number in and you get it out. Thats it....

  • Ok. Thanks.
    Is the fixed version you mentioned already uploaded?

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

  • Update: 1.3.1:


    Fixes: Adjusted SpmodAPI that you can run it without TinyModularThings.
    Fixed: StoneMacerator do not freeze anymore after a reload of a chunk/Server.
    Fixed: FluidHandler from WoodGasser had no check for fake extraction.
    Fixed: Some Inventory inserting and Extracting part.


    Downloads you find at the Start post.

  • Thank you so much :D


    Btw: what's that buildcraft file download in your release thing all the time? Something useful? :D


    €dit: To avoid multiposts, I'll just add this here:


    I still crash when booting the game. This time, I get a new error though...



    I get this crash with both Buildcraft 4.2.2 official as well as with your edited 4.2.2.1


    Any ideas how to fix that?


    Additional info: The only mod of yours i'm loading is the API, AdvGen in not even in yet.

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

    The post was edited 2 times, last by Shadowlife ().

  • Please give me a Pastebin with your full FMLLog. That Crashreport define me to a line that makes no sence at all at least for me because it did not have that crash in some form at all.
    The first thing i assume is a ID missmatch.
    To help you i always log everything in SpmodAPI. So loading blocks items utilities world stuff and so on.
    if anything fails and i think that does happen at your side then search for this:
    "Config could not load. Reason: "
    There is always a [SpmodAPI] behind something i log. Please check that.

  • Btw: what's that buildcraft file download in your release thing all the time? Something useful? :D

    It is a custom Version that allow me to add pipes. I already figured out that it is a BC bug that pipes crash the game when i install them with the original mod.
    I told Spacetoad that and asked him to make a custom release. He did agree. Also i can add features/fixes to it which help a lot of things out.
    But this version is not nessesary. It is only needed that TinyModularThings can add pipes. You can dissable them with a config so you do not require BC.


    And to the other thing it is a API Only mode bug. ^^" Will add a fix soon.

  • Wow, you're really quick! Awesome! Checking this out right now :D


    €dit: Game boots now. I get a crash when using NEI though. Testing a bit more for further info now.


    €dit2: Sorry to bother you again...


    The NEI crash keeps appearing as soon as I want to show recipes (not only from this mods). This issue appears for both item recipe and item usage.


    Log content:


    Usage mode (extract from forge log):


    Recipe mode (extract from crashlog since game was already restarted):


    I suppose the issue is somewhere in this line: "if (result.d == APIItems.mobMachineHelper.cv)"


    €dit3: Nope, I'm using the latest NEI and CCCore.


    Also, I've got a request for the mod:
    Could you please add a possibility to the solar turbine to add water via pipe/fluiduct?
    Thanks!


    I'm going to check whether my NEI is outdated now, but I don't think so.


    Nope not outdated.
    Also could you lower the amounts of "Test" messages in the log from the IV transformer please? They're kind of spamming the log :D
    Maybe simply only output the test every 100 or 1000 ticks?
    Or simply add an item to read the content and show a chat message with it?

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

    The post was edited 5 times, last by Shadowlife ().

  • Ok. Bugs were the following:
    Forgot to shutdown the Client Plugins. Fixed!
    Unneeded Test Messages. Fixed!


    To the Other thing. I am still thinking about that part if i should implement that. Currently nope i will not add IFluidHandler support (thats the Pipe/Duct support). But maybe at the next big update

  • Nice :D But just to be sure, this is 1.6.4, correct ? if yes, will you update for 1.7.x ( not asking for a release date :P , just asking if a new version for a new MC version will be done ? :D ^^ ) ?

  • Yep 1.6.4 atm. Great for me as it is a pain to find updates or replacements for almost 230 mods xD

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

  • Nice :D But just to be sure, this is 1.6.4, correct ? if yes, will you update for 1.7.x ( not asking for a release date :P , just asking if a new version for a new MC version will be done ? :D ^^ ) ?

    1.7.10 will probably skipped. My todolist is still long. And even if i would start updating it now i would be finish when 1.8 is the main version and 1.7.10 is outdated. So i am waiting for people to say ok 1.8 is the main version now or that my todolist is finish now. That is the easiest way to handle it. When i would update to always the newest version it would take me ten times longer as normal... (Adv generators took me 2 months...)

  • Since you already updated the NEI crash, could you upload a built version of the mod with the change included please?

    Iff yu find misstaks, you may keep them! (Or tell me if neccessary...)

    The post was edited 1 time, last by Shadowlife ().

  • Since you already updated the NEI crash, could you upload a built version of the mod with the change included please?

    I will update it soon. There are some other bugs i found and i do not want to make for 1 bug a fix every time again..
    And since that is only a nei bug which you can fix by the way alone temporary with deleting the nei folder in the SpmodAPI Plugins folder (there is a save catch that will prevent crashes if a plugin is not exsisting) i will wait with the update...
    At the moment i am currently playing a little bit MC finding bugs and fixing them.
    Sorry for beeing only selfcare but i startet playing mc a couple days ago after 3-4 months only coding and no really playing...