Reactor fluid ports not working

  • I'm having some troubles with fluid reactors. Specifically fluid ports do not work. At all.

    I tried with and without fluid ejector upgrades, I have liquid heat exchangers next to the faces of the ports which are powering stirling generators powering a MFSU. Placing hot coolant cells directly into the exchangers produces power and cold coolant but the cold coolant just sits there. The reactor produces hot coolant when on but that just sits there. I tried fluid distributors and regulators, while they can get cold coolant out of the exchangers, they refuse to get hot coolant out of the reactor or put cold coolant in. I even tried pipes from a couple different mods.

    Could someoene please explain why I can't get machines to interact with the fluid ports?

    the frustrating thing is I have gotten this exact same system to work on other versions of IC but not here for some reason.

    According to the game the version is 2.2.823

  • Where about are you putting the fluid ports in the 5x5x5 structure? Are they at the edges or in the middle?

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.

    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(

    I see this too much.

  • Where about are you putting the fluid ports in the 5x5x5 structure? Are they at the edges or in the middle?

    They are on the corners currently but other positions seem to be giving me the same issues, do they need to be in specific spots?

  • And you're saying, that the heat exchangers don't get any hot coolant, but if you put it in there yourself, everything works fine? That's weird.

    The heat exchangers work fine, turning on the reactor makes it turn cold coolant into hot coolant, the only thing that doesn't work is the fluid ports.

    This is an older version of IC (It's part of a modpack on a server), and the exact same setup works fine in other versions. Did fluid ports just not work at all in that version or something?

  • I set up multiple heat exchangers for a new 5x5 build yesterday, and I was having a similar issue. Solved it by making sure both the fluid ports and the liquid heat exchangers had fluid ejector upgrades installed.

    I wasn't able to get ports to work on corner blocks, so I just use the sides and stack the rows. Have both Stirling generators and a two-stage turbines/kinetic generators running off the reactor.