Help: installation of IC2 1.15

  • i've been playing IC for a long time,
    and i've never had any problems with installation.


    from a fresh 1.8 jar,i installed modloader,modloadermp,player's modloadermp fix,minecraft forge,and then IC2 1.15.
    when i start the game, i'll get to the mojang logo and then minecraft will shut down,no blackscreen,nothing.


    here is the modloader.txt:



    Oct 3, 2011 12:31:11 PM ModLoader init
    FINE: ModLoader Beta 1.8.1 Initializing...
    Oct 3, 2011 12:31:12 PM ModLoader readFromClassPath
    FINER: Adding mods from C:\Documents and Settings\liam\Application Data\.minecraft\bin\minecraft.jar
    Oct 3, 2011 12:31:12 PM ModLoader readFromClassPath
    FINER: Zip found.


    if anyone can help me with this,please do.


  • You should probably run MC from a Batch or Shell file (Depending on OS), but I'm going to say you fall into this category:


    Quote


    + IC²'s new sound system could possibly use 200MB more RAM than your PC can provide. Be sure not to allocate more than [Your RAM] - 200MB, or errors could occur.
    If you happen to encounter this error, you can fix it by downloading Player's SoundSystem Fix and fully replacing the folder given (Delete the folder from your minecraft.jar, and replace it with the new one provided).


  • Try deleting all of your folders in the .minecraft except your save folder. Then run the minecraft.exe again and download the game. Then re install the preqs and then run the game once and then install IC2.


    I have noticed that the new IC2 version take a significantly longer time to load. I.E. the white Mojang screen stays up for a long time. Also I see to have no sound...

    All people dream, but not equally. Those who dream by night in
    the dusty recesses of their mind, wake in the morning to find
    that it was vanity. But the dreamers of the day are dangerous people,
    for they dream their dreams with open eyes, and make them come true.
    --T.E. Lawrence

  • Drop the contents of http://player.to/ic2_20111003_v115/soundsystem_update.zip into your minecraft.jar, delete the paulscode directory before.


    Thanks! That worked perfectly.


    Edit: If I save and quite from a game to load a new world the old world game sounds still play until the new world is loaded.

    All people dream, but not equally. Those who dream by night in
    the dusty recesses of their mind, wake in the morning to find
    that it was vanity. But the dreamers of the day are dangerous people,
    for they dream their dreams with open eyes, and make them come true.
    --T.E. Lawrence

  • That's a known issue and need some base file modifications. A fix within Minecraft Forge is in the works, you'll have to restart MC until then.


    Alright well then I wont do that. I will do as you suggest and make sure that I close minecraft before switching worlds.


    Also would it be possible for you to release another quiet version of the sounds. The sounds coming from the IC2 items are extremely loud compared to the sounds of the base minecraft. (I.E. The chainsaw, electric jet pack, wrench, etc are too loud )


    Edit: Also the machines are loud if it wasn't already working on something from a previous save. For example if I put cobblestone in an empty macerator it will be load. But if I close minecraft and then come back in the macerator working sound will be at the right volume.

    All people dream, but not equally. Those who dream by night in
    the dusty recesses of their mind, wake in the morning to find
    that it was vanity. But the dreamers of the day are dangerous people,
    for they dream their dreams with open eyes, and make them come true.
    --T.E. Lawrence

  • thats my modloder.text



    Mods loaded: 6


    ModLoader Beta 1.8.1


    mod_BuildCraftCore 2.2.0


    mod_BuildCraftBuilders 2.2.0


    mod_BuildCraftEnergy 2.2.0


    mod_BuildCraftFactory 2.2.0


    mod_BuildCraftTransport 2.2.0





    Minecraft has crashed!


    ----------------------





    Minecraft has stopped running because it encountered a problem.





    If you wish to report this, please copy this entire text and email it to support@mojang.com.


    Please include a description of what you did when the error occured.











    --- BEGIN ERROR REPORT a65490be --------


    Generated 10/4/11 5:29 AM





    Minecraft: Minecraft Beta 1.8.1


    OS: Mac OS X (i386) version 10.6.8


    Java: 1.6.0_17, Apple Inc.


    VM: Java HotSpot(TM) Client VM (mixed mode), Apple Inc.


    LWJGL: 2.4.2


    OpenGL: NVIDIA GeForce 320M OpenGL Engine version 2.1 NVIDIA-1.6.36, NVIDIA Corporation





    java.io.EOFException: Unexpected end of ZLIB input stream


    at java.util.zip.InflaterInputStream.fill(InflaterInputStream.java:223)


    at java.util.zip.InflaterInputStream.read(InflaterInputStream.java:141)


    at java.util.zip.ZipInputStream.read(ZipInputStream.java:146)


    at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:92)


    at java.util.zip.ZipInputStream.getNextEntry(ZipInputStream.java:70)


    at ModLoader.readFromModFolder(ModLoader.java:1173)


    at ModLoader.init(ModLoader.java:824)


    at ModLoader.AddAllRenderers(ModLoader.java:186)


    at aam.<init>(aam.java:61)


    at aam.<clinit>(aam.java:10)


    at net.minecraft.client.Minecraft.a(SourceFile:259)


    at net.minecraft.client.Minecraft.run(SourceFile:629)


    at java.lang.Thread.run(Thread.java:637)


    --- END ERROR REPORT e99d8da9 ----------





    can sumone help

  • Non of those fixes worked for me.
    i have never had problems before with the mod.


    Have buildcraft installed as well.


    Heres modloader txt


    Fixed Spoiler


    Please help

  • Don't know why yours dosen't work. I installed on a fresh MC download 1.81 and installed the required mods in the order as outlined in the OP. I also added BC 220, RedPower v2 pre-release, EqEX 416 and non-forge mods, having problems with the portal gun mod. The only problem I had was with the sound but the soundplayer fix solved that.


    Are you using the latest jre 7? That is what I'm using.



    Just noticed your on Apple, I'm using Win764bit

  • i've installed the fix,but it's still crashing.


    here is what cmd gave me.



    is it possibly because of XP?

  • the error report mentioned in cmd says this:


    pt 1:

    </init></init></init>

  • pt 2:

  • Miner7747: Something breaks in OpenAL during the initialization. Try disabling the sounds in the IC2 config.
    Snipey: You don't have MC Forge 1.1.1


    my config is blank,i think that minecraft shut down before the contents were created. can someone post the conents of the IC2 config please?