[Addon V1.36] Dynamo -> [BTW v3.0] [IC² v1.23]

  • Fixed the dynamo not sending energy when the world reloads, fixed the config file issues (more info inside Readme.txt) and changed output to 2EU. New file on first post

  • I downloaded


    Dynamo 1.2:
    Requires Minecraft 1.8.1, BTW v2.95 and IC² v1.15
    Download here


    Dynamo 1.0:
    Requires Minecraft 1.7.3, BTW v2.94 and IC² v1.00
    Download here


    But both same For Minecraft 1.8.1, BTW v2.95 and IC² v1.15. Then i try this one its for Minecraft 1.7.3, BTW v2.94 and IC² v1.00


    jorgebonafe has attached the following file:

  • Still getting the same error on WorldGeneration... Installed it 3 times (once by deleting all already internal files and then re-adding them from a fresh download), and still got this bug...

    Would anyone like to try a Slowpoke Tail?! Only 1 Million Yen!


    Quote

    this isn't about arrogance or ego, I have a block that I put a lot of freaking work into


    Every Mod Author, in existence. And yet, you STILL say otherwise.

  • Fixed the dynamo not sending energy when the world reloads, fixed the config file issues (more info inside Readme.txt) and changed output to 2EU. New file on first post


    hmm.. re-packaged it as a .zip, dropped it in the mods folder, dropped config file in it's place and still not getting power on world load. (had a derp moment for a bit, no power! realized the bat-box was full after doing a few things) Not a huge deal but I figured i'd point it out.
    you said it was supposed to be reduced to 2/t from 4? i'm getting 3 from each of the dynamos, total of 9/t.


    I'd provide my save but i've got an interesting mix of mods and basically all of BTW got their Item IDs reassigned :)

  • I'll check again.... it worked for me, but maybe I missed something.....


    Wonder if it's just a odd mod interaction that i've got going on. I'll set up something separate later with just IC2 and BTW. (later because my hand's not liking me at the moment)


    I've sorta gone a little out of control with the dynamos. I really don't need this much power right now yet i've got this nice 3x3 grid of 9 now. A Bit expensive but totally worth it as the power only fails in the rain. Even then it only fails there because i'm too lazy to go hunt down some cow to make glue.
    Course the eventual plan is a EV wire to a miner off in the distance but i'll need some diamond for an upgrade to the bat-box first.

  • Great addon. We needed something like this. Any chance of it being made to double as a gearbox? Perhaps side outputs for axles? If not, that's all well and good, too.


    :Nuke TNT: x64
    You've earned some recreation! :3

  • For Electric -> Mechanical, I was thinking about using a new axle (not block) instead...
    ------------------------------
    Steel Axles
    _ :Refined Iron: _
    :Rubber: MinecraftSlime :Rubber:
    _ :Refined Iron: _
    where:
    :Refined Iron: : Steel
    :Rubber: : Rubber
    MinecraftSlime : Slime
    _ : empty Space


    |OR| :Resin: instead of MinecraftSlime to allow for item interchange between the two...
    -------------------------------
    That way you could keep the same block, and BTW's tech tree can be preserved...

    Would anyone like to try a Slowpoke Tail?! Only 1 Million Yen!


    Quote

    this isn't about arrogance or ego, I have a block that I put a lot of freaking work into


    Every Mod Author, in existence. And yet, you STILL say otherwise.

  • God, this was annoying! Trying to understand undocumented code is a pain in the ass :P


    I believe it is fixed now... Hopefully... Check the output again? It should be 2EU now....


  • Wonder if it's just a odd mod interaction that i've got going on. I'll set up something separate later with just IC2 and BTW. (later because my hand's not liking me at the moment)


    I've sorta gone a little out of control with the dynamos. I really don't need this much power right now yet i've got this nice 3x3 grid of 9 now. A Bit expensive but totally worth it as the power only fails in the rain. Even then it only fails there because i'm too lazy to go hunt down some cow to make glue.
    Course the eventual plan is a EV wire to a miner off in the distance but i'll need some diamond for an upgrade to the bat-box first.


    ok, made a copy and ripped out the rest of the mods. the EU Reader is still reporting 3 EU/t


    in other news: built a 5x5 array with TMI and a bunch of glass fiber cable just because. Large arrays are possible but they rapidly get to the tons of resources stage so 2 or 3 EU/t will definitely feel about right, depending on what you want to do. They also take up a *lot* of room.


    plus there's inherent limits to how many you can pack in without even more resources on Bat-Boxes of MFE's.

  • Are you sure about the reading? I can't get 3EU here no matter what, not even if I put the bat box glued to the dynamo's output, its still 2EU.


    What configuration are you using for the blocks? I mean, positioning in game, not Ids... Are you using windmill or water wheel?


    By the way, i'm only updating version 1.2, so forget about 1.0, I wont work on it anymore

  • WorldGeneration bug fixed. Loaded my world and simply checked... 2 EU/t output as according to the EU Reader..


    Nice work! :thumbsup:

    Would anyone like to try a Slowpoke Tail?! Only 1 Million Yen!


    Quote

    this isn't about arrogance or ego, I have a block that I put a lot of freaking work into


    Every Mod Author, in existence. And yet, you STILL say otherwise.

  • Are you sure about the reading? I can't get 3EU here no matter what, not even if I put the bat box glued to the dynamo's output, its still 2EU.


    What configuration are you using for the blocks? I mean, positioning in game, not Ids... Are you using windmill or water wheel?


    By the way, i'm only updating version 1.2, so forget about 1.0, I wont work on it anymore


    My main save i'm using a wind mill. In the test case I used a water mill. Same results on both.


    have one gearbox from the power source down and initially to a 3 way split that later got expanded to a 9 way vertically from the 3 way. (same as the pic, just add 2 more layers)


    using glass fiber cable to connect it all to a bat-box.


    and yup, measure right outside any given dynamo and I get a 3 EU/t reading.


    hmm... that's odd, downloaded the latest version just now (1.2), extracted it to a folder off of mods (had it in a zip before) and Modloader reported this:
    FINE: Mod Loaded: "mod_JBDynamo 1.1" from mod_JBDynamo.class
    Oct 06, 2011 11:27:10 PM ModLoader readFromModFolder


    ok... color me *very* confused. it all works fine now, despite it being the exact same download, just in a slightly different location. getting 18 EU/t now from the massive array.
    The reason I use the mods folder is that it's tons easier dealing with that then stuff in the .jar, also tons easier to upgrade or remove stuff. I've got the core files and APIs in there sure but anything else gets dropped in the mods folder.


    thanks for the effort either way. Apparently a .zip in the mods folder acts a bit different than just extracted to it's own folder.
    Although I really do need more power.. i've been procrastinating on the solar farm I sorta need to build. (the dynamos are nice but won't be enough for a mass fab off somewhere)
    More than enough for a bank of Macerators though, just not enough for a couple Induction furnaces, those are nice but are rather power hogs.

  • Quote

    hmm... that's odd, downloaded the latest version just now (1.2), extracted it to a folder off of mods (had it in a zip before) and Modloader reported this:
    FINE: Mod Loaded: "mod_JBDynamo 1.1" from mod_JBDynamo.class
    Oct 06, 2011 11:27:10 PM ModLoader readFromModFolder


    Yeah, ignore that... its really 1.2, I just forgot to change the version number on the code :P



    Quote

    ok... color me *very* confused. it all works fine now, despite it being the exact same download, just in a slightly different location. getting 18 EU/t now from the massive array.
    The reason I use the mods folder is that it's tons easier dealing with that then stuff in the .jar, also tons easier to upgrade or remove stuff. I've got the core files and APIs in there sure but anything else gets dropped in the mods folder.


    Yeah, I didn't make this compatible with installing like that. Actually, I didn't even bother to see how to do that, just wanted to finish the mod and it didn't seem important. So for now you should just install it like its on the instructions or there will probably be unexpected results...



    Quote

    Although I really do need more power.. i've been procrastinating on the solar farm I sorta need to build. (the dynamos are nice but won't be enough for a mass fab off somewhere)
    More than enough for a bank of Macerators though, just not enough for a couple Induction furnaces, those are nice but are rather power hogs.


    Well, I guess that means its usefull but not overpowered, so, mission accomplished :P

  • Well, I guess that means its usefull but not overpowered, so, mission accomplished :P

    That's pretty win right there, imo...


    Any thoughts on 'Steel Axles'? (good, bad, or otherwise?)

    Would anyone like to try a Slowpoke Tail?! Only 1 Million Yen!


    Quote

    this isn't about arrogance or ego, I have a block that I put a lot of freaking work into


    Every Mod Author, in existence. And yet, you STILL say otherwise.


  • Any thoughts on 'Steel Axles'? (good, bad, or otherwise?)


    Maybe, but I think I rather make a new block. since I'm already using entities for IC, I can easily make a new block using the same ID. But I wont do that for a while. Real life calls :P