Crash when launching with IC2.Classic.Version. installed

  • Hello! I am trying to create a modpack to play with my friends, but first I started by modifying existing ones like Tekkit Legends and FTB Ultimate and everything ran with no problem, but the last mod I tried to add to FTB was IC2 (the same version installed in Tekkit Legends). The version in FTB was "Industrial-Craft-2-Mod-Experimental-1.7.10" and the one in Tekkit Legends "IC2.Classic.Version.".

    The problem comes in when I try to launch the game and it crashes, the crash report is attached since it was too long XD

    It says the error comes from "ic2/core/block/machine/tileentity/TileEntityStandardMachine" which I saw is missing frome the IC2 classic files, I even tried copying it from the IC2 Experimental files and didn't work.

    So I wanted to know if there's a way to solve my problem? Thanks!

  • You have a addon that requires IC2Experimental. Check out all your IC2 addons.
    Also IC2C on 1.7.10 the latest version is 1.2.x.x you have a very outdated version because Tekkit DOESNT UPDATE SHIT!

  • Thanks, but now I removed the addons and installed the version of IC2C. I am now having a different crash:

    Does it mean I forgot to remove an addon?Full report is attached.

  • Go into the IC2 Config and remove the Line that contains the Recycler Blacklist. There isa Config Folder for your Mods in the same directory where the Mods Folder is.