Stuck in teleporter when using it

  • What's up everyone =)


    so even after doing some research, I still have the problem that I always get stuck inside the teleporter when I'm using it. The character is stuck in the teleporter, but always bounces up and down like the camera does and the only way to free myself from it, is to use double jump in op mode to make my character fly.


    By now I ended up clearing all blocks around and above the teleporter, because I was hoping I maybe get pushed to the side, but nothing. I also ended up using a chunk loader (check modlist below) around both teleporters I'm using and even tho it seems the chuck loading works fine, I still get stuck in the teleporter. After installing that chunk loader mod, I also noticed another chuck loader as a power tier 1 machine of industrial craft which I've never seen before and can't find any ic wiki information about, but even getting this machine to work didn't fix the issue.


    Right now I'm a bit clueless so I thought it couldn't be too bad asking in the official forums about help and I would be glad if someone can help a little.


    == Used Mods (minecraft 1.12.2) ==

    Forge 1.12.2 14.23.5.2838 (latest)

    Industrial Craft 2 - 2.2.8.111 - ex112

    CodeChickenLib 1.12.2 required for: ChickenChunks Mod 1.12.2 (the chunk loader mod)

    Guide API 1.12.2 - 1.8-63 + RedstoneFlux 1.12.2 - 1.0.6 both required for MFFS 1.12.2 - 4.0.1.0

    Worldedit Forge 1.12.2 - 6.1.10


    Greetings

    - FlizzyDuck

  • This used to be a problem on servers, it appears the client has acquired it too. Whilst the teleporter aims to teleport above itself by half a block, until the new chunk arrives the player falls which causes them to sink into the destination teleporter. It is probably worth trying having a second player sit by the destination teleporter and see if it is the client receiving the chunk which is slow or its loading it that is the issue.

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • Hello :)


    sorry took a little while, but now we have tested it with 3 different players and all 3 characters got stuck in the teleporter even if another character stood next to the teleporter destination.


    Edit to make it even more weird: I placed another teleporter like 12 blocks away from the destination point (based on the chunk loader mod it's even the same chunk) and voilà teleportation worked fine. Now I destroyed that new teleporter, but then placed a newer teleporter at the same location like the last new one and it doesn't work anymore...


    Is there any requirement (in whatever weird way someone could think of) when placing a teleporter or when using the Transmitter to set up the connection or anything?