1.23 Bug: Mod not working with latest lwjgl.

  • I tried installing the latest lwjgl, it was working fine without IndustrialCraft with other mods such as buildcraft. The mod works without the latest lwjgl and the same minecraft.jar.
    The problem is that the game crashes at the Mojang splash screen if both are installed.

    I'm using java 7 on 64-bit Windows 7.
    I don't know if there are any error logs on this, the ModLoader.txt doesn't show that anything is wrong.

  • I actually tried with and without the soundfix, if you're thinking about the soundsystem_update thing. Didn't make a difference, still crashed the game.
    I used it before but I upgraded from java 6 to java 7 today and the sound now works without the soundfix.

  • Gives me this, with or without the soundfix.

  • That screams 'lwjgl' not being installed, or since you insist that it is, the wrong version of the library. If you have 64 bit /java/ you need 64 bit libs. If you have 32 bit /java/ (even on a 64 bit OS) you need 32 bit libs.

  • 1. It's installed correctly.
    2. There is only one version of the libs, and from what I see it contains files for both 32 and 64-bit.
    3. The files for both 32 and 64-bit needs to be copied over to minecraft and replace the existing ones.
    4. This is a problem with industrialcraft, since removing this only this mod makes the game work.
    5. I might have done the error log thing incorrectly.

  • Well, that was everything it returned... But I didn't do it correctly, the command in the provided link didn't work. Someone had improved it and posted it in the same thread, and that one did work. Just ignore the previous "log".
    Here is the real log, and this is the actual log after minecraft crashed. It's not very interesting though since it just cuts shortly after IC2 is loaded, and everything else looks normal. And yes, this IS the entire log.

  • did some testing, Minecraft works fine with latest lwjgl w/ modlloader, modloadermp, modloadermpfix, audiomod, soundsystemfix, forge 1.12, portalgun mod v3, BTW 2.98, BC 223 and RP2v2b

    When adding IC2 1.15, 1.22 and 1.23, then Minecraft does not load and Java platform crashes.

    IC2 1.15, 1.22 and 1.23 works fine with lwjgl 2.71


  • I would like to confirm the issue: I did a full mod-load, & then updated lwjgl and got the following log yesterday:

    Redid the mod-load today starting fresh, but did the lwjgl upgrade first, then all mods but IC2, and finally IC2. Only when trying IC2 1.23 at the end did I get a Java crash.

    Redoing from vanilla without upgrading lwjgl is working so far.


    P.S. BC/BC-addons/IC2/EE/RP2/Rei'sMap/PG/WR/Matmos/Somnia/assort'd Risugami & DaftPVF mods are all working together with sound, using vanilla lwjgl (2.7.1?).
    Still need to build IC blocks to see if particular sounds are good.

    P.P.S. Sounds are good for IC2 without AudioMod and with the above mods installed on vanilla lwjgl.