[Addon v1.106]PortableTeleporterv2.1.1

  • So I've been having a good time playing around with my portable teleporter, but grew tired of waiting for a single one to recharge. So what I did was made a second one and linked it to the same teleporter so that when I teleported back I could just take the spare that has been charging while I was out and about. This apparently unlinks the first portable teleporter because it now teleports me into the abyss link it is unlinked. Could we get the option to link more than one portable teleporter to the same teleporter?

  • I'll try again in a bit and report back. Actually I just used one I know for a fact was linked to the teleporter and it still teleported me into the abyss. Distance issue maybe?


    Also, the teleporter is hooked to another actual teleporter. Uses the actual teleporter in between using the portable teleporter wouldn't' cause any issues would it?

  • Is it supposed to teleport you to the void when unlinked?
    or is that just a bug?
    (I read the thread and I know that you're aware of this "feature", but do you wan't it to happen?)

  • it is an unintentional feature (origionally) that I like for the reason that it makes sense to "lose" your particles


    however since the users' opinions are more important, I will start a pole to see who wants it to just say "Teleporter does not have a target"

  • it is an unintentional feature (origionally) that I like for the reason that it makes sense to "lose" your particles


    however since the users' opinions are more important, I will start a pole to see who wants it to just say "Teleporter does not have a target"


    Maybe make an option which is off by default?


    And when is it going to be updated?

  • After watching Direwolf's videos on teleporters and this mod, I decided to give it a try today. Built a pad in my base, built the personal teleporter, linked them, and rode the long rail out to a vast abandoned mine complex about 1100m away. Teleported home with no problem! But it still means a 2 minute railcart ride to get there... so I built another pad there and linked it to the first. Tried my personal teleporter... and wound up in the Void. Had to revert to a previous save - which meant all the work I've done since last night was LOST (it was that, or all my expensive gear!)


    So I suppose you can clearly guess what my vote was. I'm reluctant to use the mod until that's fixed. I know it seems "cool" and somehow makes sci-fi sense, but there's honestly no reason the teleporter should even work without designated target data - it should be no different than the in-game ones in that regard.


    I am eagerly awaiting the fix. Those of you who feel it's "fun" to be sent someplace where you lose everything with no hope of reclaiming it, feel free to go to the Nether and jump in lava, OK?

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • Thanks, Beast. So now we will just get a "no target linked" kind of message instead of getting ported into the Abyss, right?

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • Well, that's the promise... but not the result. I just got teleported to the Void again. I am using 1.30, I didn't get a meesage. Just popped into the abyss.


    Not sure what the cause is - perhaps because I linked to the pad, saved the gmae and tried using it next time I logged in, or maybe I clicked on something besides thin air... regardless, it's still possible to be teleported into the Void.

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • OK, it seems that the teleporter forgets the link coordinates when you log off. I successfully used it before, recharged it, made sure it was linked to the destination pad and went to my mine.


    Did some mining, and logged off. Backed up my save because I suspected this would happen. Logged back in and tried the port... off to the Void. Whiskey Tango Foxtrot.

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell

  • Omg thanks now I know what I forgot, it will be updated and fixed very soon, right after I release the next AdvGenerators Mod (it's almost done)


    edit: I just realised that I still have a bit to go so I will update it now

  • Thank you for your dedicated work on these mods. It contributes to my enjoyment of the game. I don't know where I'd be without the Advanced Miner! My main world is an old one I've had since like 1.3, so naturally chunks containing IC resources are far from my main base. Between this mod and that one, it ought to be easier to go out and gather what I need!


    Looking forwward to the update and hoping it fixes the problem!

    "A stupid man's report of what a clever man says can never be accurate, because he unconsciously translates what he hears into something he can understand." - Bertrand Russell