[IC2 Exp][1.7.10] Advanced Machines 1.1.6

  • Hello!


    I am running a vanilla server with latest minecraft forge. I'm trying to install advanced machines, but whenever I try to install it, it just crashes.


    Could someone please link/explain instructions on how to install advanced machines?

  • Hello!


    I am running a vanilla server with latest minecraft forge. I'm trying to install advanced machines, but whenever I try to install it, it just crashes.


    Could someone please link/explain instructions on how to install advanced machines?

    How were you installing it?


    EDIT: is just IC2 working without Advanced Machines? Also, please read this

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

  • Server works fine with just IC2, without advanced machines.



    When I try to install, Crashes. Getting log right now. Thank you for your help :)

  • Server works fine with just IC2, without advanced machines.



    When I try to install, Crashes. Getting log right now. Thank you for your help :)</init>

    What version of Forge are you using, and are there any other mods on the server?

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

  • No crash on startup, but a few things I found:
    Seems you forgot something in the @Mod annotation:
    @Mod(modid = "AdvancedMachines", name = "IC2 Advanced Machines Addon", version = "4.2", dependencies = "after:mod_IC2")


    "after:mod_IC2" -- Industrial Craft mod class is now just 'IC2.' Instead use 'after:IC2.'


    Also, nothing shows up in creative inventory.


    -aidancbrady

  • Using newest version of Buildcraft, which is 3.2pre7.


    Not running any other mods on the server


    Version of forge is 4.2.5.303


    When I installed advanced machines, I assumed everything in the "common" folder located within the .zip was supposed to go into the "common" folder located within the IC2 .jar (which I have in my forge mods folder).

    The post was edited 1 time, last by Deviant ().

  • Wrong installation problem then, you just put the advanced machines 4.2 zip in the mods folder


    EDIT: if you want to use this mod without a null pointer exception crashing your game, you need to use the IC2 beta here

    Is the answer to this question no?


    Quote

    Hey don't take it so hard. Ignorance is part of this generation it seems. -the wise words of XFmax-o-l

    The post was edited 1 time, last by CrafterOfMines57 ().

  • I use the lastest beta of IC2 (industrialcraft-2_1.107.35-lf) and the latest AM (4.2) and I still get the "NullPointerException" crash ...
    It happens as soon as I place down an advanced machine (i.e rotary macerator)


    Any advice?

  • 2012-10-19 11:16:07 [SEVERE] java.lang.RuntimeException: java.lang.NoSuchMethodException: ic2.platform.NetworkManager.initiateTileEntityEvent(net.minecraft.src.TileEntity, int, boolean)
    2012-10-19 11:16:07 [SEVERE] at ic2.api.NetworkHelper.initiateTileEntityEvent(NetworkHelper.java:62)
    2012-10-19 11:16:07 [SEVERE] at ic2.advancedmachines.TileEntityAdvancedMachine.q_(TileEntityAdvancedMachine.java:130)
    2012-10-19 11:16:07 [SEVERE] at net.minecraft.server.World.tickEntities(World.java:1189)
    2012-10-19 11:16:07 [SEVERE] at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:559)
    2012-10-19 11:16:07 [SEVERE] at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:457)
    2012-10-19 11:16:07 [SEVERE] at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    2012-10-19 11:16:07 [SEVERE] Caused by: java.lang.NoSuchMethodException: ic2.platform.NetworkManager.initiateTileEntityEvent(net.minecraft.src.TileEntity, int, boolean)
    2012-10-19 11:16:07 [SEVERE] at java.lang.Class.getMethod(Class.java:1622)
    2012-10-19 11:16:07 [SEVERE] at ic2.api.NetworkHelper.initiateTileEntityEvent(NetworkHelper.java:49)
    2012-10-19 11:16:07 [SEVERE] ... 5 more
    2012-10-19 11:16:07 [SEVERE] Unexpected exception
    java.lang.RuntimeException: java.lang.NoSuchMethodException: ic2.platform.NetworkManager.initiateTileEntityEvent(net.minecraft.src.TileEntity, int, boolean)
    at ic2.api.NetworkHelper.initiateTileEntityEvent(NetworkHelper.java:62)
    at ic2.advancedmachines.TileEntityAdvancedMachine.q_(TileEntityAdvancedMachine.java:130)
    at net.minecraft.server.World.tickEntities(World.java:1189)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:559)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:457)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.NoSuchMethodException: ic2.platform.NetworkManager.initiateTileEntityEvent(net.minecraft.src.TileEntity, int, boolean)
    at java.lang.Class.getMethod(Class.java:1622)
    at ic2.api.NetworkHelper.initiateTileEntityEvent(NetworkHelper.java:49)
    ... 5 more


    Что делать?

  • Version 4.2B
    fixed machines not exploding
    will no longer launch without or before IC2
    will no longer launch unless IC2 is at version 1.107 atleast LEARN TO READ PEOPLE
    added automatic NEI registering. Does currently not work right. I dont know who is to blame but not me.

  • @AtomicStryker not sure if you were replying to me as I do have 107 and it does show it in the crash report I posted.



    IC2 [IndustrialCraft 2] (industrialcraft-2_1.107.35-lf.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available->Available->Available->Available->Available->Available




    As for the version 4.2b I downloaded it twice and it is showing as 4.2 and not 4.2b (file name)



    not sure what else I can try

  • I'm getting a crash that seems to be related to NEI (??). I'm not even sure why NEI would be involved unless it's in the code, as NEI (and CodeChickenCore) isn't installed on the server.


    http://pastebin.com/6kTDiXi9


    I'm running a server with IC2 version 1.107.35-lf, AM version 4.2B, and Forge #303.

  • Not sure if this was confined to me or not, but upon overloading a machine and having it explode, it will not be removed from the energynet, it ghosts and placing any wire results in an explosion. On top of this, attempting to wrench or otherwise remove a machine results in the same behavior.


    I was able to manually remedy this by modifying the onInject() code to call this.invalidate() and to modify the onActivate code to also call this.invalidate() [only if player is wrenching it]


    I also removed the NEI related line as it's simply broken.


    The below code shows how to get around the explosions from wrenching/removing the machines. (I didn't include the NEI removal code)


    BlockAdvancedMachines.java


    TileEntityBaseMachine.java