[IC v1.8.1]NEI Integration bug[Miner bug]

  • I cannot find a link. I found 3.1.4 only. Can you point me? Or you mean Forestry 1.4.2.0 ?

    He means BC and not yet but soonTM


    EDIT: Derp I did not see his reply or 2nd page. FU :P

    Check out Our Brand New GT New Horizons Server .:Here:.
    Check out Our Brand New GT New Horizons Let's Play Series .:Here:.

  • Well... seems like i'll keep using the wiki for IC2 stuff and using NEI for the rest until everything gets updated (and i believe we will be on 1.2.5 by them).

  • in the new 1.90 jar - i dont even see a neiIntergration

    Simple explanation. There is no NEI for 1.2.4 so they never put it in there, and the code in 1.9 still says

    Code
    1. if (loadSubModule("neiIntegration11x")) {
    2. System.out.println("[IC2] NEI integration module loaded");
    3. }


    and NEI is at 1.2 so should be 12x but oh well..
    Wouldn't it have just been easier to make the module like RedPower and Railcraft as its own thing?? seems like that would stop stuff like this from happening

  • The code wasn't loading the new submodule name, but the submodule also wasn't included in the jar by the build script o_o


    Player fixed it by reverting the name, I swear to Notch that the NEI integration will be in the next version.

  • I understand this thread has been touched multiple time now, I run a server as well, we where at 1.1 and just now it up to 1.2.3 then we found out they released 1.2.4 so we started looking into that then we found out that right after 1.2.4 was released they turned around and released 1.2.5 faster then we could even research mod updates for 1.2.4, so we've decided to stick with 1.2.3 for a while now until major updates happen... to avoid the hassle


    that being said, I have to agree with the folks on this thread first and foremost, having IC2 compitable with the MC ported version of NEI (Not enough items) for 1.2.3 (Even vanila) Would be helpful both to bukkit users and Vanila, we're currently trying to test out our server and its getting to be a headach having to build certian things and see what works and what doesn't be fixed and what doesn't


    if there is any work around ans please post it, I Would be greatful, but I have to agree with getting a 1.2.3 compatible out... I understand its work but as many people said, 1.2.4 is being skipped by many authors, (Theres still a good chunk that released updates for it) but from what me and my team have noticed, folks are going to stay on 1.2.3 for a while. (a good chunk anyways)


    ~Miralindo Owner of Spiritcraft Server

  • Well is there any Solution around this problem? anything we can change to Ignore the IC2 layers or something?


    I'm not trying to cause a fit just asking.

  • Both me and my server tech wanted to thank you for this fix, It works and we greatly apprciate you taking a moment to let us know this :)


    ~Gives happy face image~

    Delete the ic2/neiIntegration11x folder in the IC2 jar.

  • ChickenBones linked me this.


    http://www.chickenbones.crafts…I%201.1.3%20Hotfix%20.zip


    It appears to be the submodule code he gave me, compiled for 1.2.3. Give it a shot.


    Made an account just to let you guys know this fix works! I've been trying to get NEI working again on MC 1.2.3, this hotfix solved the 'crash when looking up IC² recipes' problem for me.


    For all those other mod noobs (like myself) out there: the contents of the ic2 folder go into the IC² 1.81 mod jar. The Packager.class file goes into minecraft.jar.