[Unofficial][SSP/SMP] Way to make IC2 v1.90 working on MC 1.2.5 with forge 3.x

  • You still need modloader installed and modloader mp too

    So say that. You're right, and it now works, but since the whole reason IC2 1.90 is incompatible with MC 1.2.5 as released is because of Forge dropping support for--in fact, becoming incompatible with--ModloaderMP, that information is not intuitive but is absolutely critical to distributing any community-made patch. It also forms the beginning of an answer to TartarusMkII's question, which you still have not answered. What you've done is to patch the IC2 .jar file so that its calls to ModloaderMP do not trigger the incompatibilities with that tool that were introduced by Forge 3.x. It'd be even better if you explained what it is about those calls you changed, so the extent of your alterations could be predicted.


    That said, thank you for clarifying and for creating this.

  • I have changed forge version checking from 2.x to 3.x(no major changes from forge for 1.2.4 so most of forge mods should work this way) , its true that forge 3 is droping mlMP support but for my patch both are required ml and mlMP, and by this time no conflicts beetwen mlMP and forge 3, but there will be when forge strictly drop mlMP support, becouse forge for MC 1.2.4 need it (forge 2) in this (lastest ml, mlMp, forge 3) configuration as on sceenshots it works fine with, to make it runnig make proper installation of ml, mlMP, forge than replace original class from IC2 v1. 90 with mine,


    Thats temporary solution until official update

  • Thank you very much ! It's working great for me. I can run BC 3.1.5 + IC2 1.90 + RC 4.3.0 + Craftguide 1.4.4 :).


    Thanks a lot, you made my day ;)


    Edit : I may have posted too early. RailCraft is crashing the game by a nice "Saving chunk" screen each time I open my inventory or the chest where I keep RC stuff. Too bad :/ . A third of my world is based on RC ...
    Any idea to get the thing working ?

  • This is giving me issues.


    Not sure how to do this, I suppose. I do what he said. ( Extract the .jar, it turns into a folder, replace the .class) But what do I do after that? ( Sorry if I seem like a noob. ) do I just drag the folder into the mods folder? Do I add .jar to the folder and THEN drag that folder into the mods folder? Do I compress it, rename that .zip into a .jar THEN put it into the mods folder? :s I'm new to mods. ( And FYI I'm on a Macintosh ) :S

  • This is giving me issues.


    Not sure how to do this, I suppose. I do what he said. ( Extract the .jar, it turns into a folder, replace the .class) But what do I do after that? ( Sorry if I seem like a noob. ) do I just drag the folder into the mods folder? Do I add .jar to the folder and THEN drag that folder into the mods folder? Do I compress it, rename that .zip into a .jar THEN put it into the mods folder? :s I'm new to mods. ( And FYI I'm on a Macintosh ) :S


    extract replace class zip it and rename to jar on windows just using winrar to open jar and drag anything u want inside:D, than use like a normal mod :D

  • Did it like you said, minecraft opens just fine, BUT, I go into creative mode.. and there's only additional items from Buildcraft ( which I have installed ) and nothing new/from industrialcraft.. :/ Do I need content packs or something??

  • Okay, so here's what I've done..


    extract the industrialcraft.jar, replace the class, compress it so it's a zip, rename the zip so it's a jar, drag that jar into my mods folder.


    Minecraft boots up fine, but TMI and creative mode are showing me NO industrialcraft items. The heck I did wrong?

  • You still need modloader installed and modloader mp too


    ah doh, im guessing thats why theres no 1.2.5 version of ic2 its gonna take them time to remove all of the modloadermp stuff.
    I did hear last night that there is a 1.2.5 version just not released, but that doesnt make much sense unless its too buggy ?
    quess its the waiting game yet again, ic2 is always so slow to update :(

  • Hello guys. It doesn't work for me... I get this in the server console, I'm using Forge 3.0.1.75 since that's the "recommended" version. I must say that I have ModLoaderMP 1.2.5 from SDK:
    NOTE: I've tried with Forge 3.0.1.84 but I get the same problem.



  • read my instruction again than again until u figure why it doesnt work :D (did u apply my patch to IC2? :D)


    BTW. testing SMP fix now will publish it when it will fully work without bigger


    [EDIT]


    modified class zip contains now both SSP and SMP modified classes, instructions and problems in the first post

  • thx for the fix for SMP your a big help. 8) :D
    here you earned this :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: :Industrial Diamond: !!!!

  • :) Thx for your update for 1.2.5,but it seems that I can't config the block ID when using this version.A bug can be fixed? ;(

  • You Sire are awesome! Im setting up an server atm and messing around with IC2 and the Forge conflicts. U solved my whole problems wich kept me busy for about 4 hours. It took me 20 seconds to dowload, put it in the ic²-server-file and it works as charm. no errors in serverlog so far, checking if its stable


    I use: MC 1.2.5 server jar
    Forge .84
    newest MLMP from SDK



    If u cant get it to work maybe try a fresh installation.


    TrinityCraft Server, Whitelist.


    Ic2/BC3/Forestry Railcraft/Logistics Pipes/Nuclear Control and more!

  • Great it works..


    Nice to see someone actually doing something pretty fast.


    Just getting a comp issue with BC, but on its own i run ic fine until the dev gets ready to release something.

  • delete all old mod configs (may corrupt exisitng worlds) and there shouldnt be any comp issues, i am running BC 3.1.5, IC2 v1.90, AdvancedMachines_3.9, SeedManager_v1.2.1, -additionalbuildcraftobjects, LogisticsPipes, additionalpipes, IC2Thermometer_v1.1.12_Client, and it works fine all together, only what does mod need to be based on lastest forge for MC 1.2.4 and to be updated to MC 1.2.4 than almost all mods should work on MC 1.2.5 without bigger changes

  • I don't know what I did wrong, but I follow the instructions to a T, and still no industrialcraft items show up ingame.


    Could it make a difference that I installed modloader/modloaderMP/forge through MCPatcher? I did Buildcraft while those 3 mods were installed with mcpatcher, and it works fine.
    Only mods I had in when I was trying industrialcraft with buildcraft and its packs. Will try it without them.


    :/

  • Tried it AGAIN, download IC2 jar, and your .class, unarchived the IC2 jar, replaced the .class, compressed the IC2 folder making it a .zip, renamed it to a .jar, dragged that .jar into my mods folder, booted up minecraft, looked at creative mode and TMI listings, nothing from IndustrialCraft.
    I had no mods installed except Modloader, ModloaderMP, forge and TMI.


    So what went wrong? Minecraft boots up, but no IC items in TMI or creativemode. Also tried refining iron, ETC and nothing came of it.


    What'd I do wrong!? :S :wacko: 8| ?(



    Other question; If you've made this, couldn't ( Hypothetically ) Alblaka use your .class? :huh: