[Bug?] eloraam's red power not working with machines.

  • hi. i am sorry if this has been said before, but i noticed that while using eloraam's red power mod redstone wires does not work on any machines of IC2.


    it works well with BC but not IC.. is this an IC2 side bug? or red power?


    thanks in advance.

  • can you show example?



    ok, confirmed. it is not. I need to use a redstone powder bridge.


    Please ignore this floating platform with 10,000 solar panels. Nothing to see here.

  • was going to submit a screenshot but u already did.. as u can see u cant link redpower wires to any of ic2's machines.. and tbh that is very annoying since i got used to them now xD

  • however, in this way, it works.


    I suspect it is a redpower feature than bug.

    Please ignore this floating platform with 10,000 solar panels. Nothing to see here.

  • yes on blocks that u can put wires on the sites and top but if u try putting it on a batbox or other blocks like that it wont work.

  • while playing around with that, if i press shift while clicking around with wires, you MIGHT be able to place the wires.

    Please ignore this floating platform with 10,000 solar panels. Nothing to see here.

  • ya that works. but i have to use un-insulated wire.. i am not a programmer or anything so i am kinda confused about witch mod have the bug\conflict as they both use minecraftforge.

  • ya that works. but i have to use un-insulated wire.. i am not a programmer or anything so i am kinda confused about witch mod have the bug\conflict as they both use minecraftforge.

    I might be something in IC2, as Eloraam said she can't do anything about blocks not knowing that they are able to accept power? Not totally sure though, I know nothing about coding :p

  • I might be something in IC2, as Eloraam said she can't do anything about blocks not knowing that they are able to accept power? Not totally sure though, I know nothing about coding :p

    This is how redpower is supposed to work, insulated wire only works with redpower or vanilla objects, to use other addons redstone signals you need to use uninsulated wire between the addons object and the redpower circuits.

  • The confusing part is that RP wires connect to the MFSU for example, but still won't work on it until you attach the wire onto it.

    On my install Mining Drill doesn't give off any sounds at all o.o
    Help! Somebody fix that please!
    Wait a sec... damnit.

    no idea if he was serious but either way that was damn funny xD

  • Ok I asked Elo about it and it seems the problem is the powerlevel needed for the effect.
    I guess if the storages would be changed to work with indirect powering (I guess that's the same as running redstone over a block next to it) it would work with just connected RP wire too.
    She mentioned that it now only reacts to strong power (I guess even a direct connected RP wire gives less) but what that means does only one know that modded with redstone so I don't XD

    On my install Mining Drill doesn't give off any sounds at all o.o
    Help! Somebody fix that please!
    Wait a sec... damnit.

    no idea if he was serious but either way that was damn funny xD

  • Ok I asked Elo about it and it seems the problem is the powerlevel needed for the effect.
    I guess if the storages would be changed to work with indirect powering (I guess that's the same as running redstone over a block next to it) it would work with just connected RP wire too.
    She mentioned that it now only reacts to strong power (I guess even a direct connected RP wire gives less) but what that means does only one know that modded with redstone so I don't XD

    Didn't realise it was you. Was coming here to post the question and answer that Elo posted:


    Question:


    Well I think there's a slight weird problem with RP wires in IC2 v1. The thing is that you can power a energystorage to prevent it from distributing it's energy.


    A RP wire on that block does what it should. The weird thing is that RP wires connect to said block but then it doesn't work.


    So any idea how that can happen?
    You mentioned an rs flag somewhat earlier when someone said jacketed wires won't connect to BTW's light blocks but I guess since it connects that's not the issue in this case, I guess?


    Answer:


    Yep, that just means that the energy storage unit only turns off when it receives strong power, despite setting the connection flag. Nothing I can do, that problem is on the IC² side.


    RedPower is a lot pickier about these things than regular redstone, so it's easier to see when they don't quite work right with RP wires.

  • is it safe to bug alblaka about it then?


    if so.. Alblaka, Oh Almighty One... PLX Fixorz

  • I noticed that when placing cables next to batbox/mfe, it doesnt open the charging interface. Would same be possible with RedPower wires?

  • Well the interface in Forge was a dead end, that's just a fancy per-side version of canProvidePower (which is awesome, but not what we needed here). But changing to accept indirect power did work, so we may be doing that.


    Edit to update: Redstone-sensitive IC2 machines will now react to indirect power, should be in the next version.