Bored? Random IC2/Forum chat

  • I checked that with the chamber, it returned true for has reactor, but nil for all the get methods, which was what prompted me to post that. And how would I do the Lua table thing? I'm not really experienced with Lua

    My favorite...

    Armor: :Quantum-Helmet::Quantum-Bodyarmor::Quantum-Leggings::Quantum-Boots:

    Item: :Uranium::Uranium Ore::Reactor:

  • I checked that with the chamber, it returned true for has reactor, but nil for all the get methods, which was what prompted me to post that.

    Most strange, if it has an attached reactor to get the values from it shouldn't have trouble doing it. I presume wrapping the reactor itself is getting valid values rather than nil too?

    And how would I do the Lua table thing? I'm not really experienced with Lua

    That was an idea for the addon to give you a table as a return value for a getReactorStatsesque function. Just a concept to allow much greater monitoring (if you were so inclined) without having to add dozens of individual functions. Although of course individual functions are friendlier to performance when being polled frequently.

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.


    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(


    I see this too much.

  • Yes, works fine when wrapping an actual reactor. I feel that for the less Lua-skilled people here, functions would be easier to work with, if you find time to improve this ;)

    My favorite...

    Armor: :Quantum-Helmet::Quantum-Bodyarmor::Quantum-Leggings::Quantum-Boots:

    Item: :Uranium::Uranium Ore::Reactor:

  • Hi! CrossVas , Chocohead

    My game keeps crashing with this error massage. I hope somebody can help.

    On PC it works, but on the laptop - no. I don't understand why.


    An invalid crafting recipe was attempted to be added. This could happen due to a bug in IndustrialCraft 2 or an addon.


    (Technical information: AdvRecipe, unknown type)

    R: 1xitem.nanoBow@0

    O: null

    T: null


    The game will exit in 30 seconds.


  • Can I see the your list of mods?

  • That's odd. It shouldn't matter what you run on, PC ore laptop, the problem is in the modpack. Make sure that the modpacks are 100% identical. Copy the instance from PC to laptop and see what happen. And update the mods to the latest version.

    EDIT: Also provide the latest log file located in <minecraft_directory> from laptop.

  • They're 100% identical on the PC and on the laptop.


    EDIT: added logs from PC and from laptop.

    Files

    • log laptop.txt

      (113.28 kB, downloaded 65 times, last: )
    • log PC.txt

      (360.48 kB, downloaded 71 times, last: )

    The post was edited 1 time, last by Yura ().

  • 2019-12-28 20:19:05 [INFO] [STDOUT] Java: 1.8.0_211, Oracle Corporation - On PC
    2019-12-28 20:13:48 [INFO] [STDOUT] Java: 12, Oracle Corporation - On Laptop

    Downgrade Java on laptop to 1.8.0 ( Java 8 ) and try again.

  • Log says the opposite.
    Find "Control Panel - All Control Panel Items - Programs and Features" and look for Java. There should be only one JRE (and JDK optional). If there are more than one remove it. For minecraft you need Java 8

    EDIT: What launcher do you use?

  • CrossVas

    I deleted Java from Programs and Features and downloading jre-8u211


    EDIT: But in Programs and Features there was Java 8 only installed.

    The post was edited 1 time, last by Yura ().

  • EDIT: Ok, all works now. I didn't see a JDK 12 in Programs and Features. I deleted it and all now works.

    Thank you for help :) <3

    The post was edited 1 time, last by Yura ().