[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • i can't start server with fastcraft
    console only say this: A problem occurred running the Server launcher.root@vps


    log say:

  • could you add a feature that would allow things like seeing the sky even at the lowest view distance or the ability to turn off animated textures?

  • Thanks Hazado, this bug should be fixed.


    New test build at http://files.player.to/fastcraft-1.18.jar




    firstarchon: Features of this sort are not my focus atm. I do have some ideas for "lossy" tweaks later on. Being able to see the sky regardless of the view distance is presumably quite difficult without making the world border too visible in some cases. FastCraft should already make animated textures significantly faster.


    crunkazcanbe: This is most likely not a FastCraft issue, check/post your log right before the crash. It may contain useful information about the source of the problem.

  • Most likely it is a mod that adds things to villages because all i see in the logs is village and fastcrast so most likely your mods not compatible with one of the 10 mods I have installed that alter villages i guess ... If I crash again can I give you the full log , and see if you can tell what mod is doing it ? Because I am stupid when it comes to things like this . :(

  • I'm having the same bug as crunkazcanbe (or at least the stack traces look similar). Here's a full crash report: http://pastebin.com/jpu7e58w


    Tested with:
    Fastcraft: 1.18
    Forge: 10.13.2.1277


    crunkazcanbe: If you post the full crash report, we may be able to compare mod lists to get a better idea of what's causing the crash.



    EDIT: Never mind. Removing fastcraft didn't fix the issue. Apparently it was just masking the root cause.


    EDIT 2: I removed Fastcraft, and that didn't fix the problem. I ended up deleting everything but the region files, and now everything is working. My suspicion is that crashing at that moment corrupted the village data. (Fortunately it was just a mining dimension, so no loss there!)

  • As mentioned earlier, this happens without FC, even in MC 1.6. The part of FastCraft you see in the stack trace is very simple pass-through code setting a FC-internal variable to know MC is generating terrain right now. It's really not more than replacing mc.doSomething() with fc.doSomething() { itsDoingThis = true; mc.doSomething(); }, i.e. wrapping the original call with the very same state and parameters. There's not much room for incompatibility at this very specific location, even if someone edited said mc.doSomething() via a coremod.


    I googled the specific crash location once and a bug tracker entry for one of the major world gen mods indicated some mod(s) not having its structure generation code adjusted to more recent vanilla changes.


    The debug logging FC 1.17+ does before said crash is supposed to give a hint about what's wrong. You have to check your fml-server-latest.log (or client for sp) right before MC/FML logged the crash stack trace the first time. FastCraft catches the exception, logs some extra info and them re-throws it. It's being logged as ERROR, just grep/search the log for it, presumable 3 lines worth of "[Server thread/ERROR] [FastCraft/FastCraft]".


    I'm not that interested in this specific crash issue because of FastCraft, which doesn't seem to contribute to it, but it's about time to get investigated and fixed ;)


    Cobra1117: In all likelihood you'd have experienced your edit 2 case with FastCraft installed as well, regenerating just fixes the corruption in any case. Since MC doesn't normally save the world after/during a crash, it was most likely already corrupted before you had the original crash. I've put some protection against crash related save corrupted into FML a while ago, so this is to be assumed more complicated than you suspect.

  • Cobra1117: In all likelihood you'd have experienced your edit 2 case with FastCraft installed as well, regenerating just fixes the corruption in any case. Since MC doesn't normally save the world after/during a crash, it was most likely already corrupted before you had the original crash. I've put some protection against crash related save corrupted into FML a while ago, so this is to be assumed more complicated than you suspect.


    Cool. In that case I'll put FastCraft back on the server. Thanks for the info! :-)

  • Yeah got one of my first crashes with fastcraft with version 1.17 as well.. Think the crashlogs were similar to the ones posted.


    1.18 runs so far without crashes but I've noticed quiet a bit more chopiness/lag spikes with it so far.. Not 100% of course if it is related but 1.16 and before appeared to run better...


    I have to admit, it is rather subjective and hard to measure so I'll give 1.18 a spin for a couple of days. :)


    But great work on one of the most useful mods in MC!

  • Player: quick question for you on the topic of redistribution. I know you've stated that you don't want redistribution of your mod and I respect your stance on that. Does that include things like mod repos for TechnicSolder? Currently, I have my solder install pulling from my other server as a mod repository. Basically, All the mod repo exists to do is provide incremental update support via MD5 hashing of the archives contained on it. If you'd like, I can try and figure out a way to completely lock the repo down so that only users of my friend's pack can use it. The repo isn't public, just as an FYI. It is out on the internet, but unless the person knows the server address, they're not getting into it.


    EDIT: Also, I still download the mod from your server and then just package it as a ZIP archive for Solder and upload it to my mod repo and add the new version to Solder.