[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • http://files.player.to/fastcraft-1.25.jar should fix the optifine-shaders issue, I can't fully test it with this PC though.


    Hi Player


    I tested this version and it works fine with Optifine D7.


    The only problem i have my game have 2 fps only before it was 40-60.


    I using it in a Modpack with 200 mods.


    https://github.com/GTNewHorizons/NewHorizons

  • fastcraft 1.25 not compatible with ChocolateQuest EntitySchematicBuilder
    when I use fastcraft 1.23 it was fine.
    Any idea what is going on?


    java.lang.ClassCastException: com.chocolate.chocolateQuest.entity.EntitySchematicBuilder cannot be cast to net.minecraft.entity.EntityLivingBase
    MC: at net.minecraft.client.renderer.entity.RendererLivingEntity.func_76986_a(RendererLivingEntity.java:501)
    MC: at net.minecraft.client.renderer.entity.RenderManager.func_147939_a(RenderManager.java:293)
    MC: at net.minecraft.client.renderer.entity.RenderManager.func_147936_a(RenderManager.java:271)
    MC: at net.minecraft.client.renderer.entity.RenderManager.func_147937_a(RenderManager.java:244)
    MC: at fastcraft.ak.a(F:328)
    MC: at fastcraft.ak.a(F:420)
    MC: at fastcraft.HC.al(F:29)
    MC: at net.minecraft.client.renderer.RenderGlobal.func_147589_a(RenderGlobal.java)
    MC: at net.minecraft.client.renderer.EntityRenderer.func_78471_a(EntityRenderer.java:1224)
    MC: at net.minecraft.client.renderer.EntityRenderer.func_78480_b(EntityRenderer.java:1015)
    MC: at net.minecraft.client.Minecraft.func_71411_J(Minecraft.java:1001)
    MC: at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:898)
    MC: at net.minecraft.client.main.Main.main(SourceFile:148)
    MC: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    MC: at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    MC: at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    MC: at java.lang.reflect.Method.invoke(Unknown Source)
    MC: at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)
    MC: at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

  • DreamMasterXXL: I may have to do something about the situation where Optifine is being used without its shaders stuff enabled. Unfortunately my mod compat code currently doesn't allow any dynamic reconfiguration, so this is tricky.


    Wanghh: The issue is unlikely to be related to FC since it crashes after me calling MC to render the entity the same way as vanilla does itself. Something else is apparently corrupting RenderManager.entityRenderMap.

  • Hmm very interesting mod. A bummer that i am playing on 1.10. On the other hand i have found other mods which also try to improve the performance

  • DreamMasterXXL: I may have to do something about the situation where Optifine is being used without its shaders stuff enabled. Unfortunately my mod compat code currently doesn't allow any dynamic reconfiguration, so this is tricky.


    Wanghh: The issue is unlikely to be related to FC since it crashes after me calling MC to render the entity the same way as vanilla does itself. Something else is apparently corrupting RenderManager.entityRenderMap.


    I can using Fastcradt 1.2.3 and Optifine D6 no worries.

  • As per requirements of FTB custom private modpacks I must notify of my intent to use FastCraft in the modpack I am developing called Ragnarok Galaxy. I accept the current terms set forth in the original post. Modpack is on 1.7.10 minecraft forge 1614.

  • http://files.player.to/fastcraft-1.25.jar should fix the optifine-shaders issue, I can't fully test it with this PC though.

    Oh I forgot to return back to the forum after I posted the crash, I'll test it soon, thank you very much!


    Meanwhile, I'm having this Log Spam when I tried to test something out by creating a flat world. This spam happens every 20 - 30 seconds though.

    I'm just standing still and creating minetweaker scripts, so basically I do nothing in the world and the spam is continuously happening in the log.


    I don't know if this is from fastcraft or not, but I mentioned it because the log says fastcraft on it. I'm sorry if it is not.


    Edit: the new fastcraft works well with optifine shaders. So far now issue, I hope it will stay that way. And no performance issue as well with 410 mods.

    Thank you Player!

  • That's not a FC issue, you just have entities that were saved in the wrong chunk, which isn't being influenced by FC and happens in Vanilla too. See the log line above for the relevant message, the stack traces are useless vanilla spam.

  • That's not a FC issue, you just have entities that were saved in the wrong chunk, which isn't being influenced by FC and happens in Vanilla too. See the log line above for the relevant message, the stack traces are useless vanilla spam.

    Oh is there anyway to identify what entities are causing this? The log didn't say much and this only happens on flat world.

  • sionw: Do you actually use the 1.7.10 version of the pack? The console and logs/latest.log or logs/fml-client-latest.log should have something.


    RumPilot: Did you actually install the Sampler mod? It's in the 2nd spoiler box and separate/independent from Fastcraft.