[WIP|1.7.10] FastCraft 1.25 (Note: All Posts of new Members need to be approved first, so if you press the submit button but no new post appears here, it is in the folder of posts to be approved first, and Player will receive them a few hours later)

  • Player, you have really worked some miracles with this code here. I don't know how you did it but this mod has single-handedly prevented me from having to altogether skip the 1.7.10 generation of mods.

    The chunk loading lag in 1.7.10 was completely unbearable. I basically had to start Minecraft and then alt-tab to another program for 10 minutes. The whole time Minecraft was just frozen solid and filling my log with chunk ticking errors.

    This mod completely solved that issue. Thank you so very much for your effort in making it!

  • Gotta say thanks for this, it has done wonders for my personal pack. I was starting to get disheartened about 1.7.10 as it was just about unplayable with any number of mods causing crazy lag during chunk gen.

    While I still get occasional spikes while generating new chunks, the game feels a TON smoother and removes a ton of frustration.

  • This mod sounds amazing, i am very tempted to install it and test it (although you said you don't want inexperienced users installing it soo... im not sure in which category i fall into). I think i will give it a try at least to see the chunk generation speed and make some stress tests.

    • Official Post

    Just people testing/using it is good, since any of the issues that could arise are more likely to be found the more people that use it. At least that's how I see it.

    145 Mods isn't too many. 9 types of copper and 8 types of tin aren't too many. 3 types of coffee though?

    I know that you believe that you understood what you think I said, but I am not sure you realise that what you read was not what I meant.

    ---- Minecraft Crash Report ----
    // I just don't know what went wrong :(

    I see this too much.

    • Official Post

    By inexperienced users he means modpack users, aka the ones that dont know how to install a single mod on their own.
    If you are able to install forge, IC2, and all those mods without help of 3rd party, you are not inexperienced.

  • ok guess then im very experienced :D i have made packs of more than 100 mods in the past, resolving all the id conflicts and such, tho i still consider myself kinda newb :D

  • Hello ! I install your mod just with forge, a minimap and optifine.
    Does this mod is "affected" by optifine ? (Do I need to remove optifine, or not change the config of it, actually I change the chunk loading thing in it on "smooth").

    BTW thanks for your mod !

  • First at all, amazing piece of code you wrote Player.
    FastCraft is working perfect when starting the server with Forge, but if i use it with Cauldron (170 or lower it doesnt matter) i'm getting a Crash.

    Here's the log.

    Keep up the great work!!

  • As everyone else has said, this is quite a piece of work. Really helped me so far.

    As for the Cauldron issue, is there a way to get this to work on a dedicated server? Most hosts will not allow you to add startup options.

    I maintain the DNS Techpack, found on the AT Launcher. You can find me on Twitter @IAmOmicron or on Discord with the same alias.

  • That's due to some code differences in MCPC, I've added the startup option -Dfastcraft.asm.permissive (has to be before -jar) which disables hook insertion validation, which is fine for the case you had. It requires some extra care in regards of backups and testing however.

    Sadly i'm still getting an error when loading a world.

    This is using


    java -Xmx%mem% -XX:MaxPermSize=256M -Dfastcraft.asm.permissive -jar cauldron-1.7.10-1.1206.01.170-server.jar nogui

    Second Crash File..happened while starting up the server

  • I tried installing this today with Bevo's Tech Pack and for some reason it made things much worse. I normally can get about 10-15 FPS without Optifine. I installed this, and couldn't get over 3 FPS. Am I doing something wrong? Is there a configuration somewhere that I need to tweak?

    Edit: Ok, so it wasn't the mod causing the issues. The server updated and something in the new version of BTP is causing the frame rate issues. I'll track that down first.