Rubber Trees

  • Is there a compatability issue with BiomesOplenty? We can't seem to find ANY trees at all.. I've set the retrogen data to this:

    treeDensityFactor = 1.0
    ; Maximum amount of chunks to check for retrogen viability each tick.
    ; Retrogen is the retroactive generation of terrain features, e.g. ores and trees.
    ; Set it to 0 to disable retrogen.
    ; When enabling this the recommended value is 16
    retrogenCheckLimit = 16
    ; Maximum amount of chunks to process for retrogen each tick.
    ; Values exceeding retrogenCheckLimit are being truncated.
    retrogenUpdateLimit = 2

    It's been a couple weeks and nothing seems to pop up. I even cropped the world using MCEdit down to our spawn to let it regenerate everything outside of that... No Rubber Trees and no errors that I can find....
    This is the most I can find -> [11:40:33] [Server thread/INFO] [FML/]: Found a missing id from the world taiga:molten_cryptogen
    [11:40:33] [Server thread/DEBUG] [FML/]: Fixed minecraft:blocks id mismatch tconstruct:slime_vine_purple: 1924 (init) -> 597 (map).
    [11:40:33] [Server thread/DEBUG] [FML/]: Fixed minecraft:blocks id mismatch quark:stone_basalt_bricks_stairs: 652 (init) -> 1635 (map).
    [11:40:33] [Server thread/DEBUG] [FML/]: Fixed minecraft:blocks id mismatch ic2:rubber_wood: 223 (init) -> 1994 (map).

    [11:40:33] [Server thread/DEBUG] [FML/]: Fixed minecraft:items id mismatch ic2:rubber_wood: 4108 (init) -> 7549 (map).

    Anyone have a clue hey could give me??
    Thank you so much for your time :)

  • I haven't tried using retrogen, but I've seen IC2 rubber trees spawn in BoP worlds using both MC 1.7.10 and MC 1.10.2. Which Minecraft version are you using, and what biomes have you looked in?

    According to the IC2 wiki,


    Rubber trees spawn only inside swamp and forest biomes and cannot be found in other biomes.

    That's a bit out of date, since I have seen them in BoP grasslands biome as well, and possibly a few others, but if you've been looking in biomes like crag, sludgepit, and wasteland, that might be the problem.

    Edit: also make sure you didn't disable rubber tree generation a few lines above. If you did, changing the tree density factor isn't likely to make any difference.

  • Woops! jejej of all the things to forget ;)
    It;s MC 1.10.2 lol latest IC2 on Curse. Yea, the Rubber Tree setting is set to True.
    I thought so too but reading some forums I started getting the impression it was random....

    I'll have to pay more attention to the Biomes.... I can't honestly say I tried remembering where I was.. sorry.

    Thank you so much for your time MauveCloud, you've given me a direction to head in :) hopefully with my 2 boys We'll be able to find something :)

  • Actually, I looked at decompiled code for IC2, and rubber trees can generate in any biome that qualifies as forest, jungle, and/or swamp (BoP grassland counts as swamp). Last I checked, sludgepit counted as both swamp and forest, which would make it an excellent place to look for rubber trees, except that it doesn't appear for me in biome_ids.json, so I'm not sure the 1.10.2 version of BoP includes that biome.

    Edit: I tried looking around a bit in a couple of 1.7.10 BoP worlds (in creative mode) to see if I could find a sludgepit, but didn't have much luck. However, after looking at the wiki description of the Sludgepit, I'm less certain about it being a good place to look for rubber trees in the versions that include it - even if it has a high chance of attempting to spawn a rubber tree, that will presumably fail if the location is already blocked by other leaves.

    Edit #2: I gave myself a biome radar and some biome essence ore, and with some sludgepit essence, I found one, and confirmed that IC2 rubber trees can generate in the sludgepit biome in 1.7.10, but not very many due to the overlapping canopy formed by the trees that BoP generates for that biome.

  • yea... I can't find any rubber trees.... I'm starting to think it may be because of Spongeforge...... That didn't click until just now.....