IC2 crashing Minecraft Server 1.12.2

  • Hello! I'm setting up a server to play with friends, but I have problems with IndustrialCraft 2. I have the following mods installed:

    SecurityCraft+ v1.8.18.2

    BattleTowers-1.12.2

    candyworld.1.1.5

    Carryon+ 1.12.3

    DungeonTactics 0.16.6

    ElectrobobsWizardry-4.2.11

    Hwyla-1.8.26

    industrialcraft-2-2.8.170-ex112

    ironchest 7.0.71.846

    tombstone-3.7.4-1.12.2

    twilightforest-1.12.2-3.10.1013


    The crashreport says that only IC2 is the only one failing to load, but I'm sure you guys are more experts than I am, so i'm leaving you the crash report
    __________________________________________________________________________________________


    ---- Minecraft Crash Report ----

    // Don't be sad, have a hug! <3


    Time: 05/06/20 18:56

    Description: Exception in server tick loop


    net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from IndustrialCraft 2 (ic2)

    Caused by: java.lang.OutOfMemoryError: Java heap space

    at java.util.HashMap.resize(Unknown Source)

    at java.util.HashMap.putVal(Unknown Source)

    at java.util.HashMap.put(Unknown Source)

    at com.google.common.collect.SparseImmutableTable.<init>(SparseImmutableTable.java:76)

    at com.google.common.collect.RegularImmutableTable.forOrderedComponents(RegularImmutableTable.java:169)

    at com.google.common.collect.RegularImmutableTable.forCellsInternal(RegularImmutableTable.java:159)

    at com.google.common.collect.RegularImmutableTable.forCells(RegularImmutableTable.java:131)

    at com.google.common.collect.ImmutableTable$Builder.build(ImmutableTable.java:359)

    at com.google.common.collect.ImmutableTable.copyOf(ImmutableTable.java:221)

    at com.google.common.collect.ImmutableTable.copyOf(ImmutableTable.java:211)

    at net.minecraft.block.state.BlockStateContainer$StateImplementation.func_177235_a(BlockStateContainer.java:281)

    at net.minecraft.block.state.BlockStateContainer.<init>(BlockStateContainer.java:95)

    at net.minecraft.block.state.BlockStateContainer.<init>(BlockStateContainer.java:62)

    at ic2.core.block.state.Ic2BlockState.<init>(Ic2BlockState.java:24)

    at ic2.core.block.BlockTileEntity.func_180661_e(BlockTileEntity.java:254)

    at net.minecraft.block.Block.<init>(Block.java:234)

    at net.minecraft.block.Block.<init>(Block.java:243)

    at ic2.core.block.BlockBase.<init>(BlockBase.java:45)

    at ic2.core.block.BlockBase.<init>(BlockBase.java:37)

    at ic2.core.block.BlockTileEntity.<init>(BlockTileEntity.java:110)

    at ic2.core.block.BlockTileEntity.create(BlockTileEntity.java:102)

    at ic2.core.block.BlockTileEntity.create(BlockTileEntity.java:92)

    at ic2.core.block.TeBlockRegistry.buildBlocks(TeBlockRegistry.java:244)

    at ic2.core.init.BlocksItems.initBlocks(BlocksItems.java:171)

    at ic2.core.init.BlocksItems.init(BlocksItems.java:157)

    at ic2.core.IC2.load(IC2.java:222)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:637)

    at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)



    A detailed walkthrough of the error, its code path and all known details is as follows:

    ---------------------------------------------------------------------------------------


    -- System Details --

    Details:

    Minecraft Version: 1.12.2

    Operating System: Windows 10 (x86) version 10.0

    Java Version: 1.8.0_251, Oracle Corporation

    Java VM Version: Java HotSpot(TM) Client VM (mixed mode), Oracle Corporation

    Memory: 103268688 bytes (98 MB) / 259522560 bytes (247 MB) up to 259522560 bytes (247 MB)

    JVM Flags: 0 total;

    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0

    FML: MCP 9.42 Powered by Forge 14.23.5.2826 15 mods loaded, 15 mods active

    States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored


    | State | ID | Version | Source | Signature |

    |:----- |:-------------- |:----------------- |:--------------------------------------------- |:---------------------------------------- |

    | LCH | minecraft | 1.12.2 | minecraft.jar | None |

    | LCH | mcp | 9.42 | minecraft.jar | None |

    | LCH | FML | 8.0.99.99 | forge-1.12.2-14.23.5.2826-universal.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |

    | LCH | forge | 14.23.5.2826 | forge-1.12.2-14.23.5.2826-universal.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |

    | LCH | securitycraft | v1.8.18.2 | [1.12.2]+SecurityCraft+v1.8.18.2.jar | None |

    | LCH | battletowers | 1.6.5 | BattleTowers-1.12.2.jar | None |

    | LCH | carryon | 1.12.3 | CarryOn+MC1.12.2+v1.12.3.jar | 55e88f24d04398481ae6f1ce76f65fd776f14227 |

    | LCH | dungeontactics | DT-0.16.6 | DungeonTactics-1.12.2-0.16.6.jar | None |

    | LCH | ebwizardry | 4.2.11 | ElectroblobsWizardry-4.2.11-MC1.12.2.jar | None |

    | LCH | waila | 1.8.26 | Hwyla-1.8.26-B41_1.12.2.jar | None |

    | LCE | ic2 | 2.8.170-ex112 | industrialcraft-2-2.8.170-ex112.jar | de041f9f6187debbc77034a344134053277aa3b0 |

    | LC | ironchest | 1.12.2-7.0.67.844 | ironchest-1.12.2-7.0.71.846.jar | None |

    | LC | tombstone | 3.7.4 | tombstone-3.7.4-1.12.2.jar | None |

    | LC | twilightforest | 3.10.1013 | twilightforest-1.12.2-3.10.1013-universal.jar | None |

    | LC | candymod | 1.1.5 | candyworld-1.1.5.jar | None |


    Loaded coremods (and transformers):

    Profiler Position: N/A (disabled)

    Is Modded: Definitely; Server brand changed to 'fml,forge'

    Type: Dedicated Server (map_server.txt)

    ______________

    Any help??


  • Just a wild guess here, but can you launch your server without any mods at all? It seems that you've allocated too little RAM (~250 MB).


    Remove all mods and try vanilla first. See if that works.

    Or try increasing the allocated memory to atleast 1 or 2 GB.

  • Just a wild guess here, but can you launch your server without any mods at all? It seems that you've allocated too little RAM (~250 MB).


    Remove all mods and try vanilla first. See if that works.

    Or try increasing the allocated memory to atleast 1 or 2 GB.

    It works without IC2, and also vanilla, IC2 is the trouble maker. About the RAM, I already gave 2 gigs to the server but the problem was still happening.

  • It works without IC2, and also vanilla, IC2 is the trouble maker. About the RAM, I already gave 2 gigs to the server but the problem was still happening.

    Are you sure you really gave the server 2 gigabytes? You might have intended to, but the log you included indicates it had quite a bit less than that:


    Memory: 103268688 bytes (98 MB) / 259522560 bytes (247 MB) up to 259522560 bytes (247 MB)

    JVM Flags: 0 total;

  • Quote

    Are you sure you really gave the server 2 gigabytes? You might have intended to, but the log you included indicates it had quite a bit less than that

    Didn't he do so after posting the log?