[AddOn v1.23] Energy Coupler v0.21.1 - Convert EUs <-> BuildCraft Energy

  • Very nice mod. Been waiting for this. Only two things it lacks is the ability to turn it on and off with redstone like the advanced machines and the ability to turn Bc energy into EU's so we can link the power systems completely.

  • Ok, I've added the ability to convert BC Energy into EUs when redstone is applied to the coupler. During my testing, I stumbled upon something strange though and I can't tell if it's the coupler or the BuildCraft Wooden power pipes. When you hook a stone engine directly to a coupler, you get almost as much EUs out of coal as you would in a standard IC2 generator, with loss for rounding. But when you move the stone engine away 2 tiles and add a wood and gold power pipe connection to the coupler, you lose something like 42% of the energy generated by the stone engine. Which, to me is a crazy amount of loss. I think it's from the BuildCraft wooden power pipes, but I've included the source so that a fresh set of eyes can check it out.

  • You can't see it behind the wall but there is conductive pipe connected to the bucket filler which then fills lava bucks from the tanks to the geo-generator. Need to still see if it produces more power than needs. At least it's a nice way to get rid of lava...




    Please for the love of god make this a SMP mod :D

  • Everytime I place down one of those Blocks my Minecraft crashes saying Saving Chunks. The Error Message either disappears too fast or doesnt occur at all, thats why i cant post an error log... :cursing:
    List of Mods: BC, IC, EE, Inventory Tweaks, Minefactory, RecipeBook, Technic bridge, Treecapitator, The additional Pipes, The Advanced Mahines, Advanced Solarpanel, The Mobile Pump,

  • Everytime I place down one of those Blocks my Minecraft crashes saying Saving Chunks. The Error Message either disappears too fast or doesnt occur at all, thats why i cant post an error log... :cursing:
    List of Mods: BC, IC, EE, Inventory Tweaks, Minefactory, RecipeBook, Technic bridge, Treecapitator, The additional Pipes, The Advanced Mahines, Advanced Solarpanel, The Mobile Pump,


    Are you using BuildCraft 2.2.2? All the other posts here that have had that problem have been using BuildCraft 2.2.1. You should check that first.

  • Ok, I've added the ability to convert BC Energy into EUs when redstone is applied to the coupler. During my testing, I stumbled upon something strange though and I can't tell if it's the coupler or the BuildCraft Wooden power pipes. When you hook a stone engine directly to a coupler, you get almost as much EUs out of coal as you would in a standard IC2 generator, with loss for rounding. But when you move the stone engine away 2 tiles and add a wood and gold power pipe connection to the coupler, you lose something like 42% of the energy generated by the stone engine. Which, to me is a crazy amount of loss. I think it's from the BuildCraft wooden power pipes, but I've included the source so that a fresh set of eyes can check it out.


    Ok, I misread my previous calculations. It turns out that the ~42% was not loss, but energy gained. I was only getting 42% of the BC Energy a stone engine produces. Which means it's even worse than I thought. I think I may have found the bug in the BuildCraft PowerTransport system though. After patching that temporarily, I was able to get about 91% of the energy a stone engine produces. I still don't know where that loss is coming from though. It seems strange to me that there would be that much loss with only a wooden and stone power pipe between the engine and the coupler. I may try to do some more digging this weekend if I have the time.

  • Hey I am not able to get this to work
    I set up a test just to see if it all worked.
    I have a nuclear reactor hooked to an MSFU which is connect to the HV energy coupler. The coupler has a wooden conductive pipe connect to a quarry but it isn't powering it.
    Did I do something wrong?
    Here is a pic incase my wording isn't great



    Any help would be appreciated
    Thank you,
    Brandon

  • Are you using BuildCraft 2.2.2? All the other posts here that have had that problem have been using BuildCraft 2.2.1. You should check that first.

    Now, everytime I open up my Inventory it crashes :(
    And yes, I now updated to BC 2.2.2

  • Can't wait to try this out. However, it doesn't currently seem to work in SMP. (versions of installed mods are in the 2nd spoiler)


    TIA for your efforts! BC pipes with liquids are so buggy in SMP, I can't wait for oil independence :)


    Let me know if you need help testing/debugging SMP


    Dropping the .zip in the mods folder results in this:


    Putting the .class files in the server .jar ends up with this:

  • SMP support is very relevant to my interests. I've had 2 (BC) power rooms go up in smoke because of weird waterproof pipe mechanics. I would love to run my quarry from my nuclear reactor on my server. I would also be interested in testing if you need someone to help test SMP

  • Works for me (at the moment).


    Attention: LV coupler works. HV (and probably MV too) turns into a LV coupler upon placing, costing you a diamond!


    This probably has to do with it being the same block ID. Does anyone know how to fix this?

  • Works for me (at the moment).


    Attention: LV coupler works. HV (and probably MV too) turns into a LV coupler upon placing, costing you a diamond!


    This probably has to do with it being the same block ID. Does anyone know how to fix this?

    I'll test this when I get back from class. My BC power room went up for the 3rd time (something to do with teleport pipes bugging out and my water platforms quit sending water).

  • Works for me (at the moment).


    Attention: LV coupler works. HV (and probably MV too) turns into a LV coupler upon placing, costing you a diamond!


    This probably has to do with it being the same block ID. Does anyone know how to fix this?


    Works fine here.


    210.0=LV
    .1=MV
    .2=HV


    Although I'm getting some weirdness with the coupler overwriting all of BC's blockids. I think it's the initialize() calls


    Quote

    I'll test this when I get back from class. My BC power room went up for the 3rd time (something to do with teleport pipes bugging out and my water platforms quit sending water).

    I'm sure you're using gold pipes etc etc. There are definitely issues with his forceloader and other BC stuff in the same chunk.



    I'm also getting 1640~ EU from a coal in a pipe connected steam engine, 3932 when directly connected. BC 2.3