[Addon v1.95]Rocket Science v0.89 - flying autominers, missiles, and nuclear fusion!

  • metalearza: I need more information (or preferably a screenshot). Does the laser fire? They do have a small miss chance - I should've been more clear about that in the post. Updating now.

    i guess your right, the laser just missed the thermo nuke missile so thats is why it goes through it, by using 4 laser it never goes through it. sorry for the trouble.

  • Here's the Log. It's too long so I'm afraid I'll have to double post.

    I think IC2 is loading after Rocket Science but I'm sure you'll know that better than me...

    Part 1/2</init></init></init></init></init>

  • Part 2/3

  • I hope you can help me.

    I can't get some of the blocks in Creative and none of the recipes works and neither the blocks or the items are in NEI.

    Thank you!</init></init></init>

  • Thanks for the reply Kensington. I do appreciate it.

    I've dumped my mod loader log here: http://pastebin.com/KmvJtngf

    Examing it, it does appear that Rocket Science is being loaded by mod loader prior to IC2. I don't think I've seen this type of thing before.

    As a note, I'm currently using MultiMC, and on a Mac laptop. My PC recently suffered some sort of BIOS chip explosion and am currently making do.

    I've also created a 'new' mine craft instance with just Modloader/Forge/IC2/Rocket Science and get the same error.

  • Tslavo: Curses, onBlockDestroyedByExplosion is acting up. I'll get on that. (What sort of missile exploded with no force? If it's an incendiary, they explode with strength 1, which isn't enough to break cobblestone, and if the ground is too far below, no fire gets spawned.)

    It was a mock setup of a silo at sea level with the silo doors about 10 or so blocks above and I tested it with both TNT and Napalm but not nuke and it couldnt even blow away the sand walls of the silo or wooden door with either charge.

    As for the other problem, it seems I might have found the issue. I checked my statistics page and found an entry that says "If you have this, it's a glitch" block. Maybe the warhead that fell off glitched into this block and destroying it caused the issue?

    Edit: Obviously not a wooden door, but a block of wood set as a blast door.

    Edit 2: When striking the silo doors, I mean from launch upward and coliding, not coming down upon.

  • Hey there, first post on the forums. I love your addon Kentington, and I was just sitting down to play with the new update in a test world when I ran into a odd bug... I can't interact with the lasers, radar, or the defense coordinator. At all. If I point my cursor at it Minecraft selects the block behind it. I couldn't remove the block with any tool I have even if I wanted to (didn't try explosives but I was trying to keep the bugged out objects there in case you needed more info on it). I just end up breaking the block behind it. They still shoot down incoming missiles though. Well, sort of...

    While writing this post I tested the system by firing 8 rockets at it, targeted about 20 blocks to the left. The system has 6 lasers in it, and it shot down only 6 of the 8 (I assumed this is a power issue, although I launched another 8 with only 3 lasers active and the MFSUs running the lasers resumed charging a few seconds before the rest hit, without another firing). Regardless of the number of missiles that were hit, when it shot them down, I heard it try to play the sound for shooting down a missile 6 times at once, but it failed a fraction of a second in and Minecraft stopped playing all sounds. (This also occurs when using just 3 lasers as well for me, however the majority of the length of the sound is still played.) I also got the following error:

    Exception in thread "Thread-15" java.lang.NullPointerException
    	at paulscode.sound.libraries.LibraryLWJGLOpenAL.loadSound(SourceFile:434)
    	at paulscode.sound.libraries.LibraryLWJGLOpenAL.quickPlay(SourceFile:617)
    	at paulscode.sound.SoundSystem.CommandQuickPlay(SourceFile:1762)
    	at paulscode.sound.SoundSystem.CommandQueue(SourceFile:2250)
    	at paulscode.sound.CommandThread.run(SourceFile:121)

    Additionally I got this message while shutting down Minecraft:

    SoundSystem shutting down...
    Error in class 'SoundSystem'
    	Command thread did not die!
    Ignoring errors... continuing clean-up.

    Restarting Minecraft does not solve any of these issues. The world was a superflat creative world (which I switched in and out of creative mode with NEI). I was able to open the GUI for the defense coordinator once, but I had NEI open at the time so it was all screwed up as others have shown here, but when I went back to actually use the GUI after I was done finishing my test setup it wouldn't let me click it anymore. Toggling NEI off does not help either.

    Info about my MC setup:

  • My Chute isn't opening even if I fall more than 3 Blocks (almost killed me trying to go down my mineshaft). Is someone else having the same problem?

  • :thumbup: :Nano-Leggings:

  • I ran into a little hitch while trying to fully automate the Isotope Extractor with buildcraft and RP2. I have a nice setup where a RP2 Deployer full of buckets grabs water and sends the full buckets to a buildcraft autocraft table to fill water cells with the buckets, and a filter to send them back to the deployer. So long as it has empty cells to work with it fills endlessly. Next I tried to route them to the Isotope Extractor, and after fiddling around with setups I found if I piped it with buildcraft to the top, it would fill the correct spot. So far so good, it starts to run making deuterium cells, and a pipe out the side took the deuterium out and put it in a chest. Then a tried to find a pipe config to take out the empty cells and send them to my filling loop... and then hit a wall. Bottom, Sides, Top, nothing would take out the empty cells. I tried a RP2 filter to grab them, still no luck.

    I was wondering if you could make it so empty cells are taken out the bottom if using buildcraft pipes, or make RP2 machines able to interact with the inventory. If you don't want to work with those APIs, maybe have it dump the empty cells in an adjacent chest. Would love to complete my Deuterium factory.

    Haven't gotten into the missiles yet, but so far love the mod.

  • I was wondering if you could make it so empty cells are taken out the bottom if using buildcraft pipes, or make RP2 machines able to interact with the inventory. If you don't want to work with those APIs, maybe have it dump the empty cells in an adjacent chest. Would love to complete my Deuterium factory.

    In previous versions I had a great deal of luck using Advanced Wooden Pipes from Zeldo/DaStormBringer's Additional Pipe Mod:

    Specifically, if you use the advanced wooden pipe, set it to extract empty cells, it will pull them out regardless of what internal inventory slot they're in.

  • Another bug, crash on booster block being destroyed by a missile. I think Tsalvo reported the same error a page or two ago. If you fire a missile right at an unfired missile it will crash. As I believe Tsalvo described, warheads getting destroyed don't cause a crash but don't destroy the missile booster. On crash a missile is dropped on the ground and a warhead was left undestroyed.

    Here's the crash log:

  • I am new to the whole forum and mod thing so i dont know what the rules and stuff are and I dont know if this has been posted but whenever i place one of the blocks from the addon I.E. The missile defense block my game crashes but i can place the missiles fine please help me i need help i dont know what im doing if anyone can reply to this with REALLY REALLY SPECIFIC instructions that would be awesome

  • Some Bugs:

    1. Missiles dont actually launch when using single player commands and neither do autominers. Not a priority but just a note.
    2. returning missile sprites are bugged. Just sayin.

    BTW Love the missile defense system...although it takes too much energy for just one shot. Are you basing the ratio off of tesla coils? You should just make it more of a superlongrage mining laser energy drain.

    EDIT: Yay 100 posts!

    "A modern tank can speed at 60 mph while shooting a target with pinpoint accuracy from 5 miles away." Civ-5

  • I can't seem to figure out but the parachute pack doesn't work when I fall from high heights. It might have something to do with the config ids for the items is different from the ones in the config file. I used NEI and the item ids in game just don't match up with the config file.

    parachuteArmorID:20007 in the config file and in-game it's 20263
    parachuteItemID:20001 in the config file and in-game it's 20256

    I am on Minecraft 1.2.5
    Got the lastest versions of Modloader and Forge
    got Industrialcraft 1.9.5b
    I am using the 4096 id fix if that helps

    Edit: Also don't know if its related, but when the passenger rocket comes back down from orbit, its texture gets all screwed up looking like a deformed Steve skin.