Support Request: IC2 not working

  • Ok so I installed modloader and all the other required files, then put the IC2 jar into the mods folder then started minecraft. Everything starts up without error but when i make a creative world I see no IC2 items in the inventory and none of the recipes. As further proof of the mod not working I spent 45 minutes searching some huge caverns up and down for IC2 ores and found none. I'm using the latest versions of IC2 and the required files. Also i put inventory tweaks into the mods folder to see if it just wasn't reading it but inv tweaks worked just fine.

  • Hmmm... I think Creative + mods is still dodgy atm. But, just in case, can you get an error report via the batch script launchers that have been laying around?

  • I'm trying to use simple minecraft error test but all I keep getting is "Error: Could not find or load main class (directory)\.minecraft\bin\jinput.jar"

    I've also tried using mo'creatures and millenaire both installed the same way as IC2 and neither worked. All three instances done on clean installs with just the required mods.

  • When in doubt, start from scratch and follow all the directions exactly. If you're not sure what a direction is; check to see if someone else asked about it (and if not /then/ ask your self).

    If it /still/ fails to work and you've tried that properly a few times then it is time to post in detail exactly what environment, tools, and versions of everything you are trying to use.

  • open config folder, in .minecraft there will be a modloader.cfg, open it it notepad/notepad++ and see if it has ic2 enabled

    that fixed it, i completely forgot about that file and the fact that i had turned them off. Thanks! But now there is a new problem sadly...

    It's crashing after the mojang logo and i cant scroll down on the error report. Now I could just spend hours starting from scratch and figuring out where the error lies but I've had to go through this dance numerous times now with every patch and mod update and its really painful. I'd be grateful if somebody told me an alternate method of getting these error logs when it even crashes(wont let me even rightclick) on the logs themselves.

    EDIT: nvm just found out modloader makes logs while i was searching for a config file. One last thing, is there any way to show all the IDs being used in a list instead of having to look at each individual config file? It'd make finding block id conflicts a whole lot easier to sort out.