[Bug][1.337b] Mass Fabricator is acting strange with Zeldo's insertion pipe

  • Alright, here goes: I had a setup with my mass fabricator that would automatically pump scrap into it, through one of Zeldo's insertion pipes, such that when the mass fabricator was full, the next piece of scrap would go through a Redstone pipe and activate a mechanism which, to summarize, would turn on the mass fabricator long enough to use up the full stack of scrap, then turn it off again. With v. 1.23, the device worked perfect, and the MF was only on when there was scrap to burn. Then, I updated to v1.337b, and the MF got fixed so that it worked with Buildraft pipes in a logical way. I had to change my system around a little (connect pipes to the right faces), but the concept was the same. In this new version, the insertion pipe is underneath the MF and the wooden pipe pulling out UU-matter is on the right; the glass fiber cable is coming in from the back, and the redstone signal is from the top (with redpower wires). Sending scrap through the insertion pipe fills up the MF just right, but once there is a full stack of 64 scrap in the MF's lower slot, the next item to go through the insertion pipe vanishes instead of going down the fork to the Redstone pipe. I believe that it is somehow being "overstuffed" into the mass fabricator, but I don't know how that could be possible.


    On a somewhat-related note, does a full MFSU with a redstone current still emit any "overflow" power it recieves? If I could set it up so that the mass fab is running off of my excess power full-time, that would make this strange glitch irrelevant.

  • Strange that you're having trouble with missing scrap, as I have a similar setup, minus the automatic switching on, and have no problems of vanishing scrap. If you continue to feed scrap in, does it all vanish, or is it just the first bunch that completes the 64 stack inside the machine?


    Here's what I've got going on:


  • Aha, I've done it! Found the source of the problem! I discovered that the insertion pipe wasn't even putting the scrap into the MF if there was room for scrap, so after a few minutes of experimenting, I found that the insertion pipe was trying to force scrap into the redstone engine that was pumping out UU-matter! At least, that's what I think was happening; after breaking the engine that was next to the Insertion pipe, it worked like it was supposed to. Strangely, though the RS engine was messing with it, the pipe wasn't "connecting" to the engine, though... Anyway, here's a picture of my failed design. It's fixed now.


    BTW, for anybody that uses Wireless Redstone with buildcraft, be careful, because BC pipes think that redstone transmitters/recievers have a valid inventory for items. >.< Pipes WILL connect to them and screw things up (even though that wasn't the problem in this case)

  • I've also noticed a lot of display problems with items in adv. insertion pipes. Seems to work properly, but many times the item in the pipe looks like it's not there at all, or going out the side of the pipe, or something (SMP).

  • I have noticed (in SMP) that items disappear (visually) from pipes when they cannot be inserted in the first machine in the series. But they still make it to the second, third, fourth and so on.