[Addon v1.118+] [SSP/SMP] Nuclear Control v.1.6.2b/e


  • Time Card, Energy Sensor Kit, Energy Sensor Location Card, Energy Array Location Cards was added in the 1.1.10. You can check change log in the second post of this thread for more details.
    Let me know if you miss something that should be in the 1.1.9b

  • Ah cool, I updated to 1.1.10b and everything appears, the client crashes out of the game when I try and take the information panel or the extender out of the item selection in creator mode, time to poke around some more.

  • I think I captured what you asked for, I suspect it doesn't show anything as it didn't update when the client dropped out with connection lost - end of stream, immediately after I moved an industrial information panel out of the item selection.


    Thanks for the assistance, I know it's hard work guiding the blind through this kinda thing.


  • If you play SMP - double check that you have same version of the addon on both sides and same block/item ids.

  • Spot on, there was a difference with the blockNuclearControlMain being set to 442 on my server and 192 on my client setup, I changed the client to 442 as a test and the problem was resolved.


    Thanks again.

  • Coming across a weird problem, every time I launch minecraft every sound works perfectly except the alarms from this mod, which make no noise at all. If I press F3+S I start hearing the alarm sounds, but I lose my sound pack. =\


    I've tried adding your ic2nuclearControl folder to my sound pack with no luck, & even if I don't use a sound pack & just load the default sounds it still has no alarm sound until I press F3+S...


    Any idea what could cause this?

  • Coming across a weird problem, every time I launch minecraft every sound works perfectly except the alarms from this mod, which make no noise at all. If I press F3+S I start hearing the alarm sounds, but I lose my sound pack. =\


    I've tried adding your ic2nuclearControl folder to my sound pack with no luck, & even if I don't use a sound pack & just load the default sounds it still has no alarm sound until I press F3+S...


    Any idea what could cause this?


    Please specify version of the NC and Forge build. Do you use Control Pack or any alternative sound system, which modifies sd class?

  • I'm using forge build 3.3.8.164, and NC version 1.1.10b. The only sound mod I have is soundpacks v1.3 & nothing that edits sd.class other than forge.


    Thanks for quick response, btw. o.O


    Edit: just tried forge 3.4.9.171 with same result.

  • I'm using forge build 3.3.8.164, and NC version 1.1.10b. The only sound mod I have is soundpacks v1.3 & nothing that edits sd.class other than forge.


    Thanks for quick response, btw. o.O


    Edit: just tried forge 3.4.9.171 with same result.


    As far as I can see in mod_Soundpacks, it unloads all sounds from standard minecraft sound folders and then loads its own sounds.
    It also has an explicit reloading of sounds for moCreatures, probably was the same issue.
    So I see nothing to fix on my side. I can't handle wishes of other mods to unload my sounds =)

  • Alrighty then, I was just confused as to what was causing it, at least now I know. Thanks for your help!


    Edit: I also found this alarm sound online that I've been using and really like. I edited it to fit your loop time a little better, and figured I might as well share it.

  • Heya!
    Thanks for making this great mod!


    I'm running Tekkit, which includes your nice stuff and I tried using the Industrial Information Panel.


    It worked fine in SSP, so I tried using it in SMP, too, but it didn't want to work for me - any idea on how to fix it or is this a known issue?


    cheers!


  • If server is bukkit with multiverse (or other type of multiple world support plugin), then problem is known. Unfortunatelly I am not familiar with bukkit - so I still have no idea how to fix it.
    Otherwise I need more details.

  • I can place the item just fine, turn it, supply it with a redstone current and put a card in and then... it's bright green but there's no information displayed at all. :-|


    I'll make some screenshots, editing it's when done.


    EDIT:
    http://imgur.com/a/Tm2Fk

  • I... have no clue, giving it a shot in a second.


    EDIT: Oh, duh. It was the range. Thanks for helping me out so quickly on this, hope I didn't take too much time out of your day.

  • You know i always come up with interesting ideas. The one i had on recent playing with the reactor planner is kind of a big one tho.


    What, if you could link a Pneumatic Tube from Redpower 2 with a link card and display the amount of items(or in case of IC² most likely Ice) going through a pipe.
    If that don't work, the same idea could also work on Buildcraft.


    I know i know, Eloraam isn't much of a fan of people using her stuff, talk to her maybe you both can come up with something. It would definitely be cool to at one point being able to precisely measure the various Minecraft related Tech Mods and generate precise statistics and controls for very complex machines.


    Sorry that I'm dumping my imagination on you, but it seems to inspire, even just a little bit.

    Intel i7 990X @ 4,60 GHZ, Asus Rampage III Black Edition, 24GB Corsair Dominator GT DDR3,
    2x Zotac Nvidia Geforce 580AMP 1,5gb, OCZ Revodrive 3 X2 240GB 1GBps,
    1TB Western Digital Cavier Black, 2x Hitachi HDS723030BLE640 3TB, 3x BenQ XL2410T LCD-Monitors


    Hosting Minecraft Servers on an Octo Core 32GB Ram Server: http://two66.com/
    Free Space available! If you need a Server let me know!


  • Items count is cool, but it is not even close to the nuclear reactors =)
    Energy storage monitoring at least related to the nuclear energy production.
    As for RP2 integration, I want to integrate with RP computer (via ribbon cable). I PM'ed to Eloraam on minecraftforum with asking for permissions, but still no answer.