Bug: Redstone powered MFE does not output fully when full

  • I got an MFE with an input of 63 EU/t and I have redstone connected to it so that it will only output when full. But when it is then fully charged it only outputs at aprox 42 EU/t, wasting 21 EU/t from my solar panels... I got it connected to a Matter Fabricator so I would think it would output at the 63 EU/t it get in.

  • Then there is only 42 EU\t demanded. Some screenshots or a detailed scheme would help. So far it sounds like "My car rides only 30 MPH, not faster, what's wrong?" - "What car?"

  • It's really simple:
    I have an MFE with: one input at 32 EU/t and another input at 31 EU/t. Then i got a single output cable going into a Mass Fabricator.
    There is nothing more to it...

  • It's really simple:
    I have an MFE with: one input at 32 EU/t and another input at 31 EU/t. Then i got a single output cable going into a Mass Fabricator.
    There is nothing more to it...

    What cable?

  • Replicated with the setup below. I'm not too familiar with the energy net code yet, so I don't immediately have a solution in mind, but I did at least figure out why it was happening.

    • Tick 1: The MFE is full, and sends out a pulse of 128. Receives its 63 EU from the generators. Power level is 599935.
    • Tick 2: The MFE is not full, so does not pulse. Receives 63 EU, power level is 599998.
    • Tick 3: The MFE is not full, so does not pulse. Receives 2 EU (because that's all it demands), power level is 600000.
    • Tick 4: Same as tick 1, the MFE finally pulses again.


  • Replicated with the setup below. I'm not too familiar with the energy net code yet, so I don't immediately have a solution in mind, but I did at least figure out why it was happening.

    • Tick 1: The MFE is full, and sends out a pulse of 128. Receives its 63 EU from the generators. Power level is 599935.
    • Tick 2: The MFE is not full, so does not pulse. Receives 63 EU, power level is 599998.
    • Tick 3: The MFE is not full, so does not pulse. Receives 2 EU (because that's all it demands), power level is 600000.
    • Tick 4: Same as tick 1, the MFE finally pulses again.


    Yeah that is what I think too, but it is hell of anoying xD

  • Okay, what if we apply a tweak like we did for machines, and make a redstone powered storage boxes emit down to storage - output? So a redstoned MFE would output down to 599872. Wouldn't look as pretty, unless we added an invisible 128EU buffer at the top, but it'd allow it to take in full power again.